Jump to content

[SOLVED]GraphicsEnabler isn't working on 10.8 Radeon HD 4890

ati chameleon 10.8 Mountain Lion 4890 Radeon HD not working

  • Please log in to reply
5 replies to this topic

#1
maltba

maltba

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Hey Guys,

need some help with my Mountain Lion Installation.
I have a very smooth running 10.7.3 with GraphicsEnabler=Yes and a custom Personality for dual Monitor Support.

System specs are:

Rampage II Extreme
Intel i7 920
Sapphire Radeon HD 4890 2GB

Current Custom Kexts in 10.8 are:
FakeSMC - some old version don't know if it ever got updated but it works fine in lion
IONetworkingFamily\Yukon2.kext
IOBlockStorage - some patched plist for proper detection of the ICH10R chipset


My problem is that the GraphicsEnabler simply does not inject the card into 10.8. I am not able to get to the login screen with GraphicsEnabler=Yes.
If i boot with GraphicsEnabler=No then OS X is loading some generic NV50HAL driver which only gives me 1440x900 Resolution w/o QE/CL. This behaviour is also different from Lion, where even when GraphicsEnabler=No the right driver is picked but because of the wrong standard personality the dual monitors aren't working.
Does anybody else ran into that problem and might give me a hint what i'm doing wrong?

If you need more information i will be happily answer your questions.



thanks in advance

maltba

#2
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
NV50HAL is a nVidia driver/kext, try deleting it and see what happens

#3
maltba

maltba

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
i don't think that this would work. i've tried this before on lion because this kext was always loaded when i messed up my ati4800Controller.kext, while editing the personalities. when i've tried that on lion it crashed my hole system. maybe someone with a working 4890 on 10.8 could provide me his ATI4800Controller.kext and his ATIRadeonX2000.kext that would be awesome.

thanks in advance. :)

#4
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,823 posts
  • Gender:Male
Hi

you need the QE_CI Exotic patch Mountain Lion GM for hd48xx to get your hd4890 working !!!

#5
maltba

maltba

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
sorry my internet was messed up yesterday evening -.- i tried this though but it doesn't seem to work. Also it seems like i don't even get this ***DEVICE IN SLOT-1*** Message which i usually get on lion before the gui starts up. To me it really looks like chameleon isn't injecting the graphic card correctly. I will try to change the pcie port of the card now because i've changed the port recently to the 2nd one, because the first one had some strange problems. Furthermore i will try to set up vnc on mountain lion and try to vnc into it when its booted up fully with graphicsenabler=yes and post some ioreg stuff. Will report back soon.

#6
maltba

maltba

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Ok guys i fixed it. Just forgot to update the Kernel Caches after I Installed the Kexts from fantomas. -.- Single Display is working now but no dual display but this is a problem with the Motmot Personality which i can fix myself. Many thanks for your help :) A Difference from 10.7 is although definitly that the 4890 isn't wokring anymore without the qe/ci patch. althought this isn't a problem if you know it^^

For everyone reading this thread:
GraphicsEnabler=Yes
fantomas 48xx qe/ci Enabler kexts
!!use cvads kext utility to install the kexts!!

and then everything will run smoothly.

see you
maltba





Also tagged with one or more of these keywords: ati, chameleon, 10.8, Mountain Lion, 4890, Radeon HD, not working


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy