Jump to content

Dell Inspiron 17R Notebook (Inspiron 7720) - Can run Mac OS X


  • Please log in to reply
199 replies to this topic

#101
ACDindia

ACDindia

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
Hi Saranted!
You can delete the NVDA* kexts when booting in safe mode...
Simply navigate to S/L/E and delete all NVDA kexts and also Geforce kext...
U do not need Graphics enabler if u have inserted the right Device id.... Edit the chameleon plist file accordingly... Set GraphicsEnabler=No
Repair permissions..
Reboot.
U shud b able to proceed.

Is there a way we cud get the battery management??
I tried AppleACPIplatform n AppleBatteryManagement kexts which worked fine but had some KPs....
Removed them.

#102
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands
These work for me, no problems so far.

Got them from here: http://www.insanelym...n/#entry1851700

Attached Files



#103
Saranted

Saranted

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
finally i can boot in normal mode thanks for everything
and special thanks for lejenk, i do again the steps that you give me and it works amazing
very thanks for all your support

#104
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands
The 384mb intel Graphics, is after the MB Pro late 2012 update, has nothing to do with the 10.8.2 update, had to reinstall, kept it in mind, and checked where it went wrong, just don't install that update, all is fine.

Btw, anyone noticed the notebook running extremely hot? Primarly the HDD's? When i convert video's, after about 30 minutes, i can not hold the notebook on my lap anymore, around 80 degrees, the HDD's it is. Edit: Error in the DSDT.

Edit: Also just noticed, usb 2.0 sticks are not recognized, 3.0 and other usb devices work, anyone else noticed something similar Reverting IOUSBFamily.kext solves it.

#105
ACDindia

ACDindia

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
I have noticed a thing about my USB, i guess its working as USB 2.0!

I have an external Toshiba 1TB HDD which has an LED indicator. This indicator is illuminated to White light when connected to USB 2.0 and Blue Light when connected to USB 3.0.
On my Windows 8 installation, it shows Blue light when connected and on my Mac it shows white???

#106
ThibaultAnd

ThibaultAnd

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
Hi everyone,

I haven't been here for a while and I'm surprised and very happy that you are progressing very fast on this project ! Congrats !
Since I saw this, I decided to reinstall Mountain Lion and almost everything works (no nVidia :( ) : wifi atheros, sleep,etc... (Thanks to the kext and the DSDT Lejenk posted)

By the way, @Lejenk, I tried your AppleHDA kext + Your DSDT (the DSDT is in the right location) and it didn't work : It seems like that it didn't recognize the audio in system profiler since I got "Intel High Definition Audio : 0"
I had to use VoodooHDA to get the audio working, but it's better to use a patched AppleHDA (besides I have to adjust the volume in the voodooHDA settings...)
Can you figure out what's wrong ? I used your last files and even tried to patch my own AppleHDA... I have the same IDT as you, 111d76e0 (Obvious since we have the same computer :P)

Thanks !

#107
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands
Hi ThibaultAnd,

So it only shows the Intel High Definition Audio?
Attached a screen of my profiler, the BoomDevice is an Audiobooster application called Boom.

Did you remove the VoodooHDA when installing AppleHDA?
And how did you install the AppleHDA?

Attached also my latest DSDT.
Extra included since the previous version:
- Atheros 9285
- Intel HD4000 (No more need for efi string)

Also cleaned up the last warning.

Also, even if we have the same model, hardware can differ :)
If the new files do not work, could you attach the codec.txt here?

I have noticed a thing about my USB, i guess its working as USB 2.0!

I have an external Toshiba 1TB HDD which has an LED indicator. This indicator is illuminated to White light when connected to USB 2.0 and Blue Light when connected to USB 3.0.
On my Windows 8 installation, it shows Blue light when connected and on my Mac it shows white???

Did you install any usb kexts? USB 3.0 should work fine.

Attached Files



#108
ThibaultAnd

ThibaultAnd

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
Hi Lejenk
I found my problem : I think it is Chameleon related because I don't have audio nor graphics (without EFI strings) when I boot with Chameleon (Installed on a USB stick because I have troubles on installing on the hard drive but I will figure it out by myself) but when I boot with the GRUB bootloader (also have Linux), it works (It boot in verbose mode but it is fine)

Anyway, Thanks for every work you did !

#109
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands
You could try Enoch, it has an audio injection module. Could also be some setting in the org.chameleon.boot.plist.
Could you report back if you have solved the problem? :)

#110
ThibaultAnd

ThibaultAnd

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
I tried to install Enoch And it gave me a boot0:error
My OSX partition (installed on a HDD) is active, I also tried Chameleon (or chameleon bootloader based like Chimera or Enoch as you suggested) manually and I get boot0:done then It quits and boot on the SDD :/
Any clues ? :)

Thanks !

#111
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands
Is the /Extra folder present on the HDD?

#112
ACDindia

ACDindia

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
Hey Lejenk!
Thanks for the reply!!

I am not using any IOUSBFamily kext.....

Also, there is another problem, I tried computer sleep by closing the lid.... It went smooth... and instantly woke up when lid was lifted..
everything was working but the Trackpad...
How can I fix this??
I am using Chimera Bootloader.

Thanks in advance! :)

#113
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands
Attached the controller i'm using. Works for me even after sleep. Don't know if it is because of the kext, but it is worth a try.

Any managed to use UEFI boot?
Called Dell today, first i had to do a bios update, well, i have A12, that could not be the problem, then he put me on hold, came back to me simply stating: "It does not work, and i can not help you, wait for a bios update."
Well that was something i figured out already ¬¬

Attached Files



#114
ACDindia

ACDindia

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
I will give that a try n report here.. :)

BTW, about the USB 3 problem.... I have attached a screenshot on my USB device list..
It shows two USB High-Speed Bus (USB 2.0) and one USB Super-Speed Bus (USB 3.0)..
The problem is that there are no Hubs listed under USB Super-Speed Bus... everything I have attached is under the two USB High-Speed Bus..

The 1.0TB external HDD that I had attached with the system is shown as USB 3.0 external drive but works as USB 2.0 as indicated by the LED....

Dunno where I am goin wrong.... ! :wallbash:

Thanks for your continued help!! :D

Screenshot:

Attached File  USB.tiff   1.95MB   14 downloads

Attached Files

  • Attached File  USB.tiff   1.95MB   14 downloads


#115
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands
I don't even have the USB Super-Speed Bus listed. Think it is because i replace the IOUSBFamily.kext.
I've looked at the speeds between my USB 2.0 and USB 3.0 devices, they all work as USB 2.0, will have to look in to it when i have time. No solution at the moment, sorry :)

#116
ACDindia

ACDindia

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
Bro, your ApplePS2Controller works... :) :) thanks!!
my trackpad is working after sleep :) :)

Anyone else trying this, please note: It works if its in S/L/E and doesn't work from Extra (at least for me).

About USB, no problem, we can manage that for the time...... hopefully u will get some time soon...!!! :)

Thanks for the help....

#117
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands
Fix attached. I have set: USB Emulation > Disabled, in bios. (Don't know if this makes a difference)

My USB 2.0 mass storage devices are not recognized, installed the vanilla iousbmasstorage.kext, will revert, hopefully USB 3.0 keeps working like this :D

Attached Files



#118
ACDindia

ACDindia

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
greatt!

But USB 2.0 devices won't work with this Kext??
hmmmm.... thats a hard choice.... only USB 2.0 or Only USB 3.0.....

#119
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands

greatt!

But USB 2.0 devices won't work with this Kext??
hmmmm.... thats a hard choice.... only USB 2.0 or Only USB 3.0.....


They will work if they work now, they do not work for me without the lion iousbfamily.kext, has nothing to do with the kext i just uploaded. :)

#120
ACDindia

ACDindia

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
Bro this did not work...

Also, the USB Super Speed Bus that was shown (although useless) in the System Information is gone.......
This worked for you, so should I have to use the IOUSBFamily that you are using???

I installed your kext in S/L/E...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy