Jump to content

Dell Inspiron 17R Notebook (Inspiron 7720) - Can run Mac OS X


  • Please log in to reply
199 replies to this topic

#61
idpsystem2

idpsystem2

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Hi everybody!

My 7720 arrived today. I tried to install hackintosh even before booting up Windows 8 :)

I ran into QE/CI problem. I have the 3D model and seems that the system cannot recognise its HD4000 video (under System Info - Graphics section). I heard somebody saying that 650m always kicks in for this 3D variant.

Will the DSDT tweak works? Your help is pretty much appreciated!

#62
cynixway

cynixway

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

Hi everybody!

My 7720 arrived today. I tried to install hackintosh even before booting up Windows 8 :)

I ran into QE/CI problem. I have the 3D model and seems that the system cannot recognise its HD4000 video (under System Info - Graphics section). I heard somebody saying that 650m always kicks in for this 3D variant.

Will the DSDT tweak works? Your help is pretty much appreciated!

My PC is 3D edition too.Have you successed?

#63
idpsystem2

idpsystem2

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Still struggling with QE/CI.

I saw bdmesg reported the card correctly as Dell NVidia 650m 2GB RAM. But the system still cannot use it. I hoped to use HD4000 but it simply does not exist at System Info at all.

The system will definitely hang at startup when GeForce.kext is there. If I remove it, it will reports NVDGK100Hal loaded. Apparently the system is up because I saw the harddisk indicator and my wifi adapter running. It remains in the text-based boot screen and seems that the GUI can't be loaded onto the screen. If I further remove NVDGK100Hal.kext, it boots without QE/CI and System Info reported 0MB video RAM and using BIOS rom.

I tried ThibaultAnd's thread's DSDT edited by Rampage Dev and it will show the card with 3GB RAM (?), still no screen with NVDGK100Hal's presence.

Still seeking for hopes from DSDT edit or UEFI boot. I am using Legacy boot right now.

#64
rpriyana

rpriyana

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
you can try contacting Rampage Dev directly. Maybe he can edit your DSDT for you, like in my case.
you need to extract your DSDT, easiest done from a linux boot stick.

#65
idpsystem2

idpsystem2

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Thanks rpriyana. Andrew said that my IOReg don't have any HD4000 registered. He guided me to install different versions of NVidia driver too. I gave up for the time being.

#66
draggix

draggix

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Dell N7110
Core i7 2670 2.2Ghz
4GB Ram
NVIDIA GeForce Go GT525M
Intel HD3000
I'm installing iAtkos L2 Lion
Checked:
bootloader : Chameleon 2.0
bootloader options : Built-in-Ethernet , Cpu Throttler , Original Apple Boot Logo
Patches : FakeSMC , Disabler , RTC , IOPCIFamily
Drivers : AHCI Sata intel , USB , USB 3.0 , MotherBoard Sensors , PS/2
-s
typing -s to enter single user mode.
once on root typing:
mount -uw /
cd /System/Library/Extensions
mkdir IntelBack
mv AppleIntelHD* IntelBack/
mv AppleIntelSNB* IntelBack/
exit

#67
rpriyana

rpriyana

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Hi,

Anyway successfully updated from 10.8 to 10.8.2 using the combo update?

#68
koulis7558

koulis7558

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hi to all, as i see you have succesfully install 10.8 mac os... can someone post the exact steps on how to and the exact files needed so we can install this beloved system to? I have the dell 7720 SE and im trying many nights an days but with no result.... Thanks in advance...

#69
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands
I'm deleting my previous post when i have finished typing this one.
Yesterday i managed to get my audio working bij patching the AppleHDA and DSDT. So in all my excitement i started posting all the files i needed for my system. This included a buggy DSDT and SSDT.

So today i rebuild the DSDT and SSDT, and i must say, i'm pretty satisfied with the result.

What is working at the moment:
- Audio (AppleHDA + DSDT edit) (Speakers/Built-in Mic/Line in/Line out)
- HD4000 Graphics (EFI string)
- Sleep/Wake (SSDT + patched IntelCPUPowerManagement, no need for NullCPUP....kext)
- Touchpad (Only the basic, no extras. Modified ApplePS2Controller)
- FN Keys (DSDT Edit, only the sound keys)
- Masstorage devices (USB keys etc... USB Rollback)
- Wifi (Replaced with an Atheros AR9285, modified IO80211Family)
- Running 10.8.2

Speedstep should work, i have not confirmed this yet, will when i have tested this, if not, well, yet another challenge.

So first of, for the audio, you need to add the following to your DSDT file:
Spoiler

Then install the attached AppleHDA with kexthelper or something, to /System/Library/Extensions.

If the sound chip differs from mine, i have the IDT 92HD91BXX, you can use the following guide to patch your AppleHDA and create the right DSDT entries:
http://www.insanelym...-idt-92hd91bxx/

For the HD4000 graphics to work, you need to add the following lines to your org.chameleon.Boot.plist:
Spoiler

After the edit it should look similar to this:
Spoiler


The sleep/wake, well, i used 2 scripts for this to get this to work. All is described in the following topic:

I attached the SSDT and AppleIntelCPUPowerManagement. Remember to delete the NullCPUPowerManagement.kext and edit your org.chameleon.boot.plist like this:
Spoiler


The touchpad, well enough solutions in this topic, attached the ApplePS2Controller, copy it to Extra/Extensions.

USB Rollback kexts are also attached, install them to /System/Library/Extensions.

Benchmark could be worse: http://browser.prima...kbench2/1542580


EDIT: Had some trouble with the use kernelcache option in the boot.plist, so i modified it and replaced the attachment. Small increase in boot time now.

EDIT2: Added a new AppleHDA, sound dropped completely when moving the slider down, should be fixed now.

Edit3: Been batch processing video conversion for about 24 hours now, cpu load has been 90% all the time, still no performance loss. Laptop runs a little hot, but it's stable.

Posted Image

Attached Files



#70
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands
Can anyone perhaps fix the AppleHDa to support the mic line in?

Tried various kexts for the cardreader, even tried to patch my own, followed some guide for the applestoragedrivers, no succes yet.

If anyone already has a solution for the above, then please post them.

#71
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands
Created a display override to inject some descent info in the about this mac screen.
Posted Image
Attached the override, copy the folder to /System/Library/Display/Overrides.

A guide on how to create your own: http://www.insanelym...splay-problems/

If you don't like the name, open the file inside the folder with text editor, and edit the following:

<key>DisplayProductName</key>
<string>17" LCD Display</string>

PS: 384mb is because of my smbios.plist i'm currently using.

Attached Files



#72
celtic9

celtic9

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Wow, I've been away from the forum for a while and Lejenk makes huge advancements! Thanks for sharing!
I came back to share with Inspiron SE owners a discovery I found: an Elantech driver that make the trackpad works as a trackpad, with gestures and everything!
Here's the link for the Kext: http://www.tonymacx8...er-mac-osx.html

#73
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands

Wow, I've been away from the forum for a while and Lejenk makes huge advancements! Thanks for sharing!
I came back to share with Inspiron SE owners a discovery I found: an Elantech driver that make the trackpad works as a trackpad, with gestures and everything!
Here's the link for the Kext: http://www.tonymacx8...er-mac-osx.html


Restoring some data from within Windows at the moment, made a formatting mistake, don't ask.

Thanks for the compliment and share, will try the Elan fix out as soon as i can.

#74
celtic9

celtic9

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Lejenk,
I have tried your DSDT edit for AppleHDA; somehow I couldn't manage to make it work. It seems your code on this thread is missing some brackets, and I couldn't find this edit inside the file you shared.
Would you mind looking into it?

#75
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands

Lejenk,
I have tried your DSDT edit for AppleHDA; somehow I couldn't manage to make it work. It seems your code on this thread is missing some brackets, and I couldn't find this edit inside the file you shared.
Would you mind looking into it?


The edit can be found on line 7787 in DSDT Editor. Search for HDEF, the search is case-sensitive.

Can you make a codec dump? http://www.insanelym...x/#entry1861876 (5th post)


Also a thing i noticed after reinstalling OSX, i do not need the usb rollback kexts anymore, massstorage seems to work out of the box now for me.
The Elan driver does not work for me.

EDIT: Attached my current DSDT. Not much changes since the previous one. Still have a remark, that i fixed before, screwed up, so lost that dsdt.
Will rebuild the dsdt from scratch, to fix the last errors i can not fix anymore on the current one.

Attached Files



#76
ACDindia

ACDindia

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts
  • Gender:Male
Hi!
Thank you for your efforts friends!



My report:

Running Mac OS X Mountain Lion 10.8.2

SMBIOS has MacBook Pro 10,1 as info

Trackpad works as a pointing device

Keyboard works flawless with the fully functional num-pad


Audio Works, the sub-woofer that came pre-installed doesn't work though (The volume is always reset to full on restart, nothing painful though)
Ethernet isn't working after many tries (Original realtek, lnx2mac, RTL1000SL). I used original Realtek driver n it gets detected but never works!!
NVIDIA does not work! Listed though.



Intel HD Graphics 4000 works! 512MB with 8GB RAM (down to 384 MB after update Posted Image )

I need help with HDMI. There is no Video/Audio out with the HDMI..!!!!! Posted Image
Also, all apps that i install reports me that it has failed installation but ultimately it is installed??? weird???


This even happens on installation of updates. "None of the updates were installed successfully" but they are installed when i restarted???

Any clues on that??


Please help.. i need that HDMI desperately .!!!!!

I have Dell Inspiron 17R SE 7720

Thank you!!!


#77
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands

Hi!
Thank you for your efforts friends!



My report:

Running Mac OS X Mountain Lion 10.8.2

SMBIOS has MacBook Pro 10,1 as info

Trackpad works as a pointing device

Keyboard works flawless with the fully functional num-pad


Audio Works, the sub-woofer that came pre-installed doesn't work though (The volume is always reset to full on restart, nothing painful though)
Ethernet isn't working after many tries (Original realtek, lnx2mac, RTL1000SL). I used original Realtek driver n it gets detected but never works!!
NVIDIA does not work! Listed though.



Intel HD Graphics 4000 works! 512MB with 8GB RAM (down to 384 MB after update Posted Image )

I need help with HDMI. There is no Video/Audio out with the HDMI..!!!!! Posted Image
Also, all apps that i install reports me that it has failed installation but ultimately it is installed??? weird???


This even happens on installation of updates. "None of the updates were installed successfully" but they are installed when i restarted???

Any clues on that??


Please help.. i need that HDMI desperately .!!!!!

I have Dell Inspiron 17R SE 7720

Thank you!!!




I can not help with the HDMI issue, i have no possibility to test this.
For the updating problem, i had the same issue, strangely after re-installing, the problem was gone. I can not replicate the error, only when it comes to software the issue occurs, this is only when the software is outdated.

Hope this helps a bit.

#78
ACDindia

ACDindia

    InsanelyMac Protégé

  • Members
  • PipPip
  • 59 posts
  • Gender:Male
Ok.. no problem!!
You have helped a lot!!! Thankss!!! :)

By the way, I managed to get my Realtek Ethernet card to work.....

Vendor Id: 10ec Device Id: 0x8136
RTL8101E/RTL8102E CI Express Fast Ethernet Controller.

If anyone else is having issues like me, do the following:

Don't know if this has already been described here, but i followed the following steps:

1. Install official Realtek drivers from the website:
http://www.realtek.c...3&GetDown=false

Download:
MacOS 10.7 on Intel-based Mac computer
Install and reboot

2. Go into Settings>Network>Add new connection, select "Ethernet">Advanced settings>Hardware>Do the following settings:
Configure = Manually
Speed = 10baseT/UTP
Duplex = full-duplex
MTU = Standard (1500)
Hit OK>Apply

3. Reboot and you are set!!!

Lejenk, does your Subwoofer work? If so, plz help me get it working!! :) Thanks in advance!



#79
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands


Lejenk, does your Subwoofer work? If so, plz help me get it working!! :) Thanks in advance!



The subwoofer does not work. Only basic audio for the moment. I don't even know where to start to get the subwoofer working, same goes for the line in mic.

And thank you for the tip, works great.
Posted Image
Ioreg added. Can not find any info on injecting the RTL into the dsdt. Well, the devices in the fixes, i can not find them in my dsdt, and don't know where to look. Think RP01, since the Airport (Atheros 9285) is configured there, but i'm not sure.

Made a request: http://www.insanelym...cting-ethernet/

Attached Files



#80
Lejenk

Lejenk

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,381 posts
  • Gender:Male
  • Location:Netherlands
New DSDT, added 2 more patches.

Spoiler


Was worth a try, does not make a difference:
Spoiler


Cleaned up the code a bit, still have not found the missing bracket.

Had issues with downloading programs like Transmission, they froze like every 5 min or so, problem is gone after patching, even when the patches have nothing to do with the Wlan.

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy