Jump to content

Mavericks kernel testing on AMD (formerly Mountain Lion kernel testing on AMD)

Mountain Lion AMD legacy kernel x64_86 ssse3 ssse3 emulator

  • Please log in to reply
6101 replies to this topic

#1641
Tyler Worth

Tyler Worth

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
  • Gender:Male
  • Location:Silverdale, WA

AnV made a new decrypter kext: AppleDecrypt.kext... I'm not sure if Spakk meant this, but you could try. :)
I think it's somewhere in this thread. :D

Okay but If I have a Virtual box on my Laptop and I am trying to install this on my Desktop can I just use my Virtual box to move this file to my Usb Install i am using iAtkos ML on my usb. and I have gotten myself lost after reading and learning so much. im in overload.

@ Deltac0
@Spakk

Okay question is how do I use it if the machine that has the FX core only has windows 7 and 8 and My laptop is win 7 with VB of SL. I use a USB boot of iAtkos, with Sinetek mach_kernel on the root of the usb, also tried with AnV amd_kernel and just renamed it to mach_kernel because I have no idea where the boot.plist is on the iAtkos disk. I tried installing chameloen on it but i dont think it worked. haha. I am a mess. and The Sintex kernel I used is the one http://www.insanelym...80#entry1876715 and AnV kernel here: http://www.insanelym...80#entry1878822


And Just in case the moderators think other wise i am trying to Get ML to work! Thanks )


I would not mind trying the out this beta test.

I just wish one of these kernels would work with my rig. I feel like it should, but I think I am not getting the correct boot flags OR just need a nice Tutorial. once I get min completed and working I will make a tutorial.

#1642
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts
I was not getting the sleep function on Power Button Press, so what I did was used DSDTSE extracted my dsdt and used the power button hack, changed _HID to _CID and rebooted with the dsdt.aml in /Extra , the power button sleep function works after logging in to ML and pressing the power button. But it does not work with my HD 7750 (I have the kexts for it, and I am only testing ) as when I boot up into ML there is the white screen and mouse and everything is working but can do nothing. So I can make to sleep on the white screen but I cannot wake it up.

So I guess the AMD Kernel go round for sleep function can be assigned through the DSDT, I am trying to get the wake up from the white screen so post back again later with the results.

#1643
SS01

SS01

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 265 posts
  • Gender:Male
  • Location:Ottawa
What system definitions are y'all using? Maybe we need to switch to ones of Macs that used nVidia cards.. Like you need Mac Mini for Intel 3000 to work. iMac 13,1 is one I can think of. Just a thought...

#1644
Shaneee

Shaneee

    AMD Dev Tester

  • Local Moderators
  • 1,002 posts
  • Gender:Male
  • Location:Scotland
  • Interests:Web Design. OS X. Music.

What system definitions are y'all using? Maybe we need to switch to ones of Macs that used nVidia cards.. Like you need Mac Mini for Intel 3000 to work. iMac 13,1 is one I can think of. Just a thought...


I've tried all the models with nVidia cards and it made no difference :(

#1645
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts
Wake up works :) can log in also make it sleep :)

#1646
Prosaca

Prosaca

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Hello

Could someone tell me what bootloader are you using for installing it?
Should we use Nawcoms?

Thanks in advance,
Regards.

#1647
instant idiot

instant idiot

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 182 posts
  • Gender:Male
Just about everyone is probably using the Chameleon installers here: http://www.insanelym...aller-binaries/

#1648
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts
Just want to post that software updater does not work, DSDTSE does not extract or compile. When opening a new tab in safari there is a weird behaviour on the new tab (this could probably be due to no QE/CI).

#1649
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts
Reinstalled ML , software update works, not tried DSDT Editor.

#1650
SS01

SS01

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 265 posts
  • Gender:Male
  • Location:Ottawa

Just want to post that software updater does not work, DSDTSE does not extract or compile. When opening a new tab in safari there is a weird behaviour on the new tab (this could probably be due to no QE/CI).

Reinstalled ML , software update works, not tried DSDT Editor.

Hello!
I Tryed to install it on VMware on my Notebook. But it's failed...
CPU: AMD Athlon II P340 Dual-Core processor 2.20GHz.

I ve got this panic,.


Please ask in the help thread.
Thank you.

#1651
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts
It runs very quick and stable. Can not install Xcode , but can install Flash , firefox , chrome and use them, but of course cannot view videos or play flash based videos like youtube due to my HD 7750 . there are certain warnings like kernel_couldn't_symbol ZN8IOMAPPER during boot.

#1652
simc93

simc93

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
First of all thanks to everyone who helped build the kernel.
it runs better than snow leopard and lion, however it takes about 1-2 minutes to boot.
32 and 64 bits apps are working, qe/ci 100% ATI 4670 (graphicsenabler=yes aticonfig=Flicker for screen detection)
The only cons I could notice are that i can't log in iCloud, facetime, messages, Game Center, etc.(known issue on AMD hackintoshes due to the kernel)
I read somewhere that there's a kernel patch that allows atom users to be recognized as genuine Mac users (bla bla bla). That'd be great in amd too (and should be easy to patch)
The other apps that won't even launch are photoshop cs6 , premiere pro cs6, etc (I think it's something related to ssse3 and sse4.1 (AMD Athlon II X4)
my system: ECS A890GXM-A / AMD Athlon II X4 620 / XFX HD4670 DDR2 / 4gb DDR3 1600MHZ
TO WHOM IT MAY CONCERN HOW I INSTALLED ML:
I installed iAtkos ML2 (10.8.2) from snow leopard (can be lion as well) and just replaced amd_kernel (andy's rc3) after the installation was done.
wish it could help
bye

#1653
Prosaca

Prosaca

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

Just about everyone is probably using the Chameleon installers here: http://www.insanelym...aller-binaries/


I'm talking about the install process, not that.

#1654
misterfrista

misterfrista

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Münster
Hey guys!

I tested andy´s kernel and the hardcoded ones for FX Bulldozer on my system with bootflags: -v -f busratio=155 fsb=200 arch=x86_64 npci=0x2000 with and without -force64 (as mentioned by bitlock) on 10.8.2.

Only added kexts: AppleDecrypt, latest FakeSMC and NullPower

Nothing makes any differnce, still reboot after kext load.

#1655
Bitcore

Bitcore

    AMD Fanboy

  • Members
  • PipPipPip
  • 146 posts
  • Gender:Male
  • Location:The Netherlands
  • Interests:Producing Music

Hey guys!

I tested andy´s kernel and the hardcoded ones for FX Bulldozer on my system with bootflags: -v -f busratio=155 fsb=200 arch=x86_64 npci=0x2000 with and without -force64 (as mentioned by bitlock) on 10.8.2.

Only added kexts: AppleDecrypt, latest FakeSMC and NullPower

Nothing makes any differnce, still reboot after kext load.

use this kernel : http://www.insanelym...80#entry1876715
Boot with busratio=155 npci=0x3000 -v
i'm not sure if arch= is required, if you get a reboot try arch=x86_64 (it must be the the first flag)

BitCORE

#1656
Maverick

Maverick

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 230 posts
  • Gender:Male
  • Location:india
  • Interests:Caffeine,Hackintosh,
    AMD hackintosh,
    Technology,
i have this config can i install mountain lion on it
i did try with all amd_kernel but i got instant restart every time..........
Guy's i really need help......................!

CPU : AMD Athlon LE-1640 2.7GHZ
MOBO :Assus M2N8-AM SE2
GPU :Nvidia Geforce 9400GT 1GB
SSD :250 GB
Ram :8 GB

if yes then please provide me kernel and and the kext ............?


Guy's i really need help......................!

#1657
misterfrista

misterfrista

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
  • Location:Münster
Thanks BitCORE :D

At least I don´t get instant reboot, but still cant boot into System. Most likely its the nvidia bug. However 10.8.0 is bootable but 10.8.2 not!

Thanks anyway, I think I have to keep cool and wait for the devs to do their magic :)

#1658
Prosaca

Prosaca

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

use this kernel : http://www.insanelym...80#entry1876715
Boot with busratio=155 npci=0x3000 -v
i'm not sure if arch= is required, if you get a reboot try arch=x86_64 (it must be the the first flag)

BitCORE


Can't download http://speedy.sh/JEwUY/mach-kernel !!

It does ask for premium, wtf? Can someone give me a good link for the kernel, please?
I'm getting instant reboot with the one on the top of thread. AMD FX 8150 here.

#1659
Bitcore

Bitcore

    AMD Fanboy

  • Members
  • PipPipPip
  • 146 posts
  • Gender:Male
  • Location:The Netherlands
  • Interests:Producing Music

Thanks BitCORE :D

At least I don´t get instant reboot, but still cant boot into System. Most likely its the nvidia bug. However 10.8.0 is bootable but 10.8.2 not!

Thanks anyway, I think I have to keep cool and wait for the devs to do their magic :)

You can make it work with 10.8.2 :D
just replace the following kext with the 10.8.0 versions of it :
AppleFileSystemDriver.kext, IOACPIFamily.kext and AppleACPIPlatform.kext
now we need to fix this stupid graphic issues...

Can't download http://speedy.sh/JEwUY/mach-kernel !!

It does ask for premium, wtf? Can someone give me a good link for the kernel, please?
I'm getting instant reboot with the one on the top of thread. AMD FX 8150 here.

Try this link : http://updo.nl/file/84c43a32.zip

i have this config can i install mountain lion on it
i did try with all amd_kernel but i got instant restart every time..........
Guy's i really need help......................!

CPU : AMD Athlon LE-1640 2.7GHZ
MOBO :Assus M2N8-AM SE2
GPU :Nvidia Geforce 9400GT 1GB
SSD :250 GB
Ram :8 GB

if yes then please provide me kernel and and the kext ............?


Guy's i really need help......................!

Dont know anything about your specs, but it might work with this kernel : http://updo.nl/file/84c43a32.zip

Bitcore

#1660
Maverick

Maverick

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 230 posts
  • Gender:Male
  • Location:india
  • Interests:Caffeine,Hackintosh,
    AMD hackintosh,
    Technology,
Thanx for reply Bitcore


Thanks for reply i did try with this kernel but i couldn't stand up the installation
when i use this flag instant get back to the boot cd
" arch=i386 busratio=135 npci=0x3000 -v"
but when i use only "-v -f " it load the bunch of kext but after become hank.................................................. :(
Please help me ....!
if my spec doesn't support 10.8 then please at least give the the working LION kernel..........
Guys please help me.................................!!!!!!!!!!!!!





Also tagged with one or more of these keywords: Mountain Lion, AMD, legacy kernel, x64_86, ssse3, ssse3 emulator


14 user(s) are reading this topic

2 members, 12 guests, 0 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy