Jump to content

Mavericks kernel testing on AMD (formerly Mountain Lion kernel testing on AMD)

Mountain Lion AMD legacy kernel x64_86 ssse3 ssse3 emulator

  • Please log in to reply
6354 replies to this topic

#1601
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 917 posts
  • Gender:Male

Heya, my bad, I got busy. I'm still looking for a job in Germany for this summer. Well, this indicates the opemu is doing something wrong.
When does the KP occur?

-- Sinetek



Yes ! I fix errors opemu for 32 bit and write xnu_src for i386 for lion 10.7.4 , it work with flag arch=i386 , but i get same panic_trap and etc ...
maybe it is problem another ))))

#1602
Deltac0

Deltac0

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 263 posts
  • Gender:Male
  • Location:Finland
  • Interests:Caffeine, OS X, AMD Hackintosh
-

APU is AMD's CPU


May I correct you...

APU = AMD's CPU + GPU combination, just like Intel's i5 and i7.
I think APUs are meant for laptops and cheap desktops, not for power-users.

#1603
Sinetek

Sinetek

    InsanelyMac Sage

  • Coders
  • 333 posts
  • Gender:Male
Ah yeah good point there Bronya, you remind me of something that could be tried.. You know, maybe the nVidia drivers (and ATI too..) work a bit better under x86_32 mode.
Let's dig up the ML DP1 again, see where that goes.


-- Sinetek

#1604
Bitcore

Bitcore

    AMD Fanboy

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:The Netherlands
  • Interests:Producing Music

Ah yeah good point there Bronya, you remind me of something that could be tried.. You know, maybe the nVidia drivers (and ATI too..) work a bit better under x86_32 mode.
Let's dig up the ML DP1 again, see where that goes.


-- Sinetek

Sinetek , could you please tell me why your " AMD test 1" kernel works so good on fx?

Bitcore

#1605
Sinetek

Sinetek

    InsanelyMac Sage

  • Coders
  • 333 posts
  • Gender:Male
Delete /System/Library/Extensions/AppleGraphicsPowerManagement.kext

Sinetek , could you please tell me why your " AMD test 1" kernel works so good on fx?

Bitcore

Not sure, I don't remember what is special about this kernel :/ Not much I think it's like the others. You can try -nossse3bit perhaps or -nosse42bit with AnV's rehash of the kernel?

#1606
Bitcore

Bitcore

    AMD Fanboy

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:The Netherlands
  • Interests:Producing Music

Delete /System/Library/Extensions/AppleGraphicsPowerManagement.kext


Not sure, I don't remember what is special about this kernel :/ Not much I think it's like the others. You can try -nossse3bit perhaps or -nosse42bit with AnV's rehash of the kernel?

too bad ;s nope that doesn't work.
I got anv's kernel working by setting some cpu settings in my BIOS.
So maybe you made it enable some special feature?

Thanks, Bitcore

#1607
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 917 posts
  • Gender:Male

Ah yeah good point there Bronya, you remind me of something that could be tried.. You know, maybe the nVidia drivers (and ATI too..) work a bit better under x86_32 mode.
Let's dig up the ML DP1 again, see where that goes.


-- Sinetek


Yes ! But i have qe/ci ! But in single user one problem - it is no correct keyboard . Maybe no correct xnu with opemu ... One problem - if xnu with emu ssse3 , then no correct work sse3 or sse2 or sse or mmx and etc ...
Therefore to be write correct xnu_src.

--Bronzovka

#1608
Sinetek

Sinetek

    InsanelyMac Sage

  • Coders
  • 333 posts
  • Gender:Male

Yes ! But i have qe/ci ! But in single user one problem - it is no correct keyboard . Maybe no correct xnu with opemu ... One problem - if xnu with emu ssse3 , then no correct work sse3 or sse2 or sse or mmx and etc ...
Therefore to be write correct xnu_src.

--Bronzovka

what GPU? for keyboard you need a kext.
spasiba

#1609
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 917 posts
  • Gender:Male

what GPU? for keyboard you need a kext.
spasiba

No. I have keyboard apple !
If I press the button, the screen shows something else ...
Because without sse4_2 and etc ...
Maybe opemu - it is conflict with sse3 or another ....

#1610
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,944 posts
  • Gender:Male
Hi, Bronzovka!

I just read you got QE/CI with mountain Lion, right? Is it 10.8.2? Which kernel did you use for it? More important yet, which GPU do you use?

About your keyboard issues, can you upload a picture of what's going on when you press the button?

Best regards and welcome on board!

#1611
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 917 posts
  • Gender:Male

Hi, Bronzovka!

I just read you got QE/CI with mountain Lion, right? Is it 10.8.2? Which kernel did you use for it? More important yet, which GPU do you use?

About your keyboard issues, can you upload a picture of what's going on when you press the button?

Best regards and welcome on board!


Hi theconnactic!
Yes ! QE/CI for 10.7.5 and 10.8.2 ! But in 10.8.2 problem maybe GPU , because i no know for GPU. ))))
Soon picture for keyboard ! It is problem on 10.7.4 . One problem - it is no correct xnu ...
I new wrote xnu_src my ! Now work keyboard normal ! But problem it to in gui and panic "panic_trap" ...

#1612
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,894 posts
  • Gender:Male
  • Location:português

Heya, my bad, I got busy. I'm still looking for a job in Germany for this summer. Well, this indicates the opemu is doing something wrong.
When does the KP occur?

-- Sinetek


The problem occurs most frequently when I open programs and tools on such. TextEdit, Disk Utility, sometimes when I opening safari or when I want to open the terminal.

#1613
Tyler Worth

Tyler Worth

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts
  • Gender:Male
  • Location:Silverdale, WA
I used Sinteks kernel on my AMD Fx-8150 and I can install it using "-v -x -f npci=0x2000 PCIRootUID=0" but when I reboot after install it will just reboot. over and over again. not sure what to do I but the same flags for installation when booting but no prevail. :( damn fx processor. Good news it only took 15 minutes to install :P

#1614
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,894 posts
  • Gender:Male
  • Location:português
Hello and welcome bronzovka!!
please, can you upload your modified drivers here?
What Graphic card do you have?

#1615
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 917 posts
  • Gender:Male

Hello and welcome bronzovka!!
please, can you upload your modified drivers here?
What Graphic card do you have?


Hi , spakk !
I have atiradeon 5770 ! Add driver aty_init for this 5770 and work =)

#1616
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,894 posts
  • Gender:Male
  • Location:português

I used Sinteks kernel on my AMD Fx-8150 and I can install it using "-v -x -f npci=0x2000 PCIRootUID=0" but when I reboot after install it will just reboot. over and over again. not sure what to do I but the same flags for installation when booting but no prevail. :( damn fx processor. Good news it only took 15 minutes to install :P



boot only with npci=0x2000 or npci=0x3000 PCIRootUID=0 or 1 -v -f
then look at where the system is hanging.
did you have taken the decrypter, and the patched dylid placed in /usr/lib/ ?
or try with the amd_kernel by Andy and remove FakeSMC and Dont steal ...kext from S/L/E

Hi , spakk !
I have atiradeon 5770 ! Add driver aty_init for this 5770 and work =)


bronzovka, many thanks for your quick response, that does not help me, unfortunately, I have the Nvidia GTX 550 TI with 3 GByte

I used Sinteks kernel on my AMD Fx-8150 and I can install it using "-v -x -f npci=0x2000 PCIRootUID=0" but when I reboot after install it will just reboot. over and over again. not sure what to do I but the same flags for installation when booting but no prevail. :( damn fx processor. Good news it only took 15 minutes to install :P


What kind of Sinetek kernel did you use?

#1617
SS01

SS01

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 265 posts
  • Gender:Male
  • Location:Ottawa
Update: for the moment, chat server went back to irc.osx86.hu

if it doesn't get more stable, i might move us to SystemNet

#1618
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,894 posts
  • Gender:Male
  • Location:português

Update: for the moment, chat server went back to irc.osx86.hu

if it doesn't get more stable, i might move us to SystemNet


chat.osx86.hu: Could not connect!!

#1619
Bitcore

Bitcore

    AMD Fanboy

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:The Netherlands
  • Interests:Producing Music
sinetek , i see you "harcoded the TLC to 18" in AMD test 1 kernel.
How can we set the "TLC" ? and what is it?
Thanks a lot!
Bitcore

#1620
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts
On the first install with -nossse3bit I was not getting any errors, but a fresh install even after -nossse3bit I get a ZN18xxx but the system boots up fine and no issues.





Also tagged with one or more of these keywords: Mountain Lion, AMD, legacy kernel, x64_86, ssse3, ssse3 emulator


4 user(s) are reading this topic

1 members, 3 guests, 0 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy