Jump to content

Mavericks kernel testing on AMD (formerly Mountain Lion kernel testing on AMD)

Mountain Lion AMD legacy kernel x64_86 ssse3 ssse3 emulator

  • Please log in to reply
6379 replies to this topic

#6361
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 986 posts
  • Gender:Male

:)

 

il faut reprendre opemu à zéro ? 

 

must take opemu zero?

I think something needs to be corrected , because it has no effect .



#6362
gils83

gils83

    "y a pas de bug"

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,115 posts
  • Gender:Male
  • Location:France
  • Interests:le soleil du var et l'informatique

:)

 

https://software.int...B9D0D597F4D.htm



#6363
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 986 posts
  • Gender:Male

No not that . I need the programming - but it is a mystery from Sinetek ...



#6364
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 986 posts
  • Gender:Male
Hi. No. You try only in safari!

#6365
Bronya

Bronya

    InsanelyMac Legend

  • Coders
  • 986 posts
  • Gender:Male

 

safari & firefox .... Dead

 

You can compile two XNU for Athlon SSE3 & FX SSSE3
 
Because “Athlon + SSSE3 = glitches with icons”
 
Thank you

 

 

Yes . But I closed ! 
Because I'm working over the problems graphics  !
If i do not find the problem , then I have to close !  


#6366
gils83

gils83

    "y a pas de bug"

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,115 posts
  • Gender:Male
  • Location:France
  • Interests:le soleil du var et l'informatique

:)

 

il est temps de passer aux nouveaux CPU !! :) et mettre mes vieilles plateformes test au placard ou sur ebay ;)

Et grand merci à Bronya pour tout le travail énorme qu'il vient de réaliser :)

 

it's time to switch to the new CPU !! :) And put my old test platforms closet or on ebay   ;)

And thank you to all for Bronya tremendous work he has just completed :)
 
for old platforms Lion 10.7 i386 will do nicely , it would be foolish to put a GTX 780 or HD 7970 on a Athlon x2   :)


#6367
ameris cyning

ameris cyning

    Boycott the apostrophe

  • Donators
  • 1,033 posts
  • Gender:Male
  • Location:My apartment
  • Interests:OSx86, Deutschland, electronic music, Clover EFI

Absolutely perfect.

 

Can confirm it works with an A10 6700



#6368
ameris cyning

ameris cyning

    Boycott the apostrophe

  • Donators
  • 1,033 posts
  • Gender:Male
  • Location:My apartment
  • Interests:OSx86, Deutschland, electronic music, Clover EFI

Just a little update, I am having problems with the timer

 

With the correct bus ratio and a DSDT HPET fix the timer still goes berserk.

 

Clover and Chameleon do it both, so it could be the kernel.



#6369
gils83

gils83

    "y a pas de bug"

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,115 posts
  • Gender:Male
  • Location:France
  • Interests:le soleil du var et l'informatique

Absolutely perfect.

 

Can confirm it works with an A10 6700

 it's CPU SSSE3 ;)


 

The Flash Problem is not in OPEMU
 
Problem is in FlashPlayer
 
 
FlashPlayer 15.0 TEST
 
 
 
 
 
 
I try to replace it with version 11.9 Plug-in
 
replace Path:
/Library/Internet Plug-Ins/Flash Player.plugin/Contents/PlugIns/FlashPlayer-10.6.plugin/Contents/MacOS/FlashPlayer-10.6
 
Get fixes
 
 
 
 
 
 
10.9.5 (opemu-r10 from anv 10.9.2) Safari TEST
 
 
 
 
 
FlashPlayer Bug Fix file

 

 

hello :)

 

works Finalcutprox ? 

Attached Files



#6370
TheShewolf

TheShewolf

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts
  • Gender:Female
  • Location:Mexico
  • Interests:Computers, Music, Art.

Just a little update, I am having problems with the timer

 

With the correct bus ratio and a DSDT HPET fix the timer still goes berserk.

 

Clover and Chameleon do it both, so it could be the kernel.

 

boot with kernel flag -cpuEFI

I have the same issue but that always fixes it for me.



#6371
ameris cyning

ameris cyning

    Boycott the apostrophe

  • Donators
  • 1,033 posts
  • Gender:Male
  • Location:My apartment
  • Interests:OSx86, Deutschland, electronic music, Clover EFI

boot with kernel flag -cpuEFI

I have the same issue but that always fixes it for me.

 

Gracias me amiga



#6372
Duran Keeley

Duran Keeley

    InsanelyMac Sage

  • Local Moderators
  • 471 posts
  • Gender:Male

The Flash Problem is not in OPEMU
 
Problem is in FlashPlayer
 
FlashPlayer 15.0 TEST
 
I try to replace it with version 11.9 Plug-in
 
replace Path:
/Library/Internet Plug-Ins/Flash Player.plugin/Contents/PlugIns/FlashPlayer-10.6.plugin/Contents/MacOS/FlashPlayer-10.6
 
Get fixes

10.9.5 (opemu-r10 from anv 10.9.2) Safari TEST


Nice workaround!

The problem is still in the OPEMU however.

In that replacement, your are replacing Flash with a version that was compiled for an older processor instruction set.
People have been doing this with their flash on Linux that is not compiled with SSE anymore since last year.

#6373
krshadmacattack

krshadmacattack

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
 

Hello, 

 

I want say Bolshoy Speciba to Bronya and S and A  for the awesome amd kernel hack.  BSA 10.9.5 rc1

 

Have been using a Gigabyte A8-5545 APU with 8510 Graphics gpu on Niresh Mavericks distro for almost the entire last year. Currently have 10.9.5. 

 

I use a Chimera/Chameleon bootloader because I formatted my SSD for MBR instead of GUID cuz I was gonna do a Windoz or Ubuntu dual boot, so I use the Chameleon boot plist.  I have to manually use amd as the kernel flag to boot everytime since I named the mach kernel --> amd. It doesn't look for mach kernel it looks for amd, lol. 

 

I have I sound issue with my Logitech speakers Z205 chip but I think it is a sound gain issue. As in it plays on mute instead of the right volume. I think that is something in the sound drivers kext I will have to fix to turn the sound to normal level. 

 

All in all the OS X patched kernel works excellent!

 

Merry Christmas/Holiday Season to everybody.



#6374
granik

granik

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
  • Gender:Male

10.9.5 AMD OPEMU II(Bronya optimised)

10.9.5 AMD OPEMU From 10.8.5 ML FIX

 

I tried these kernels and get the error

 

invalid user opcode 64.......



#6375
DJ PhoeniX

DJ PhoeniX

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male
  • Location:Saint-Petersburg, Russia

I tried these kernels and get the error

Did you placed FakeSMC.kext & NullCPUPowerManagement.kext in /S/L/E?



#6376
oliveiro

oliveiro

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

 

 
10.9.5 AMD Athlon Graphical Glitches FIX
 
OPEMU: from anv-10.9.2-r10
Graphical Glitches FIX : from Sinetek v4
 

 

Hi 虎千代 !

I've been using this kernel you posted in november, and comparing it to "BSA 10 9 5 fx rc1"kernel. Both kernels are really good and stable, no issues. That being said, I don't know whether geekbench and cinebench are relevant tools to test kernels, but I get significant differences between these 2. Yours gets 20% better results than the bsa 10 9 5 fx rc1 when using Geekbench, but Cinebench gives a 20% slower result. (I'd rather use yours since it solves the desktop icons & other graphics glitches)

Anybody has an advice to give ?

Anyway thanks all for the amazing work done on all these kernels.



#6377
oliveiro

oliveiro

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

10.9.5 OPEMU II Rev.2

 

Include diff files

 

further testing 10.9.5 kernels : with this one I got KP during cinebench. slower on geekbench.

 

After series of benchmarks, your first kernel (the one you posted in november) is the best for my setup (see my signature) : geekbench gives a 15% better result, and cinebench gives a 25% better result than BSA10.9.5FXrc1 Kernel. Congrats (!)

 

The only thing I notice is a lot of messages in console related to this one :

 

ImageIO: ConvertBytes vImageConvert_AnyToAny error: 'kvImageInvalidParameter'

 

Safari and my Wallpaper manager spit errors related to imageIO, despite the fact I updated Python & imageIO.

 

I use genuine system.kext & frameworks, might this be a reason ?



#6378
oliveiro

oliveiro

    InsanelyMac Protégé

  • Members
  • Pip
  • 21 posts

10.9.5 OPEMU II Rev.2

 

Include diff files

 

Still using your first 10.9.5 kernel, I get crashes in libsystem_kernel.dylib with Photoshop cc 2014 when trying to use 3d. Do you think this is related to my previous post ?

 

Process:         Adobe Photoshop CC 2014 [48535]

Path:            /Applications/Adobe Photoshop CC 2014/Adobe Photoshop CC 2014.app/Contents/MacOS/Adobe Photoshop CC 2014
Identifier:      com.adobe.Photoshop
Version:         15.2.2 (15.2.2.310)
Code Type:       X86-64 (Native)
Parent Process:  launchd [1046]
Responsible:     Adobe Photoshop CC 2014 [48535]
User ID:         501
 
Date/Time:       2015-01-18 21:41:24.934 +0100
OS Version:      Mac OS X 10.9.5 (13F34)
Report Version:  11
Anonymous UUID:  
 
 
Crashed Thread:  0  Dispatch queue: com.apple.main-thread
 
Exception Type:  EXC_CRASH (SIGABRT)
Exception Codes: 0x0000000000000000, 0x0000000000000000
 
Application Specific Information:
Assertion failed: (!pthread_mutex_lock(&m)), function lock, file ../../source_library/boost_libraries/boost/thread/pthread/recursive_mutex.hpp, line 110.
 
 
Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libsystem_kernel.dylib         0x00007fff823d9866 __pthread_kill + 10
1   libsystem_pthread.dylib       0x00007fff86eb435c pthread_kill + 92
2   libsystem_c.dylib             0x00007fff85693b1a abort + 125
3   libsystem_c.dylib             0x00007fff8565d9bf __assert_rtn + 321
4   com.adobe.Photoshop           0x000000011192e6ca boost::recursive_mutex::lock() + 46
5   com.adobe.Photoshop           0x000000011192e40d boost::unique_lock<boost::recursive_mutex>::lock() + 35
6   com.adobe.Photoshop           0x000000010f15fa66 0x10e262000 + 15719014
7   com.adobe.Photoshop           0x000000010f16e2bd 0x10e262000 + 15778493
8   com.adobe.Photoshop           0x000000010fe46878 0x10e262000 + 29247608
9   com.adobe.Photoshop           0x000000010fe58b09 0x10e262000 + 29321993
10  com.adobe.Photoshop           0x000000010f6051d9 0x10e262000 + 20591065
11  com.adobe.Photoshop           0x000000010f60518e 0x10e262000 + 20590990
12  com.adobe.Photoshop           0x000000010e2e1da6 0x10e262000 + 523686
13  libsystem_c.dylib             0x00007fff856947a1 __cxa_finalize + 177
14  libsystem_c.dylib             0x00007fff85694a4c exit + 22
 
etc...


#6379
lpukraine

lpukraine

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 144 posts
  • Gender:Male
  • Location:Ukraine, Lviv

I don't know why but after installing latest update of Safari via App Store my Hack won't boot anymore. It's simply restart at start of boot after reading kexts.

 

UPD1:

Now I now why it happens.

I also installed Security Update.

New kernel inside!!!

http://www.insanelym...oday/?p=2106248

 

UPD2:

Replacing kernel did't help( System boots with a lot of errors but didn't reach a desktop.

 

UPD3:

Successfully boot system after replacing kexts. - http://www.insanelym...v-kext-for-amd/

System.kext and perhaps IOHIDFamily.kext were modified. 



#6380
TheShewolf

TheShewolf

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts
  • Gender:Female
  • Location:Mexico
  • Interests:Computers, Music, Art.

I don't know why but after installing latest update of Safari via App Store my Hack won't boot anymore. It's simply restart at start of boot after reading kexts.

 

UPD1:

Now I now why it happens.

I also installed Security Update.

New kernel inside!!!

http://www.insanelym...oday/?p=2106248

 

UPD2:

Replacing kernel did't help( System boots with a lot of errors but didn't reach a desktop.

 

UPD3:

Successfully boot system after replacing kexts. - http://www.insanelym...v-kext-for-amd/

System.kext and perhaps IOHIDFamily.kext were modified. 

 

same. I just replaced all the kexts from before the update.







Also tagged with one or more of these keywords: Mountain Lion, AMD, legacy kernel, x64_86, ssse3, ssse3 emulator


7 user(s) are reading this topic

1 members, 6 guests, 0 anonymous users


© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy