Jump to content

Mavericks kernel testing on AMD (formerly Mountain Lion kernel testing on AMD)

Mountain Lion AMD legacy kernel x64_86 ssse3 ssse3 emulator

  • Please log in to reply
6306 replies to this topic

#5421
ADHDMedia

ADHDMedia

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 616 posts
  • Gender:Male
  • Location:Modesto, CA, USA

Welp sorry about that. Did not know where to put it since this is the most active thread about the AMD kernels.

Where should I ask then?


http://www.insanelym...acykernel-(IRC)

#5422
HabDive

HabDive

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

I have a few problems with 2 kernels:

 

1. Kernel number 1

http://www.osx86.net...ricks-1091-amd/

Restart/Shutdown is working

No icon glitches.

But the video in quicktime is running faster than audio. In VLC the video is also running faster, and the audio disapears the 1 second.

 

2. Kernel number 2

http://www.osx86.net...el-nvidia-work/

With this kernel I get prefect video playback, but I also get Icon glitches, and no restart or shutdown working ((

 

As I understand fixing the Icon glitches or restart is more dificult, so can you tell me what solution could solve the playback issue?

Or if you can combine the 2 kernels into a SuperKernel that would combine the working things from those 2 kernels.

 

Thanks ;)

 

PS: my system

AMD Phenom x3 8450

Video ATI HD4830



#5423
mashnoon731

mashnoon731

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Hellow! Just curious..is there any chance of ongoing or future AMD APU ( for me AMD a8 4500m with Redeon 7640g Graphics) developments ? I'd love to see my graphics working otherwise Mavericks works great !



#5424
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts

Installed Mavericks on 

 

AMD FX 6300

 

HD 7750 2 GB

 

 20 x 2 DVI / VGA 

 

USB created with my hack , booted with npci=0x2000 GE=No , installed perfectly , rebooted in to the system again using npci=0x2000 GE=NO and perfect , I have acceleration as X plane 10 works. Installed drivers using ##### Mavericks.  



#5425
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,860 posts
  • Gender:Male
  • Location:português
you're here on the wrong side! Fill in your reports to the appropriate page!!

#5426
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts

you're here on the wrong side! Fill in your reports to the appropriate page!!

 

 

Who is on the wrong side ? is this for me ? 



#5427
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,860 posts
  • Gender:Male
  • Location:português
My working builds!

#5428
ConanHUN

ConanHUN

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts

I tried updating to 10.9.2 but I've got grey screen with a cursor after I rollback the platform and system kext.

I do the rollback in Ubuntu because the OS X won't run after the update. (qemu ud2 error)



#5429
MacGTO

MacGTO

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 154 posts

sorry guys which kernel for PENTIUM 4 640 HT?

i would install mavericks but olso mountian lion is good!!

 

tnx for yours answers



#5430
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,860 posts
  • Gender:Male
  • Location:português

These questions do not belong here and not the accounts of how you have successfully installed your systems. It was repeatedly asked these unnecessary questions and reports to be written in the pages reserved for this purpose!

This page is only for the development

Please read the rules.

Thank you.

Your problems are not cause of the kernel.

Your problems have been discussed several times here on insaneleymac and other OS X Forums and explains how to correct the deficiencies. Once again, this is not the kernel.

#5431
phantomsniper773

phantomsniper773

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

Is anyone else having difficulties with cc/clang? I was trying to install the python package "py-bcrypt" using pip, but it causes a segfault, as does anything else that I try to install that needs to compile. Would this be kernel related, perhaps due to the SSSE3 emulation? It works fine on my Macbook Air.

 

I've tried it with xnu-2422.1.72_by_bronya_sinetek_anv_rc7 as well as with savvamitrofanov:xnu-master and they both have the same issue.

 

Here's what I get:

Stack dump:

0.	Program arguments: /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/clang -cc1 -triple x86_64-apple-macosx10.9.0 -emit-obj -disable-free -disable-llvm-verifier -main-file-name bcrypt.c -mrelocation-model pic -pic-level 2 -mdisable-fp-elim -relaxed-aliasing -masm-verbose -munwind-tables -target-cpu core2 -target-linker-version 236.3 -gdwarf-2 -coverage-file /private/var/folders/1t/jw2xdf1x00l007jkyvlp8csr0000gn/T/pip_build_mihirjoshi/py-bcrypt/build/temp.macosx-10.9-intel-2.7/bcrypt/bcrypt.o -resource-dir /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/../lib/clang/5.1 -D ENABLE_DTRACE -D MACOSX -D NDEBUG -D NDEBUG -D ENABLE_DTRACE -I /System/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7 -Os -Wall -Wstrict-prototypes -Wshorten-64-to-32 -Wall -Wstrict-prototypes -Wno-error=unused-command-line-argument-hard-error-in-future -Wno-error=unused-command-line-argument-hard-error-in-future -fdebug-compilation-dir /private/var/folders/1t/jw2xdf1x00l007jkyvlp8csr0000gn/T/pip_build_mihirjoshi/py-bcrypt -ferror-limit 19 -fmessage-length 0 -fwrapv -stack-protector 1 -mstackrealign -fblocks -fobjc-runtime=macosx-10.9.0 -fencode-extended-block-signature -fno-common -fdiagnostics-show-option -vectorize-loops -vectorize-slp -o build/temp.macosx-10.9-intel-2.7/bcrypt/bcrypt.o -x c bcrypt/bcrypt.c

1.	<eof> parser at end of file

2.	Code generation

3.	Running pass 'Function Pass Manager' on module 'bcrypt/bcrypt.c'.

4.	Running pass 'X86 DAG->DAG Instruction Selection' on function '@encode_base64'

clang: error: unable to execute command: Segmentation fault: 11

clang: error: clang frontend command failed due to signal (use -v to see invocation)

Apple LLVM version 5.1 (clang-503.0.38) (based on LLVM 3.4svn)

Target: x86_64-apple-darwin13.0.0

Thread model: posix

clang: note: diagnostic msg: PLEASE submit a bug report to http://developer.apple.com/bugreporter/ and include the crash backtrace, preprocessed source, and associated run script.

I know this isn't the help forum, but I thought perhaps I could get some insight into whether or not this is a kernel issue, since it seems like it might be.



#5432
sdruid

sdruid

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:Metro Atlanta, Georgia
  • Interests:Reiki Master

Hi, a newbie here...  I'm mostly a PC person but have some or average knowledge of Mac.   I have an AMD based PC with AM3+ processor / Gigabyte motherboard, and installed VIrtualBox to run Mac OSX 10.7 and 10.8 on my machine in the emulator.   First question, can I use the AMD patch to get this done and how do I use the patch to patch OSX 10.8 or 10.7 which I'm trying to install.  I've looked thru the standard installs I've found online and they all say that AMD processors are not supported in running OSX in Virtualbox on a PC (64bit).   I'm running WIndows 7 Pro....  I've looked thru some of the postings here and didn't see any obvious instructions so i decided to post.    Any help would be appreciated or a point in the right direction...

 

thanks



#5433
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,860 posts
  • Gender:Male
  • Location:português

 

have you installed the latest XCode 5.1 Beta 5 Version? or do you use an older version?


Edited by spakk, 19 March 2014 - 07:37 PM.


#5434
phantomsniper773

phantomsniper773

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

Hi spakk, I have version 5.1 (5B130a) which I downloaded directly from the app store. I'm not sure if it's a beta version or not. It's the most up-to-date one in the app store I think. Should I use an older version?



#5435
phantomsniper773

phantomsniper773

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

.........is these the same version ? or newer Version?

 

I think it's the same version

 

Never mind, I had the newer build. I tried downgrading to 5.1 beta 5 but it still didn't work. Downgrading to 5.0.2 and using its command line tools finally worked for me. Still, I'm not sure why the newer version would cause a segmentation fault...



#5436
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,918 posts
  • Gender:Male
Post deleted! There's an appropriate topic for installation/post installation support. Thank you!

#5437
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,918 posts
  • Gender:Male
Where are our sources?! Shame on you, Apple!

#5438
wingshigh.g

wingshigh.g

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
I have a FX 8320 based ESXi 5.5. For Mavericks. I installed the BSA_kernel and got it working. However I have to have all 8 cores assigned to this virtual machine otherwise it will throw a kernel panic. I also have a Lion VM and it was fine with 4 cores.

Does anyone have the same experience or has solution to use only four cores on Mavericks in VM?

#5439
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,918 posts
  • Gender:Male

Try the flag CPUS=4. Good luck!



#5440
Andy Vandijck

Andy Vandijck

    InsanelyMac Deity

  • Coders
  • 1,625 posts
  • Gender:Male
  • Location:Tienen
  • Interests:Programming stuff for Mac OS X...
    Hacking...
    Hard rock (also really big Metallica...

Where are our sources?! Shame on you, Apple!

Yeah, we wait and we wait.

Also had another bad episode with Apple.

I used to be able to use my developer account (paid with bank transfer).

As of this year bank transfer is no longer an option (only {censored} credit card) so the 2nd of April it will be done developping for Apple...

I'm really angry at Apple for doing this...

Where's Steve? Damn you, why leave Timmy in charge ... ugh ...







Also tagged with one or more of these keywords: Mountain Lion, AMD, legacy kernel, x64_86, ssse3, ssse3 emulator


6 user(s) are reading this topic

2 members, 4 guests, 0 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy