Jump to content

Mavericks kernel testing on AMD (formerly Mountain Lion kernel testing on AMD)

Mountain Lion AMD legacy kernel x64_86 ssse3 ssse3 emulator

  • Please log in to reply
6224 replies to this topic

#501
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,819 posts
  • Gender:Male
  • Location:português

I have it, but is it really just empty file?
All I got was 0 bytes of... Well, nothing.
The name was right... :D

wait a moment, please

#502
Deltac0

Deltac0

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 263 posts
  • Gender:Male
  • Location:Finland
  • Interests:Caffeine, OS X, AMD Hackintosh

wait a moment, please

I will wait :)

By the way, LaunchDaemon (launchd) is open-source and licensed under Apache 2 license, so it's totally legal to upload it ;)
No need to delete it, other users may need it too.

#503
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,819 posts
  • Gender:Male
  • Location:português
here is a nice tool http://www.macupdate...launchd-editor/

http://www.codepoetr...s/launchdeditor

#504
Deltac0

Deltac0

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 263 posts
  • Gender:Male
  • Location:Finland
  • Interests:Caffeine, OS X, AMD Hackintosh

here is a nice tool http://www.macupdate...launchd-editor/


I already found that, but it just uses the launchd, which doesn't work :D
I need a working launchd from Lion :)


EDIT: I will install Lion to my own computer, this way I can easily try kexts from SL / Lion :)

#505
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,819 posts
  • Gender:Male
  • Location:português

I already found that, but it just uses the launchd, which doesn't work :D
I need a working launchd from Lion :)


EDIT: I will install Lion to my own computer, this way I can easily try kexts from SL / Lion :)

I have to remove my hard drive from my AMD PC, is a little complicated, wait a instant yet

here are no cost routes and spared to arrive at a positive conclusion :moil:

at the moment I can only help with 10.6.8 and 10.8. Launched file, the Lion 10.7.4 is zero byte big, no idea why?

what to do now? or Gils, can you load your Launched-file from your current LION up here, please

#506
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,819 posts
  • Gender:Male
  • Location:português
1. have tried to install launched editor on mountain lion, it does not work

2. what can be the reason that my Launched Zero byte has? although the system will boot normally

#507
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,819 posts
  • Gender:Male
  • Location:português

you looked at the file I have half of my post ?


Danke Gils

Gils, he means the Launched-file

It's located in:

/sbin/launchd

see #497

:help: has theconnatic leaving the sinking ship? :help: :jester:

I haven't seen him for long time here

#508
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,819 posts
  • Gender:Male
  • Location:português

ah! forgiveness! I did not quite follow I used google translation! :king:

I am sending you this now.


where is Deltac0, he need the file

#509
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,819 posts
  • Gender:Male
  • Location:português

et voici !!

http://www.envoyerce...1353268167.html


I've put the file sbin file (hidden)

thanks Gils, you are the best :thumbsup_anim: now can Deltac0 boot lion

#510
Deltac0

Deltac0

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 263 posts
  • Gender:Male
  • Location:Finland
  • Interests:Caffeine, OS X, AMD Hackintosh
Hi! Thanks Gils for the file! :) Will try it now! :)

EDIT:

NEW PANIC! FINALLY! :)
I mean, we solved the launchd problem! :)

Gils, could upload the whole kexts folder from Lion?
I know it's a huge folder, but those kexts should work with the kernel. :)

The panic is @ attachments.




EDIT2: xD, my mistake... I had my USB drive connected.... :/ Now booting without it, hopefully not another launchd panic...


EDIT3: SAME PANIC......... This is getting ridiculous... The version of the file doesn't matter... It just doesn't work. Tried with 10.8 DP1, 10.7.5, 10.6.8 launchd, NO DIFFERENCE, always ERROR 86.
I will now look at the kernel source, what is this error 86...

Attached Files



#511
instant idiot

instant idiot

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 182 posts
  • Gender:Male
Just a moment, I'll try uploading my 10.7.5 /System/Library/Extentions/... Shall I upload launchd too?

#512
instant idiot

instant idiot

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 182 posts
  • Gender:Male
http://bayfiles.com/.../HbPt4h/SLE.zip

#513
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,819 posts
  • Gender:Male
  • Location:português

Hi! Thanks Gils for the file! :) Will try it now! :)

EDIT:

NEW PANIC! FINALLY! :)
I mean, we solved the launchd problem! :)

Gils, could upload the whole kexts folder from Lion?
I know it's a huge folder, but those kexts should work with the kernel. :)

The panic is @ attachments.




EDIT2: xD, my mistake... I had my USB drive connected.... :/ Now booting without it, hopefully not another launchd panic...


EDIT3: SAME PANIC......... This is getting ridiculous... The version of the file doesn't matter... It just doesn't work. Tried with 10.8 DP1, 10.7.5, 10.6.8 launchd, NO DIFFERENCE, always ERROR 86.
I will now look at the kernel source, what is this error 86...


We urgently need to look for the cause of the error Launched 86 , Request for feedback please

#514
Shaneee

Shaneee

    AMD Dev Tester

  • Local Moderators
  • 1,002 posts
  • Gender:Male
  • Location:Scotland
  • Interests:Web Design. OS X. Music.
I am getting the launchd errno 86 now aswell. The install starts loading as lion does then KP's. From what I found its something to do with drivers not being mounted. I have tried the launchd file from 10.8 DP1 and my 10.7.4 installation.

EDIT:
System froze instead of kp.
Booted using,

-legacy arch=i386 -force64 -v npci=0x2000

It freezes at BSD root: disk2s2, major 14, minor 11

On Lion right after that line is launchd loading...

Is this classed as progress or another brick wall?

#515
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,894 posts
  • Gender:Male
Watching closely this thread, at least twice a day. I didn't abandon the boat, my friends.

Very interested to see if you guys can succeed in booting ML DP1. That would be an enormous step!

Gilles, glad to see you here at last! :)

#516
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,819 posts
  • Gender:Male
  • Location:português

I am getting the launchd errno 86 now aswell. The install starts loading as lion does then KP's. From what I found its something to do with drivers not being mounted. I have tried the launchd file from 10.8 DP1 and my 10.7.4 installation.

EDIT:
System froze instead of kp.
Booted using,

-legacy arch=i386 -force64 -v npci=0x2000

It freezes at BSD root: disk2s2, major 14, minor 11

On Lion right after that line is launchd loading...

Is this classed as progress or another brick wall?



Please boot with boot flag:
-v busratio=20 arch=i386 -force64 maxmem=4096 npci=0x2000

#517
Deltac0

Deltac0

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 263 posts
  • Gender:Male
  • Location:Finland
  • Interests:Caffeine, OS X, AMD Hackintosh
Hi!

I'm a little busy at this moment, but when I'm back home (about 6½h), I'll look the launchd source and find out the error 86!

Lion 10.7.4: http://www.opensourc...launchd-392.38/
Mountain Lion 10.8.0: http://www.opensourc...launchd-442.21/

EDIT: I FOUND IT!

/usr/lib/sys/errno.h says this:

#define EBADARCH 86 /* Bad CPU type in executable */

Have fun investigating more, I gotta go now... :)

#518
Shaneee

Shaneee

    AMD Dev Tester

  • Local Moderators
  • 1,002 posts
  • Gender:Male
  • Location:Scotland
  • Interests:Web Design. OS X. Music.

Please boot with boot flag:
-v busratio=20 arch=i386 -force64 maxmem=4096 npci=0x2000


Didn't help. Still pauses before launchd loads.
Will take a look at the launchd source and see if there is anything I can do.

#519
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,819 posts
  • Gender:Male
  • Location:português

I am getting the launchd errno 86 now aswell. The install starts loading as lion does then KP's. From what I found its something to do with drivers not being mounted. I have tried the launchd file from 10.8 DP1 and my 10.7.4 installation.

EDIT:
System froze instead of kp.
Booted using,

-legacy arch=i386 -force64 -v npci=0x2000

It freezes at BSD root: disk2s2, major 14, minor 11

On Lion right after that line is launchd loading...

Is this classed as progress or another brick wall?


nice to see you, :wink2:

Hi!

I'm a little busy at this moment, but when I'm back home (about 6½h), I'll look the launchd source and find out the error 86!

Lion 10.7.4: http://www.opensourc...launchd-392.38/
Mountain Lion 10.8.0: http://www.opensourc...launchd-442.21/

EDIT: I FOUND IT!

/usr/lib/sys/errno.h says this:

#define EBADARCH 86 /* Bad CPU type in executable */

Have fun investigating more, I gotta go now... :)

Great work, Deltac0 :wink2:

#520
Deltac0

Deltac0

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 263 posts
  • Gender:Male
  • Location:Finland
  • Interests:Caffeine, OS X, AMD Hackintosh

Great work, Deltac0 :wink2:


Thanks! I'm back @ home now, time to start experimenting with some AMD patching ;)

EDIT: Don't know what is the problem with launchd... The error 86 is Bad CPU type, but the launchd runs fine when ran from SL.
The problem means that the launchd is x86_64... Don't understand, when I do "file launchd" it says that it IS universal PPC / i386 / x86_64...


I will now install Lion on my Phenom II machine (32-bit), then I will modify the XCode 4.2 for SL to run on Lion 32-bit.
Then I'll compile a new launchd with ARCHS="i386" option, it should work... But I just don't understand why it doesn't work with the universal binary.





Also tagged with one or more of these keywords: Mountain Lion, AMD, legacy kernel, x64_86, ssse3, ssse3 emulator


3 user(s) are reading this topic

1 members, 2 guests, 0 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy