Jump to content

Mavericks kernel testing on AMD (formerly Mountain Lion kernel testing on AMD)

Mountain Lion AMD legacy kernel x64_86 ssse3 ssse3 emulator

  • Please log in to reply
6369 replies to this topic

#241
PookyMacMan

PookyMacMan

    InsanelyMac Legend

  • Moderators
  • 1,464 posts
  • Gender:Male
  • Location:Earth–Western Hemisphere, specifically
  • Interests:Computer science, engineering, trumpet performance, and a host of others. :D
spakk, please read what I wrote in the edit box for your post. Also, I think something strange happened with the first code box...you should probably repaste org.chameleon.boot.plist unless it's just my computer acting up. Sorry about that. :(

#242
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Local Moderators
  • 1,967 posts
  • Gender:Male
  • Location:marocain

spakk, please read what I wrote in the edit box for your post. Also, I think something strange happened with the first code box...you should probably repaste org.chameleon.boot.plist unless it's just my computer acting up. Sorry about that. :(


sorry, can you explain that to me with an example, please

#243
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,172 posts
  • Gender:Male
hi AMD users :)

had any one succeeded to boot on raid mode without panic ?
and is there solution for still waiting for root on ACHI mode (kernel solution) ?

on my system i work under 10.6.8 and IDE mode with atiata.kext

#244
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Local Moderators
  • 1,967 posts
  • Gender:Male
  • Location:marocain

Intel Core i3-2350m with vanilla kernel.


Mountain Lion is running on my Samsung RV509 Pentium Dual Core P6200 - 2.13 GHz very stable

http://www.microchoi...__Free_Dos.html

hi AMD users :)

had any one succeeded to boot on raid mode without panic ?
and is there solution for still waiting for root on ACHI mode (kernel solution) ?

on my system i work under 10.6.8 and IDE mode with atiata.kext


disable in the BIOS the FireWire

Mountain Lion is running on my Samsung RV509 Pentium Dual Core P6200 - 2.13 GHz very stable

http://www.microchoi...__Free_Dos.html



disable in the BIOS the FireWire

here is a good guide to install Snow Leopard, unfortunately in German http://www.root86.or...etail-Tutorial-

Hi Mohamed Khairy



HFS HDD for Snow Leopard must be placed in the first place, it should be otherwise, then turn off the computer and put the SATA cable to the correct position. The other HDD's need to be placed on the other positions, otherwise, an error message occurs when booting -> AppleUSBOHCI ... still waiting for root device.l

#245
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,172 posts
  • Gender:Male
my MB doesnt contain firewire

#246
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Local Moderators
  • 1,967 posts
  • Gender:Male
  • Location:marocain

my MB doesnt contain firewire


here is a good guide for M5A97pro socket AM3 + / Phenom x4 960 of gils, unfortunately in French

http://www.hack-my-m...s-l2-sur-pc-amd

good luck

my MB doesnt contain firewire


ON Board 1394 Function [Disabled]

#247
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male

Intel Core i3-2350m with vanilla kernel.


On my Intel, the lack of corecrypto does not matter at all. Or else i forgot to rebuild the cache... hm, going to test it again: we must know how crucial corecrypto is. Because if it isn't, as i suspect, the problem is perhaps the same AMD users have since Leopard days when trying to boot with arch=x86_64: the lack of ssse3 instructions. That's why we need a Bulldozer - or Bobcat, or Trinity - to check this out.

#248
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,172 posts
  • Gender:Male

here is a good guide for M5A97pro socket AM3 + / Phenom x4 960 of gils, unfortunately in French

http://www.hack-my-m...s-l2-sur-pc-amd

good luck



ON Board 1394 Function [Disabled]


didnt tried iatkos L2 as i stopped to use hacked retail dvd
so i only setup retail

i already tried retail lion 10.7.3 setup on my pc but there is panic
so i just fine with retail setup 10.6.8
-------
yes my motherboard doesnt contain firewire (1394)
-------
again does your pc boot on sata set to raid mode ? with out painic ?

#249
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,172 posts
  • Gender:Male
i will setup lion an mountain lion on my PC when there is ssse3 Emulator done :) :D

#250
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male

didnt tried iatkos L2 as i stopped to use hacked retail dvd
so i only setup retail

i already tried retail lion 10.7.3 setup on my pc but there is panic
so i just fine with retail setup 10.6.8
-------
yes my motherboard doesnt contain firewire (1394)
-------
again does your pc boot on sata set to raid mode ? with out painic ?


Mohamed, we usually set our SATA mode to RAID when we haven't AHCI as an option, since RAID implies AHCI. This workaround has been successfully used in a plethora of old motherboards. I confess i didn't read carefully your posts though: do you want to use RAID as a workaround for AHCI, or do you really want to use RAID for what it is/does?

#251
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,172 posts
  • Gender:Male

Mohamed, we usually set our SATA mode to RAID when we haven't AHCI as an option, since RAID implies AHCI. This workaround has been successfully used in a plethora of old motherboards. I confess i didn't read carefully your posts though: do you want to use RAID as a workaround for AHCI, or do you really want to use RAID for what it is/does?


i have two hard disks 500 gb on raid mode for windows and data
and 640 HDD single for osx and ubuntu and storage

-----
so when using windows must be on raid mode

but raid mode give me panic under osx :(
so must change to ACHI or ide to by pass this panic
to me achi mode some times boots and some times still waiting for root
so the stable mode is ice mode using appleatiata.kext ported to snowleopard by andyvand :)
but this kext may some time rarely stop from working during using osx

-------

so my question is raid mode on yours pc does this panic ?
will picture it now and upload it :)

#252
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male
P.S.: Mohamed, we have a channel for AMD Hackint0shing discussion on irc.osx86.hu: join us at #LegacyKernel!

#253
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,172 posts
  • Gender:Male
ok no problem

what is the program you use for irc as it is long time from using this chat when there is a development on chameleon for AMD by valv
edit entered chat room only two is on line !!

any way this is my panic with raid mode
Posted Image

#254
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Local Moderators
  • 1,967 posts
  • Gender:Male
  • Location:marocain
Mohamed here we treat only Mountain Lion AMD kernel, please

delete AppleIntelCPUPowerManagement.kext from S / L / E
maybe your system will boot

Mohamed here we treat only Mountain Lion AMD kernel, please

delete AppleIntelCPUPowerManagement.kext from S / L / E
maybe your system will boot

than start with boot flag -s



#255
Mohamed Khairy

Mohamed Khairy

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 2,172 posts
  • Gender:Male

Mohamed here we treat only Mountain Lion AMD kernel, please

delete AppleIntelCPUPowerManagement.kext from S / L / E
maybe your system will boot

ooops forget to sorry about off topic :(
appleintelcpupowermanagment is black listed by kernel so it isn't the cause
as i remeber from long time about 3 years nearly on 10.5 the raid mode was working for me on m4a78t-e motherboard
and tried to jump to 10.6 was having panic and confused about cause till discovered that the cause is raid mode

so question again is raid mode works for yours ?

#256
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Local Moderators
  • 1,967 posts
  • Gender:Male
  • Location:marocain
Hi, I have a massive problem, I use ML 10.8.0 and I want to update to 10.8.1 and finally 10.8.2.

the install, I get the following error message;

OS X update can not be installed on this drive. This volume does not meet the prerequisites for this update

What can I do? to solve that problem?

could it possibly be the problem when booting the modified AMD ML kernel??

Hi, I have a massive problem, „!“ I use ML 10.8.0 and I want to update to 10.8.1 and finally 10.8.2.

the install, I get the following error message;

"OS X Update can't be installed on this disk. This volume does not meet the requirements for this update"

What can I do? to solve that problem?

could it possibly be the problem when booting the modified Mountain Lion AMD kernel??

#257
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Local Moderators
  • 1,967 posts
  • Gender:Male
  • Location:marocain
I will install the combo update with Pacifist and hope that it will work.

#258
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male
My friends, take a look at this link: http://ftp.leg.uct.a...hitecture.cmake

Please do a search in it with the keywords "ssse3" and "emulated".

Post here your impressions, let me know if they match mine.

#259
SS01

SS01

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 265 posts
  • Gender:Male
  • Location:Ottawa
spakk, you probably shouldn't do that, the connactic kernel is only for 10.8.0

you ninja'd me, theconnactic. And wow... if that's what I think it is, our job just got a whole lot easier. What's that source from?

#260
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male
Looks like some kind of public server, which i found accidentally when searching for instructions emulation-related content. Let's explore it? I strongly suggest you all to download this page, store in the reading list etc, nothing guarantees that this server won't be closed anytime soon. Lets take this possible opportunity!





Also tagged with one or more of these keywords: Mountain Lion, AMD, legacy kernel, x64_86, ssse3, ssse3 emulator


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy