Jump to content

Applegraphicspowermanagement.kext not loading


  • Please log in to reply
35 replies to this topic

#21
X-TRiAL

X-TRiAL

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
  • Gender:Male
  • Location:UK
Thanks, I tried this, but it didn't work for me.

In -v all I got was this "nspace-handler-set-snapshot-time: 1343775763" which is the last thing to load on a normal boot, but it just freezes when I enable the switchable graphics in the BIOS.

#22
HUSABER

HUSABER

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 964 posts
  • Gender:Male
  • Location:Cyprus
  • Interests:Motocross-HusabergFC-600 FourStroke,KTM500 TwoStroke,TM300 TwoStroke
    Free Time-My Hackint...
dont try only -v,try another command -s,-f or press only enter..
you have GraphicsEnabler=Yes in smbios.plist?

#23
X-TRiAL

X-TRiAL

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
  • Gender:Male
  • Location:UK
When I use GraphicsEnabler=Yes in Chameleon it loads my DSDT and then shows my card "Nvidia GeForce GT 540M" and the PCI Root ID and then freezes.
I can boot with -x but I could do that before your files were installed.

Will try with -f, -s and enter.

#24
HUSABER

HUSABER

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 964 posts
  • Gender:Male
  • Location:Cyprus
  • Interests:Motocross-HusabergFC-600 FourStroke,KTM500 TwoStroke,TM300 TwoStroke
    Free Time-My Hackint...
upload your boot.plist,and smbios.plist here

#25
X-TRiAL

X-TRiAL

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
  • Gender:Male
  • Location:UK
All didn't work for me :/

I have uploaded my DSDT too... Attached File  Archive.zip   19.73KB   4 downloads

#26
X-TRiAL

X-TRiAL

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
  • Gender:Male
  • Location:UK
What you saying?

#27
HUSABER

HUSABER

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 964 posts
  • Gender:Male
  • Location:Cyprus
  • Interests:Motocross-HusabergFC-600 FourStroke,KTM500 TwoStroke,TM300 TwoStroke
    Free Time-My Hackint...
Put inside Extra (No zip...unziped 3 file)
Your DSDT have 1 Error but is fixed totaly

Attached Files



#28
X-TRiAL

X-TRiAL

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
  • Gender:Male
  • Location:UK
Sorry, none of this worked for me.

I used your new files and now I can't boot.

GraphicsEnabler=Yes, freezes and doesn't load any kexts, so I don't think this will be a solution.
When using GraphicsEnabler=No, I just get Kernel Panic with your files.
I have also tried -f -s and enter, and I cannot start up.

Regards

#29
HUSABER

HUSABER

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 964 posts
  • Gender:Male
  • Location:Cyprus
  • Interests:Motocross-HusabergFC-600 FourStroke,KTM500 TwoStroke,TM300 TwoStroke
    Free Time-My Hackint...
Change bootloader....on 3 mashines with Puma 10.8 i have only one,working perfectly with GraphicsEnabler
Old Chameleon , but boot for 5 sec T61,mobo G41 and G55

#30
X-TRiAL

X-TRiAL

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
  • Gender:Male
  • Location:UK
I'm starting to think its not actually the AGPM, thinking it may be more related with this thread:

http://www.insanelym...howtopic=281178

What you think? Worth a try? Maybe you get help with the edit of the Nvidia kext?

Regards

#31
HUSABER

HUSABER

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 964 posts
  • Gender:Male
  • Location:Cyprus
  • Interests:Motocross-HusabergFC-600 FourStroke,KTM500 TwoStroke,TM300 TwoStroke
    Free Time-My Hackint...
SORY ERROR IS MY...
http://www.osx86.net...rch.html#result

#32
X-TRiAL

X-TRiAL

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 164 posts
  • Gender:Male
  • Location:UK
That is for a search?

#33
HUSABER

HUSABER

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 964 posts
  • Gender:Male
  • Location:Cyprus
  • Interests:Motocross-HusabergFC-600 FourStroke,KTM500 TwoStroke,TM300 TwoStroke
    Free Time-My Hackint...
The best driver from site...see post here work..... :wallbash:

#34
nyolc8

nyolc8

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 802 posts
  • Gender:Male
  • Location:Budapest, Hungary
Sorry for bumping this old topic, but is there any way to patch AppleGraphicsPowerManagement to load with macpro3,1 smbios? Maybe some binary file modification in the kext? I know that it's not loading on real macpro3,1. I just asking that maybe it could be patched somehow...

#35
aphioner

aphioner

    InsanelyMac Geek

  • Banned
  • PipPipPip
  • 145 posts
  • Gender:Male
  • Location:Turkey
Hey guys. After looking for a definitive solution, I finally found one.

It's necessary to modify Applegraphicspowermanagement.kext and SMBIOS (MacPro3,1 or MacPro4,1) and try a new bootloader. I literally didn't change any files except the bootloader and when system booted up AGPM was loaded successfully.

#36
HUSABER

HUSABER

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 964 posts
  • Gender:Male
  • Location:Cyprus
  • Interests:Motocross-HusabergFC-600 FourStroke,KTM500 TwoStroke,TM300 TwoStroke
    Free Time-My Hackint...

Sorry for bumping this old topic, but is there any way to patch AppleGraphicsPowerManagement to load with macpro3,1 smbios? Maybe some binary file modification in the kext? I know that it's not loading on real macpro3,1. I just asking that maybe it could be patched somehow...

AppleGraphicsPowerManagement/Contens/info plist-You see?Dont have any MacPro 3.1 :hysterical:

Maybe you need to start with MacPro 4.1 smbios,or another mashine :wink_anim:

Screen_Shot_2013_06_19_at_8_31_02_AM.png







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy