Jump to content

10.8 ALC883 enabling sound problem


  • Please log in to reply
2 replies to this topic

#1
noxwell

noxwell

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Hi all! I have problem with enabling sound on my fresh Mountain Lion asing AppleHDA with additionary kexts. Motherboard is ECS P35T-A I have tried this pack http://www.osx86.net...ntain_lion.html and this http://www.root86.or...3-Mountain-Lion, but both of them give me error in my system.log
01.08.12 18:09:02,573 com.apple.kextd[12]: Kext id com.apple.driver.AppleHDAController not found; removing personalities from kernel.
01.08.12 18:09:02,574 com.apple.kextd[12]: Kext id com.apple.driver.AppleHDAHardwareConfigDriver not found; removing personalities from kernel.
01.08.12 18:09:02,576 com.apple.kextd[12]: Kext id com.apple.driver.AppleHDAPlatformDriver not found; removing personalities from kernel.
01.08.12 18:09:02,580 com.apple.kextd[12]: Kext id com.apple.driver.AppleHDA not found; removing personalities from kernel.

Native AppleHDA have no errors in system.log, but in kextstat there is no any HDA kext. Here is kexstat output:
Spoiler


VoodooHDA works fine, but it is not, what i need.

And where is /var/log/kernel.log? Maybe it will be useful

#2
noxwell

noxwell

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
OK, now this error disappeared. kextstat now return:
home:~ alexey$ kextstat |grep -i hda
   72	1 0xffffff7f811f9000 0xc000	 0xc000	 com.apple.iokit.IOHDAFamily (1.7.4a1) <5 4 3 1>
   73	0 0xffffff7f81205000 0x14000	0x14000	com.apple.driver.AppleHDAController (1.7.4a1) <72 10 5 4 3 1>
   76	0 0xffffff7f80a5f000 0x4000	 0x4000	 com.kext.HDAEnabler (1.0.0d1) <10 4 3>

There is no some services and there is no any device in sound preferences. In device info in sound section there is only:

[b]Intel High Definition Audio:[/b]

  ID аудио: 12

BTW, there is no neither AZAL nor HDEF section in dsdt, maybe this is the reason? I'm using now HDAEnabler from http://www.osx86.net...p?do=file&id=12

I have tried to patch AppleHDA by this instructions http://www.insanelym...howtopic=276249 (using zlib.pl of course), but no sound appeared

#3
noxwell

noxwell

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Solved, thanks to Riley Freeman! The problem was in missing HDEF section in DSDT, added it using attached manual

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy