Jump to content

iCloud problem

  • Please log in to reply
2 replies to this topic



    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
I'm constantly receiving the following messages in the system log:

com.apple.launchd.peruser.501[261]: (com.apple.ubd[523]) Exited with code: 254
com.apple.launchd.peruser.501[261]: (com.apple.ubd) Throttling respawn: Will start in 10 seconds

I've tried deleting the com.apple.ubd.plist file from ~/Library/Preferences to no avail.

What can I do to stop this?



    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 203 posts
  • Gender:Male
  • Location:Switzerland
yes getting the same.

textedit doesn;t launch and pages doesn't give me option to save to icloud....



    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
I encountered a few problems with OSX on a GA-Z77x-UP5 TH board that resulted in the problem as described in this thread.

First I noticed that after installing the iWork '09 suite none of the applications would fully load, instead once past their respective welcome screens they would hang until told to force quit. Looking at the console logs showed.

24/01/2013 10:35:40.862 com.apple.launchd.peruser.501[147]: (com.apple.ubd[306]) Exited with code: 25424/01/2013 10:35:40.862 com.apple.launchd.peruser.501[147]: (com.apple.ubd) Throttling respawn: Will start in 9 seconds

This message would repeat in the logs every 10 seconds. And would continue to repeat even after the offending application had been force quit. A quick search for com.apple.ubd shows it is the iCloud synchronization daemon.

I then became aware of this kind of behaviour in a few select other applications, like TextEdit and MKV2M4V. It was apparent that this issue needed resolved, permanently. So my quest began scouring OSX86 community sites like this one but information was scant on my specific issue and even more so on any possible solution.

After finding my way to a thread I thought I had found the answer but the solution posed its own problems.

Open Keychain Access, and search for "ubiquity." Double click each certificate (not public key), and changes the Trust value to "Always Trust." Quit and restart.

Once Keychain Access was open and I typed in ubiquity I saw a listing of many thousands of items. These I would have needed to poke through individually to find, first if they were private or public and second adjust their certificates. On top of that what happens later when new certificates show up. There had to be an easier way.

After a lot, lot more poking around the interwebs I saw a post related to Ubiquity and how that user noticed in ~/Library/Logs/Ubiquity/ (go to console app, left panel, under FILES, click on ~/Library/Logs) logs that it was attempting to create a file in a directory that didn't exist, over and over again. When I checked out my Ubiquity logs I saw that the problem was slightly different, it was attempting to create a directory when it didn't have the permissions to do so.

[ERROR] 2a9dd289d47 [13/01/24 11:04:36.775] 595.main get_uuid_and_open_iidb:946 failed to mkdir "/Users/<username>/Library/Application Support/Ubiquity/peer-8F46G39-C581-EN3A-CFFF-EFSDGSDH12JJDF-v23" (Permission denied)
[ERROR] 2abf81838f1 [13/01/24 11:04:45.818] 596.main ubd_main:2695 personid: 154521546

1. Hold down option-key and click Go in the Finder menu, then select Library.
2. Double click the Application Support directory.
3. Locate and right click on the Ubiquity directory then on Get Info.
4. Click the lock icon at the bottom-right of the window.
5. You will be asked to enter your password.
6. Under the Sharing & Permissions section change the privileges for each user listed in the Name column to Read & Write.

After doing this those continuous messages in the console logs from com.apple.ubd immediately disappeared and when I tested Pages '09, Numbers, Keynote, TextEdit and MKV2M4V all worked as should.

I have been thinking about why so few people have experienced this problem. I only just did a fresh install, following the guides for new hardware chosen because of its compatibility with OSX. Other people with the exact same setup didn't seem to have this issue. Then it dawned on me, the one thing I did different was move my home directory to another drive (twice). So perhaps others in this situation did something similar?

Just a final word. The OSX86 community online is a most awesome resource and is home to a very helpful, industrious bunch of people. I am honoured today to be contributing what little I have to offer for the greater good. I truly hope if you find yourself here and have read this that you are leaving with a working solution!

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy