Jump to content

Ati Radeon 4350 with Mountain Lion


  • Please log in to reply
1 reply to this topic

#1
sciueferrara

sciueferrara

    InsanelyMac Protégé

  • Members
  • Pip
  • 42 posts

Hi everybody. Sorry if my English is bad

Posted Image


I installed Mountain Lion GM on my PC, and all works fine, except for graphic and audio.


My graphic card is Ati Radeon 4350 512MB (0x954f).


I've problems with this card, in fact the graphic is very slow and when I open launchpad, or Mission control, or Centro notifiche, or the top sites tab on safari, ML become very slow and shows lines on the monitor.


Humm... i think the kext is wrong, or i haven't qe/ci.


I tried installing some kexts i found on the web but the boot stop and didn't continue... the same thing is safe mode...

Posted Image

so I reinstalled ML three times...


I ask help you... because i don't want reinstall ML another time... i want the exact kext...

Posted Image


Can you help me... please !

Posted Image



#2
martinlbb

martinlbb

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
  • Location:Lyon (France)
Hi :)

I managed to let work AMD Radeon 4350 (512 Mb) on Mountain Lion.

I follow advice of 'Here to help' (from os86 forum) and edited Mountain Lion 10.8.2 ATI4600.kext to add HD4350 support (id = 0x954f).

It worked well, with no need of any other hacks (like modifiy org.chameleon.boot.plist).

Just work out of the box! Posted Image

I tested it with dual screens config, using DVI and HDMI ports (24" and 17").

Here is the modified Kext (just added 0x954f1002 to info.plist at line 62).

Attached File  ATI4600Controller.kext.zip   104.48KB   143 downloads

If you have different model ID, I can add to ATI4600.kext, if needed.

Enjoy :)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy