Jump to content

[How to] Check if your computer can run OSX well


  • Please log in to reply
No replies to this topic

#1
Duncan Leo

Duncan Leo

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
CPU:
Pentium 1s are unsupported. Even Windows 7 cannot run on them.
Pentium 2s unsure, but if they work they will be similar to P3/4/M's solution.
If you are running a Pentium 3/4/M, you are limited to Snow Leopard with a legacy kernel that will list your CPU as a 'Core Solo'.
Core Solo or Core Duo will work with SL at most.
Clarkdale/Arrandale/SandyBridge/IvyBridge will work. Sandy requires 10.6.8+ while Ivy required 10.7.5+/10.8+

AMD APUs will work stably with SL with a legacy kernel ^^see Pentium. Work is being done to have AMD APUs on newer OSXes like Lion and ML.


Sound:
Usually works with VoodooHDA, but for maximum functionality patching AppleHDA is recommended. Some really new sound cards are unsupported. For sound ports editing DSDT editing may be required, but VoodooHDA sometimes does a good job of detecting these.

SD card:
Most SD card readers work with VoodooSDHC.

Keyboard:
Usually comes supported with any PS2Controller kext.

Trackpad:
Synaptics: VoodooPS2Controller or ApplePS2Controller gives you a lot of functionality. Not much editing needed.
Alps: Requires special kexts. Sometimes VoodooPS2Controller supports it.
Senteliic FSP: Supported by VoodooPS2Controller.
Elantech: Best used as a PS/2 mouse. No kext available.

USB ports:
Requires DSDT editing. Different for every computer.

GPU:
Unsupported Ones:
S3 Graphics, etc

Intel:
82845GL - Resolution and Core Image only. No QE.
GMA 900 - Supported through a mix of GMA 950 kexts and others such as ElliotLegacyGMA950Enabler. Can have QE/CI.
GMA 950 - Supported from Leopard thru Lion. NOT SUPPORTED IN MOUNTAIN LION. When using with SL a Natit Alkor may be required. Can have QE/CI.
GMA X3100 - Supported. May require kext patching. Natit Alkor may be required for SL. Can have QE/CI.
GMA Netbook Graphics:
If your netbook is the early 32-bit Atom CPU + GMA 950, you can run SL at most with QE/CI
GMA 500/3100 etc not supported. Never used by Apple.
GMA X4500 - Resolution fixed working through a series of DSDT edits and some X3100 kexts
GMA HD/Intel HD Graphics/GMA 5700 There are kexts for this GPU, but because the model of MBP it is used in has a MUX with a GT330M card, work is being done to let this card work standalone. Can have QE/CI if the work succeeds.
Intel HD 3000 - Full support from 10.6.8 - current. Requires MacBookPro8,1 smbios. Important! Can have QE/CI.
Intel HD 4000 - Full support from Mountain Lion - current. Might require a MacBookPro9,1/9,2/10,1 smbios. Not sure, but has been reported working with QE/CI.

ATI:
I am not really sure about AMD cards, but as of now some older cards e.g. X1600 are unsupported in ML and we are waiting for new Macs with the Radeon HD 7k cards so that we can use ours.

NVIDIA:
GeForce 4 MX and above only.
Some New GTX *** cards do not work due to new architecture.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy