Jump to content

[Need Help] Sleep issues

lion 10.7.4 AMD AthlonII ECS sleep wake

  • Please log in to reply
46 replies to this topic

#41
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,785 posts
  • Gender:Male
Hi, eeep!


PreventUserIdleDisplaySleep 0
PreventSystemSleep 0
PreventUserIdleSystemSleep 0
ExternalMedia 0
UserIsActive 0
ApplePushServiceTask 0
BackgroundTask 0

So i think it's not the problem, right? I'll check the console right now to find some clue. Any advice about which logs should i check?

Thank you!

#42
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
just the general messages one that list's everything. Also here is same terminal output on real macbook
macbook ~> pmset -g assertions
9/24/12 10:13:30 AM PDT 
Assertion status system-wide:
   PreventUserIdleDisplaySleep			 0
   CPUBoundAssertion					   0
   DisableInflow						   0
   ChargeInhibit						   0
   PreventSystemSleep					  0
   PreventUserIdleSystemSleep			  0
   ExternalMedia						   0
   DisableLowPowerBatteryWarnings		  0
   EnableIdleSleep						 1
   NoRealPowerSources_debug			    0
   UserIsActive						    0
   ApplePushServiceTask				    0
Kernel Assertions: 0x0004
* Kernel Assertion ID = 500
   Created At = 12/31/69 4:05:34 PM PST 
   Modified At = 12/31/69 4:00:00 PM PST 
   Owner ID = 0x0000000005c1e000
   Level = 0
   Assertions Set = None (4)
* Kernel Assertion ID = 501
   Created At = 12/31/69 4:07:35 PM PST 
   Modified At = 9/22/12 2:42:35 PM PDT  
   Owner ID = 0x0000000005c47000
   Level = 0
   Assertions Set = None (4)
* Kernel Assertion ID = 502
   Created At = 12/31/69 4:07:43 PM PST 
   Modified At = 12/31/69 4:14:05 PM PST 
   Owner ID = 0x0000000005c70000
   Level = 255
   Assertions Set = None (4)
* Kernel Assertion ID = 503
   Created At = 12/31/69 4:07:46 PM PST 
   Modified At = 12/31/69 4:00:00 PM PST 
   Owner ID = 0x0000000005a63000
   Level = 0
   Assertions Set = None (4)
* Kernel Assertion ID = 504
   Created At = 12/31/69 4:07:51 PM PST 
   Modified At = 12/31/69 4:00:00 PM PST 
   Owner ID = 0x0000000005c49000
   Level = 0
   Assertions Set = None (4)


#43
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,785 posts
  • Gender:Male
Hi, eeep!

In fact, i didn't posted here the second part of the output; i thought it was not important. Silly me. :) Anyway, it's identical to the one you posted but the owner IDs. Opened the Console.app and put my computer to sleep twice, both 2:22 PM and 2:25 PM. Posting the results of both naps (using the power button and selecting the option sleep):


The first one:

9/24/12 2:22:01.551 PM WindowServer[104]: Created shield window 0x55 for display 0x5b81c5c0
9/24/12 2:22:01.552 PM WindowServer[104]: device_generate_desktop_screenshot: authw 0x0(0), shield 0x0(0)
9/24/12 2:22:01.587 PM WindowServer[104]: device_generate_lock_screen_screenshot: authw 0x0(0), shield 0x0(0)
9/24/12 2:22:07.295 PM com.apple.launchd[1]: System: Bug: 12C54: launchd + 80370 [7DCC9489-2DF5-3807-83FA-EF5666EE8078]: 0x0
9/24/12 2:22:07.295 PM com.apple.launchd[1]: System: This API can only be used by a process running within an Aqua session.
9/24/12 2:22:07.299 PM open[1077]: spawn_via_launchd() failed, errno=5 label=[0x0-0x2f02f].aidaemon path=/tbupddmx/aidaemon.app/Contents/MacOS/aidaemon flags=0
9/24/12 2:22:07.302 PM open[1077]: spawn_via_launchd() failed, errno=5 label=[0x0-0x2f02f].aidaemon path=/tbupddmx/aidaemon.app/Contents/MacOS/aidaemon flags=0
9/24/12 2:22:11.848 PM WindowServer[104]: handle_will_sleep_auth_and_shield_windows: no lock state data
9/24/12 2:22:11.947 PM com.apple.launchd.peruser.502[137]: ([0x0-0x30030].backupd-helper[1090]) Could not setup Mach task special port 8: (os/kern) invalid argument
9/24/12 2:22:12.000 PM kernel[0]: AirPort: Link Down on en1. Reason 8 (Disassociated because station leaving).
9/24/12 2:22:13.000 PM kernel[0]: ATHR: unknown locale: 60
9/24/12 2:22:13.871 PM configd[18]: network changed: v4(en1-) DNS- Proxy- SMB
9/24/12 2:22:13.939 PM com.apple.launchd.peruser.502[137]: (com.apple.FontWorker[1098]) Could not setup Mach task special port 8: (os/kern) invalid argument
9/24/12 2:22:14.253 PM com.apple.launchd.peruser.502[137]: (com.apple.mdworker.bundles[1100]) Could not setup Mach task special port 8: (os/kern) invalid argument
9/24/12 2:22:15.000 PM kernel[0]: AirPort: Link Up on en1


The second one:

9/24/12 2:25:01.309 PM WindowServer[104]: Created shield window 0x68 for display 0x5b81c5c0
9/24/12 2:25:01.310 PM WindowServer[104]: device_generate_desktop_screenshot: authw 0x0(0), shield 0x0(0)
9/24/12 2:25:01.349 PM WindowServer[104]: device_generate_lock_screen_screenshot: authw 0x0(0), shield 0x0(0)
9/24/12 2:25:01.421 PM com.apple.launchd.peruser.0[1578]: (0x7feee0506990.anonymous.cron[1577]) Could not setup Mach task special port 8: (os/kern) invalid argument
9/24/12 2:25:02.603 PM sandboxd[1572]: ([1550]) mdworker(1550) deny mach-lookup com.apple.ls.boxd
9/24/12 2:25:02.805 PM sandboxd[1572]: ([1549]) mdworker(1549) deny mach-lookup com.apple.ls.boxd
9/24/12 2:25:03.716 PM sandboxd[1572]: ([1551]) mdworker(1551) deny mach-lookup com.apple.ls.boxd
9/24/12 2:25:08.464 PM com.apple.launchd[1]: System: Bug: 12C54: launchd + 80370 [7DCC9489-2DF5-3807-83FA-EF5666EE8078]: 0x0
9/24/12 2:25:08.464 PM com.apple.launchd[1]: System: This API can only be used by a process running within an Aqua session.
9/24/12 2:25:08.486 PM open[1600]: spawn_via_launchd() failed, errno=5 label=[0x0-0x3e03e].aidaemon path=/tbupddmx/aidaemon.app/Contents/MacOS/aidaemon flags=0
9/24/12 2:25:08.489 PM open[1600]: spawn_via_launchd() failed, errno=5 label=[0x0-0x3e03e].aidaemon path=/tbupddmx/aidaemon.app/Contents/MacOS/aidaemon flags=0
9/24/12 2:25:12.690 PM WindowServer[104]: handle_will_sleep_auth_and_shield_windows: no lock state data



Thanks a lot!

#44
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Thanks to post by fantomas1 on another topic where he pointed out this site http://www.mymacnetb...tibility-chart/ .Looks like lots of good info and resources along with ability to know if sleep even possible. Didn't see a listing for your exact model, but check whatever is closest

#45
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,785 posts
  • Gender:Male
Thank you, eeep!

I'm going to check it out.

EDIT: oh, i'd already seen that. Yeah, my netbook isn't listed: it was paradoxically what encouraged me at the first place. Because it was written nowhere if it would work, but also if it wouldn't.

I think i should update that list including my own netbook, and write a guide for it, since i have the latest and greatest Mountain Lion running quite smoothly except for QE/CI (GMA3150) and that sleep issues, and it would be in no way ashamed in comparison to the results of the other hacked netbooks listed, adding to it the fact that i could replicate the process of installation (in fact, i did it a couple of times) any time.

But it will have to wait a little bit, because i didn't give up yet: i'll put this mountain kitty to sleep when i want it to, sooner or later.

What i'm going to do from now, in chronological order (and your advice or ideas would be much appreciated):

1) remove the NullCPU and AppleIntelCPUPower management kexts and throw VoodooPowerMini back in (SleepEnablerUniversal is there already);

2) remove the sleep enabler, letting only Voodoo;

3) remove voodoo, letting only the sleep enabler;

4) remove all legacy power-related legacy kexts;

5) Put back AppleIntelCPUPowerManagement and try using the ICH7 dsdt fix again.

I'll update the results at this very post, to not to flood the topic.

By the way, did you take a look at my console output? Did it show something that i should consider? There's a bug there, i think it's related to touch drivers for MozArt resistive. But before i installed these drivers back in Lion, my netbook didn't sleep either.

Thank you very much for the help you've been offering!

#46
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,785 posts
  • Gender:Male
Hey!

Thanks to fau7i, of osx86.net, who pointed me to the hibernatemode=0 fix, now my netbook sleeps! Could be just perfect... if it wasn't too lazy to wake up. The solution i successfully used for my AMD machine, darkwake=0, simply does not work, as well as darkwake=No or darkwake=10.

I'm almost there! Any help will be much appreciated. Thank you all!

#47
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,785 posts
  • Gender:Male
Hmmm... could the issue be related to the fact my graphics card isn't properly recognized?





Also tagged with one or more of these keywords: lion, 10.7.4, AMD, AthlonII, ECS, sleep, wake


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy