Jump to content

[Guide] The all-in-one guide to Vanilla OS X (including Chameleon + DSDT) for beginners (updated for Mavericks!)

Mountain Lion Vanilla OS X Chameleon DSDT Beginner Guide How-to

  • Please log in to reply
810 replies to this topic

#541
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets

DSDT patching for audio is no longer needed with HDAEnabler.kext

Thank i did it already, rip off the DSDT HDEF part, added HDAEnabler and modded AppleHDA and it works.

 

Have a look at Toleda's patched AppleHDA for Realtek ALC here http://www.insanelym...applehda-audio/ .  Patching for audio in dsdt is optional (need HDAEnabler.kext in addition to patched AppleHDA.kext if you don't have patched audio in dsdt).

 

Rehabman's VoodooPS2Controller.kext ver 1.8.7 and above https://github.com/R...-PS2-Controller fixed a bug which prevented the kext from loading on 10.9 Mavericks.

 

Thanks a lot.
 
I take out the PS2 trackpad kext inside plugins of VoodooPS2Controller and it works
 
Audio is OK with HDAEnabler.
 
:D


#542
fusion71au

fusion71au

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 355 posts
  • Gender:Male

Congratulations on your fifth Mavericks install :D .



#543
oSxFr33k

oSxFr33k

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 787 posts
  • Gender:Male
  • Interests:Sound and Graphic Design. Electronics in general.

Thanks for a great guide.  If you use MBR on the USB FLash Installer will it be necessary to patch it or is the patch only needed for the installed OSX target drive?

 

Thanks



#544
fusion71au

fusion71au

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 355 posts
  • Gender:Male

The mbr formatted install USB can still create and install to a GUID partitioned hard drive.  You only need to patch the USB installer with Nawcom's OSInstall(MBR) if your OSX target hard disk is partitioned as MBR and you want to install into it.  The target HD itself does not need it.



#545
spacetime

spacetime

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Thanks for the guide :D.. It's my first time building my own hackintosh  :D

I have some problems though,  :( I already followed until step 3.1, where my PC always rebooting after i choose to boot from my USB (first install), just barely saw the apple screen.... and then it reboot it's self.

I can't show the verbose, cause it's too fast...

 

Already trying with GraphicsEnabler=Yes -v, -v -x -f.. all to no avail.

 

Anyone has suggestion?

 

Sorry for my bad English..

 

My hardware is :

Intel i7 3770K (Ivy Bridge)

Asus P8Z77 V-Deluxe(latest bios from asus) *edit already flashed my BIOS from samisnake's repo (1805), but still no avail too

Hitachi 2TB

Corsair XMS 4GB x 2

Nvidia GTX 660 Ti x 2

 

Regards, Michael



#546
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,423 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

hello

 

u should try also

 

-v GraphicsEnabler=No Wait=Yes

 

good hack



#547
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets

My P35-DS3L has speed problems, it sleeps but when it wakes there is no video so I need to reset it :(



#548
fusion71au

fusion71au

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 355 posts
  • Gender:Male

Hi macgirl.

 

A few things you might try (one by one first)



#549
macgirl

macgirl

    Stargate's Pharaoh

  • Retired
  • 7,612 posts
  • Gender:Female
  • Location:Mexico City
  • Interests:Techie gadgets

Thanks :D

 

Darkwake is already there.

 

Trying right know.


AppleACPIPlatform and RTC patch worked  :thumbsup_anim:



#550
toomuchtv

toomuchtv

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts

Hey Folks,

 

I've been trying to follow this guide to do an install on an Asus S56C Ultrabook.

 

I can't get the machine to get past the grey apple screen. 

When booting with -f -v -x GraphicsEnabler=No the system hangs here:

 

HWSensors Project Copyright 2013 netksa, slice,.....

FakeSMCDevice: 15 preconfigured key(s) added

FakeSMCDevice: 0 key(s) exported from Clover EFI

SMC: successfully initialized

Anyone have any ideas?



#551
fusion71au

fusion71au

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 355 posts
  • Gender:Male

Hey Folks,

 

I've been trying to follow this guide to do an install on an Asus S56C Ultrabook.

 

I can't get the machine to get past the grey apple screen. 

When booting with -f -v -x GraphicsEnabler=No the system hangs here:

Anyone have any ideas?

 

FakeSMCDevice: 15 preconfigured key(s) added

FakeSMCDevice: 0 key(s) exported from Clover EFI

Are you using clover EFI as bootloader or chameleon on your install USB?

 

What SMBIOS are you using?

 

Is the graphics on your machine HD 4000 only or is it switchable with an nVidia card?  Might need to disable NVidia card in BIOS or remove the NVDA* and GeForce* kexts from /System/Library/Extension eg http://www.insanelym...torial-ml-1082/

 

Might try activating your HD 4000 graphics with Graphics Enabler=Yes and IntelCapriFB=a_value from 0 to 11 in the org.chameleon.Boot.plist (see http://www.insanelym...ig-platform-id/ ) . Guide to choosing ig-platform-id http://blog.stuffedc...i-acceleration/ (eg for IntelCapriFB=9, set graphics mem to 64MB in BIOS).



#552
Pippuz92

Pippuz92

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:treviso

HI, i have some problem to select with utility disco where to install OS X. I made the USB with ML like in the guide, on the startup boot I press enter the chamaleon make something, and then it tell me to restart pc! i can't go into utility and select in wich HDD install OS X

 

could u help me?

https://www.dropbox....20 16.44.29.jpg

https://www.dropbox....20 16.44.41.jpg

https://www.dropbox....20 16.45.06.jpg

 

here is some pic, i hope they will explain much more better my problem.

thanks



#553
ervinke2

ervinke2

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Hi guys!

 

I have a Dell Vostro 1400 notebook. Intel Core2Duo T7250 CPU, 3GB RAM, 8400M GS VGA. When I try to start the installer it hangs at ACPI: System State [S0 S3 S4 S5] (S3). I'm trying to boot a retail 10.8.4 installer. I don't know what is the problem. I tried it with iAtkos ML2 but I get the same problem. 

 

Thanks!



#554
Serge-H

Serge-H

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

Is there a risk by installing Mavericks on the same HDD where there is Windows 8 ? I'm using an HP Pavilion dv6 Notebook.. I'm kind of afraid of doing it, maybe it will corrupt something in the HDD



#555
JorgeMDQ

JorgeMDQ

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

Hi! I want to know in order to get a kext for my GFX card Zotac GeForce 9500GT its Device & Vendor ID, and I wrote the developer if can give that numbers. Meanwhile, does anybody knows if this PCI card with the same designation that the Nvidia one are equivalent ? Is its kext valid for my Zotac?

 

Thank you for any comment.

 

PS: NVIDIA Device ID: 0x0643 - Vendor ID: 0x10DE



#556
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,423 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

hello

 

use this to see u dev id

 

http://www.insanelym...and-kexts-info/

 

good hack



#557
JorgeMDQ

JorgeMDQ

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts

Hi artur-pt and thank you!  :) 

Certainly with System Info app i could found that my ZOTAC GeForce 9500 GT is recognized as an Nvidia card and its Vendor & Device ID are there. I attach an image for someone else…

 

Now, I need to know if Nvidia kexts are installed on S/L/E or in Extra. Is it equivalent where they are ?

 

 

PS: Bueno, queria subir una imagen pero el script para seleccionarla no me funciona tal como esta mi mavericks ahora. Probé con Safari, Firefox y Chrome. Cuando resuelva la subo....  :(



#558
Pippuz92

Pippuz92

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:treviso

please i really need your help guys..

 

HI, i have some problem to select with utility disco where to install OS X. I made the USB with ML like in the guide, on the startup boot I press enter the chamaleon make something, and then it tell me to restart pc! i can't go into utility and select in wich HDD install OS X

 

could u help me?

https://www.dropbox....20 16.44.29.jpg

https://www.dropbox....20 16.44.41.jpg

https://www.dropbox....20 16.45.06.jpg

 

here is some pic, i hope they will explain much more better my problem.

thanks



#559
dudi1991

dudi1991

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Hey.
When I try to install I can see the apple logo but the spinning wheel is stuck after 3 mins.
How to get the install to work??
Thanks

#560
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,423 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco

hello

 

u should post u hardware config

 

try 

 

-v GraphicsEnabler=No

 

and post photo from boot

 

good hack







Also tagged with one or more of these keywords: Mountain Lion, Vanilla OS X, Chameleon, DSDT, Beginner, Guide, How-to


13 user(s) are reading this topic

1 members, 12 guests, 0 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy