Jump to content

AMD SATA Controller


  • Please log in to reply
2 replies to this topic

#1
ryanstein

ryanstein

    InsanelyMac Protégé

  • Members
  • Pip
  • 10 posts
Hey everybody. I'm having an issue with getting my laptop to run OSX. I have an HP Pavilion G6-1d60us, which has an "AMD SATA Controller." For some reason, no kext that I have tried will allow the hard drive to be seen. I continually get Still Waiting for Root Device when trying to boot the installer from the DVD, and I can only boot OSX if I boot from a USB hard drive. I tried adding things like the IOATAFamily kext, AppleATIATA kext, etc., but none of them allowed me to see the hard drive.

Does anyone know of which kext will fix this issue? Thanks!

#2
Lordadmiral Drake

Lordadmiral Drake

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 417 posts
  • Gender:Male
  • Location:Austria
I'm having the same issue on my HP Pavilion DV7-2160eg with AMD SB700 Southbridge. Any help to us would be much appreciated

#3
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
add your device id of you controller Sata for the kext, test this kexts in your Extra and boot with -f -v


Attached File  Still Waiting.zip   138.71KB   55 downloads





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy