Jump to content

I have a problem with my wireless :/ hope you can help me :)

osx

  • Please log in to reply
29 replies to this topic

#1
Spreadwide

Spreadwide

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
Ok so i begin with my specs :

Motherboard : Asus P5QL/EPU
Processor : Intel pentium dual core e6600 3,06 GHz
Ram : 4 GB DDR2 (i know it suck like the processor)
Video card : Geforce GT 220 by nvidia
HDrive : Western Digital 500 GB

Ok so i think now you need informations of my installation :

Snow leopard 10.6.1/10.6.2 by hazard
Chameleon RC3 EFI 10.5

Now what works :

Sound (rear mic, rear headphones, front mic, front headphone) (VoodooHDA kext modified by me for enable my rear mic)
Nvidia GT220 work (nvenabler)
Ethernet work by defaut on this board

Now what doesn't work :

Wireless DWA-510 Pci card (chipset RT61) : so about this card i read a lot of post on insanelymac and other forums but still no device on airport i know ralink created drivers for this card but the drivers doesn't work in snow leopard and leopard too, i saw that these drivers are for usb wifi card only, i tried the atheros fix for this card but nothing :/ so now i try here to get more informations about this card so i hope that i can get my card works under snow leopard 10.6.2 :)
Maybe i can try to modify the dsdt i know nothing about dsdt modification.

I have another problem but it s not really important, when i go to "about this mac" -> "more infos" -> "hardware" i see only one core detected but i have a dual core and when i launch the activity monitor tools i see my two cores work together with no problem so i want to know if it s a big problem or not and if i can modify this.

P.S : Really i m sorry for my bad english, i m french and if you want more information just reply :)

Thx all .

#2
Spreadwide

Spreadwide

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
Any help ??

#3
miasvanklei

miasvanklei

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Your card has two chips:
Chip 1 : Ralink RT2561
Chip 2 : Ralink RT2527
On the ralink website you can find the driver for Chip 2:
http://www.ralinktec...port.php?sn=502

#4
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Or, if that doesn't work, and because I don't want to spend all morning looking for a kext for an older card, my advice would be to go here System Info, an app to get hardware and kexts info download and run that app so you can get vendor and dev ID, then go to http://olarila.com/kexts/ and use the ID's to search if a compatible kext is available

#5
Spreadwide

Spreadwide

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
Ok thank you for all it s awesome :) i will try your solutions, hum for the ralink website i saw that the drivers are only for ppc only? I tried the last driver i will try the second:)

Thx eep357 i will try to do that :)

I will reply later.

#6
Spreadwide

Spreadwide

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
Ok i done the search :
Ven ID : 1814
Dev ID : 0302

and that's what i got :

Posted Image

So now what should i do ? You said search the kext but i tried and i got no result (yeah i know you going to say wtf what is this man, he can't do a search by himself ?)
I going to try again but see if what i did is right.

Ok so i finally found --' i was blind maybe ^^

Posted Image

So i going to try these kext and i'll give you more infos later ;)

Ok it doesn't work these drivers are the same that the drivers of the ralink website. i have no problem during the installation but still no device i tried to modifie the info.plist but nothing. Should i boot at 32 bits mode... i don't know.
Strange ralink make these drivers and they don't work --' i used the last driver wich is on the website and i opened the info.plist and found my ID in the IOMatch... so it should work i don't know really i m tired ...

#7
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
searching just the vendor ID will give results that include every ralink wifi device, or which there are many. I'll take a look for ya tho, since at least you tried :) Wup, just saw your first pic, not looking good. Can you post the system info app screencap?

Nope, you're SOL. Time to upgrade to wireless N. You should be able to find a compatible one for $5-$10 or you can go native with PCIe to mini PCIe adapter and one of the apple airport cards (or same version without apple branding) for around $30 give or take a few depending on where and what you get.

#8
Spreadwide

Spreadwide

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
OKOK so you want a screen of the system info app voila :

Posted Image

euh yeah i will work a bit more on this problem and if i can't do anything i going to buy another pci card :) and for my cpu info do you have an idea my master ^^ now i only hope that league of legends run on this "hackintosh"...

#9
Spreadwide

Spreadwide

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
Re. I have more information i found the other pci cards wich use the same driver in windows and i got this :


G630.DeviceDesc = "D-Link AirPlus G DWL-G630 Wireless Cardbus Adapter(rev.E)"
G510.DeviceDesc = "D-Link AirPlus G DWL-G510 Wireless PCI Adapter(rev.C)"
G630B.DeviceDesc = "D-Link AirPlus G DWL-G630 Wireless Cardbus Adapter(rev.E)"
G510B.DeviceDesc = "D-Link AirPlus G DWL-G510 Wireless PCI Adapter(rev.C)"
G650A.DeviceDesc = "D-Link AirPlus G DWL-G650+A Wireless Cardbus Adapter(rev.E)"
G520A.DeviceDesc = "D-Link AirPlus G DWL-G520+A Wireless PCI Adapter(rev.C)"
G630M.DeviceDesc = "D-Link AirPlus G DWL-G630M Wireless Cardbus Adapter(rev.A)"
G510M.DeviceDesc = "D-Link AirPlus G DWL-G510M Wireless PCI Adapter(rev.A)"
DWA610.DeviceDesc = "D-Link Wireless G DWA-610 Notebook Adapter"
DWA510.DeviceDesc = "D-Link Wireless G DWA-510 Desktop Adapter"

So i going to search if i found kext with these infos

#10
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff

for the ralink website i saw that the drivers are only for ppc only?

That say's a lot right there :) What's the deal with your CPU now?

#11
Spreadwide

Spreadwide

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
Ok so i going to buy a new card --' sad no money xD, euh for cpu at the first boot i have only one core detected then i used dsdtgui and dsdtse for modify the dsdt file (delete alias) then i got both cores detected see this :

Posted Image

and when i go to -> about this mac -> more infos -> Hardware i see only one core detected :

Posted Image

(if you want a translation just say me)

So i want to know if i can change these informations because they are wrong and i want to know if it s a serious problem or not that's all :)

#12
Spreadwide

Spreadwide

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
Hum i gonna make an tutorial for the asus p5ql epu cuz i just one tutorial on it and he don't describe correctly the installation i gonna upload my informations on osx86 database too. I think it's could help someone i just need now to resolve this problem of cores and it s done

#13
PookyMacMan

PookyMacMan

    InsanelyMac Legend

  • Moderators
  • 1,462 posts
  • Gender:Male
  • Location:Earth–Western Hemisphere, specifically
  • Interests:Computer science, engineering, trumpet performance, and a host of others. :D
BTW, the TPLink TL-WN851N is a great Atheros-based card that supports 300Mbps N speeds. :) It's what I use, works great with OS X (both Snow and Lion).

As for Ralink drivers, there are some Intel versions, but they are few and far between. I think in particular the RT61 are PPC only, but there is one kext you can try: http://www.mediafire...67b2hzho689upsf I haven't tried it, but it's "supposedly" Intel. One thing I do know is that all Ralink and Realtek drivers are 32-bit only, no Ralink/Realtek driver is 64-bit.

Go ahead, submit it to the Genius Bar. :)

#14
Spreadwide

Spreadwide

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
I tried the 10.5 rt61 kext from the ralink website and i thought that i should boot with arch=i386 for 32 bit mode but i got a kernel panic so.. I will try your link :) still hope but less :D

#15
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
What's your bdmesg output look like? Just type that in terminal.

#16
Spreadwide

Spreadwide

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
*Pookymacman i tried your kext under 32bit mode and nothing maybe it could work under 10.5.x version but np
*eep357 sorry i can't give you thhis information right now i m on ubuntu installed on a usb key, i can return on sl but it takes lot of time to boot on ubuntu.
I can give you this information tomorrow sorry :/ you need wait a bit but linux and mac terminal are the same i can try this command under linux i will reply.

command don't exist under linux so i'll give you what you need tomorrow :)

#17
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
It's "usually" installed as part of Chameleon, so gonna need to be in osx. No rush :)

#18
Spreadwide

Spreadwide

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
  • Gender:Male
sorry i needed to sleep a bit. Finally i got my 2 cores detected in the system profiler and in the monitor activity. It was simple in my BIOS i have an option "Max CPUID Value" -> this option was enabled and i saw in other post that she can cause some problem with the cpu detection under osx so i just dislabed this option and i got my 2 cores detected.

And bdmesg command not found. I typed bdmesg in the terminal and nothing i tryed other command like sudo bdmesg, bdmesg output, sudo bdmesg output and nothing.
I have a question i have a dsdt file, should i put it in the extra folder or at the root of my hard drive ?
And another question can i modify my dsdt for my wireless (last idea)
thx  :)

#19
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida
ar5b91 X http://www.ebay.com/...l?_nkw=ar5b91+x
mini pci-e to pci-e 1x http://www.ebay.com/...i-/330715586187
under $20

#20
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Hmm:
Don't worry about it cause CPU issue fixed anyway
/Extra
Nope





Also tagged with one or more of these keywords: osx


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy