Jump to content

(Help) HD 5450 on 10.8 GM


  • Please log in to reply
24 replies to this topic

#1
inewadmin

inewadmin

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hello! i come from Hong Kong, i hope my english won't too bad.

Here is my situation, i install 10.8 GM on my PC, which consist Core i3 2100 and ASUS HD5450.

I have no idea how to open QE/CI in mountain lion~~~i need your help! What kexts do i need to add or edit?

Thanks!

#2
Dr. Hurt

Dr. Hurt

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,456 posts
  • Gender:Male
  • Location:Cairo, Egypt and NYC, USA
  • Interests:Wandering around on the internet!! Politics, Sci/Tech, Medicine.

Hello! i come from Hong Kong, i hope my english won't too bad.

Here is my situation, i install 10.8 GM on my PC, which consist Core i3 2100 and ASUS HD5450.

I have no idea how to open QE/CI in mountain lion~~~i need your help! What kexts do i need to add or edit?

Thanks!


You need to add GraphicsEnabler=Yes to your boot.plist and if that doesn't work download and install ATI5000Injector.kext

#3
mediamac

mediamac

    Mediarays

  • Members
  • PipPipPip
  • 173 posts
  • Gender:Male
  • Location:INDIA
  • Interests:Hackintoshing
Seems like many ATI problems.Go like this
Graphic Enabler = No and if you have a copy of Mountain Lion DP3 then copy all ATI kexts from system/extensions to a folder.Now delete all the ATI kexts inside your current mountain lion system/extensions folder.Then copy those DP3 ATI kexts to the system/extensions folder and fix permissions.
Restart and boot with -v PciRoot=1.
Let me know if this works.

#4
Ricardo Filho

Ricardo Filho

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Gender:Male
Hey, sorry for invading the topic LOL, but i need some help. My pc with hd5450 isn't working the usb mouse and i don't know if the problem is in video card or the mb (ASUS p8h61-m). Can you help me please?

#5
fullofmillions

fullofmillions

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
I succesfully installed my HD5450 following this tread:

http://www.insanelym...howtopic=279730

Put my devID 0x68f91002 on

ATI5000Controller.kext

and

AMDRadeonAccelerator.kext



QE/CI work fine




Thanks man,
This worked for me.
Have Ati HD5450 (0x68E1, 0x1002) - Entered my iD in 4th section of Graphics Accelerator Plist (Starting with 0x68e01002) and got QU/CI back.

Thanks



#6
PGHammer

PGHammer

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 282 posts

You need to add GraphicsEnabler=Yes to your boot.plist and if that doesn't work download and install ATI5000Injector.kext


Actually, all you need is to edit the Info.plist of two kexts (both in /System/Library/Extensions) - ATI5000Controller.kext and AMDRadeonAccelerator.kext *after* making syre you add GraphicsEnabler=Yes.

The Problem - Only so many GPU IDs are present in these two kexts - not enough to keep up with the many IHVs with AMD GPUs in their roster. (ASUS isn't the only IHV to get curbed; Visiontek and even XFX got curbed as well.)

The Walkthrough - Once you have the proper device ID of your GPU, you can search the appropriate section of each Info.plist for where to place your edits. I have a Visiontek HD5450 iSilence - however, other than the device ID itself, the procedure is identical for any other HD5450.

ATI5000Controller.kext covers the entire HD5xxx series, and is subsected by GPU subfamily - each subfamily is a type of tree; for HD5450, this is Cedar. My device ID is 0x100268F9; as is common practice for Apple, the IDs show in IOPCIMatch strings in reversed order. That means you add the following to the Cedar subsection's IOPCIMatch string - 0x68F91002.

AMDRadeonAccelerator.kext uses controller families; for the HD5450, you would use Hoolock. Again, edit an existing string, or add yours. Once you save your edits and exit Terminal, you still have to repair your permissions (Kext Wizard works best for this); optionally you can rebuild the kext caches as well.

#7
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i
yep :) Saphire HD 5450 1GB DDR3 1002:68e1 (subsys 174b:3000). 68e1 is still present in ML ATI5000Controller.kext, but missing in AMDRadeonAccelerator.kext. Opened AMDRadeonAccelerator.kext/Content/Info.plist, found <string>0x68e01002</string> and extended into <string>0x68e01002 0x68e11002</string>, save.

If you are using kernel cache (in /Exta/org.Chameleon.boot.plist, either UseKernelCache=yes or

<key>UseKernelCache</key>
<string>Yes</string>
)
you now MUST rebuild it for S/L/E, easiest for most via Kext Wizard.

Reboot, BOOOOM - translucent menu bar is back = QE/CI.

(mind that DVD Player will only work when the framebuffer Eulemur is set correctly in /Extra/org.chameleon.boot.plist:

<key>ATIConfig</key>
<string>Eulemur</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
)

HAPPY :)

Big thanks to all who contributed!

#8
BryanP

BryanP

    InsanelyMac Protégé

  • Members
  • Pip
  • 40 posts
Is the AMDRadeonAccelerator kext just for people with 5/6000 cards or for 4000 as well? I have a 4850 I am trying to get working but I have been using ATI4800Controller and ATIRadeonX2000 kexts.

#9
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i
hum - I switched off graphis enabler in the chameleon.boot.plist because the correct framebuffer (Eulemur) would break wake-up from sleep on HDMI video. For watching DVDs it's best however to turn it back on. Just did in 10.8.2 --> black screen on both, HDMI and DVI. I know the trick to induce monitor sleep (e.g. via Exposee) and then wake the monitor up, but that did not work. 10.8.2 is responsive via keyboard - I can put it to sleep, and wake it up again via keyboard, but both mons stay black ..

As you can see, this used to work in 10.8.0

Do you know the solution?

#10
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i
if no QE/CI (translucent meny bar etc.) after the 10.8.3 update: these steps still apply. Replace 68e1 w/ your card's DevID

#11
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
Excuse me BugsB, Doesn't Cedar work in you case?

#12
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i
hm? What do you mean - can you please elaborate adding some details to your question :)?

Excuse me BugsB, Doesn't Cedar work in you case?



#13
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
The 5450 should work with Cedar, not Eulemur.

#14
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i
no such things as fbp Cedar, buoo ..

5xxx Framebuffer Personalities
Vervet
Douc
Langur
Uakari
Zonalis
Alouatta
Hoolock
Baboon
Eulemur
Galago
Colobus
Mangabey
Nomascus
Orangutan

6xxx Framebuffer Personalities
Pithecia
Bulrushes
Cattail
Hydrilla
Duckweed
Fanwort
Elodea
Kudzu
Gibba
Lotus
Ipomoea
Muskgrass
Juncus
Osmunda

The 5450 should work with Cedar, not Eulemur.



#15
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,815 posts
  • Gender:Male
Cedar is the card's family.

#16
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i
exactly. That's why buoo;s "The 5450 should work with Cedar, not Eulemur" does not make sense - card family vs. fb p .. :wink2:

#17
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
Sorry, I got mixed up :blush:

#18
BugsB

BugsB

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,513 posts
  • Gender:Male
  • Location:Kauai, Hawai'i
buuuuuuuuuuuuuuuuuuuuuuuooooooooooooooooooooo .. :angel_not:

#19
buoo

buoo

    The Prodigal Son

  • Moderators
  • 4,534 posts
  • Gender:Male
  • Location:Italy
Leeeeeeeeeeeeeeeeeee :D

#20
QUAK3

QUAK3

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:World Wide Web
  • Interests:Triple Boot : Clover UEFI > Mac OS X 10.8.2 > Windows 8 > Ubuntu 12.1
100% Worked http://db.tt/jdmiwITh





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy