Jump to content

Can't open Security & Privacy preferences pane


  • Please log in to reply
4 replies to this topic

#1
karlcloudy

karlcloudy

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male
For some reason, when I try to open Security & Privacy in System Preferences, it just sits there and doesn't do anything. Besides being annoying, it's also preventing me from changing the app security settings. I did do a migration from a Time Machine backup when I installed it and are wondering if this could have had anything to do it.

Any ideas?

EDIT: I am running 10.8 GM

It shows this in the system log:
15/07/12 8:53:43.171 PM System Preferences[366]: +[CLLocationManager appsUsingLocationWithInfo]: unrecognized selector sent to class 0x111ea8ea8
15/07/12 8:53:43.171 PM System Preferences[366]: +[CLLocationManager appsUsingLocationWithInfo]: unrecognized selector sent to class 0x111ea8ea8
15/07/12 8:53:43.172 PM System Preferences[366]: (
0   CoreFoundation					  0x00007fff83bf0716 __exceptionPreprocess + 198
1   libobjc.A.dylib					 0x00007fff8b708470 objc_exception_throw + 43
2   CoreFoundation					  0x00007fff83c86bba +[NSObject(NSObject) doesNotRecognizeSelector:] + 186
3   CoreFoundation					  0x00007fff83bdec3e ___forwarding___ + 414
4   CoreFoundation					  0x00007fff83bdea28 _CF_forwarding_prep_0 + 232
5   Security						    0x000000010c2c1323 SecurityPrefDebugLog + 13640
6   Security						    0x000000010c2bfe9f SecurityPrefDebugLog + 8388
7   Security						    0x000000010c2c00f4 SecurityPrefDebugLog + 8985
8   Security						    0x000000010c2c0794 SecurityPrefDebugLog + 10681
9   CoreFoundation					  0x00007fff83ba2b8a _CFXNotificationPost + 2554
10  Foundation						  0x00007fff846cba76 -[NSNotificationCenter postNotificationName:object:userInfo:] + 64
11  AppKit							  0x00007fff89014aa0 -[NSTableView _sendSelectionChangedNotificationForRows:columns:] + 176
12  AppKit							  0x00007fff88ff9cdc -[NSTableView _enableSelectionPostingAndPost] + 411
13  AppKit							  0x00007fff88ffad4b -[NSTableView _doSelectIndexes:byExtendingSelection:indexType:funnelThroughSingleIndexVersion:] + 3082
14  Security						    0x000000010c2a36ce Security + 22222
15  System Preferences				  0x000000010c0c4c4b System Preferences + 35915
16  System Preferences				  0x000000010c0c3bf4 System Preferences + 31732
17  Foundation						  0x00007fff846f5fe5 __NSFireDelayedPerform + 358
18  CoreFoundation					  0x00007fff83bad4b4 __CFRUNLOOP_IS_CALLING_OUT_TO_A_TIMER_CALLBACK_FUNCTION__ + 20
19  CoreFoundation					  0x00007fff83bacfcd __CFRunLoopDoTimer + 557
20  CoreFoundation					  0x00007fff83b927b9 __CFRunLoopRun + 1513
21  CoreFoundation					  0x00007fff83b91dd2 CFRunLoopRunSpecific + 290
22  HIToolbox						   0x00007fff83346774 RunCurrentEventLoopInMode + 209
23  HIToolbox						   0x00007fff83346454 ReceiveNextEventCommon + 166
24  HIToolbox						   0x00007fff833463a3 BlockUntilNextEventMatchingListInMode + 62
25  AppKit							  0x00007fff88ea9fa3 _DPSNextEvent + 685
26  AppKit							  0x00007fff88ea9862 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128
27  AppKit							  0x00007fff88ea0c03 -[NSApplication run] + 517
28  AppKit							  0x00007fff88e45656 NSApplicationMain + 869
29  libdyld.dylib					   0x00007fff878f67e1 start + 0
30  ???								 0x0000000000000002 0x0 + 2
)
15/07/12 8:53:43.815 PM com.apple.launchd.peruser.501[167]: (com.apple.UserEventAgent-Aqua[423]) Could not setup Mach task special port 8: (os/kern) invalid argument
15/07/12 8:53:47.722 PM blued[425]: kBTXPCUpdateUserPreferences gConsoleUserUID = 501
15/07/12 8:53:47.727 PM UserEventAgent[423]: +[CLLocationManager appsUsingLocationWithInfo]: unrecognized selector sent to class 0x108220ea8
15/07/12 8:53:47.727 PM UserEventAgent[423]: *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '+[CLLocationManager appsUsingLocationWithInfo]: unrecognized selector sent to class 0x108220ea8'
*** First throw call stack:
(
0   CoreFoundation					  0x00007fff83bf0716 __exceptionPreprocess + 198
1   libobjc.A.dylib					 0x00007fff8b708470 objc_exception_throw + 43
2   CoreFoundation					  0x00007fff83c86bba +[NSObject(NSObject) doesNotRecognizeSelector:] + 186
3   CoreFoundation					  0x00007fff83bdec3e ___forwarding___ + 414
4   CoreFoundation					  0x00007fff83bdea28 _CF_forwarding_prep_0 + 232
5   LocationMenu					    0x00000001081d53be UserEventAgentFactory + 1614
6   LocationMenu					    0x00000001081d51b0 UserEventAgentFactory + 1088
7   LocationMenu					    0x00000001081d5119 UserEventAgentFactory + 937
8   UserEventAgent					  0x000000010667232f UserEventAgent + 4911
9   libdyld.dylib					   0x00007fff878f67e1 start + 0
10  ???								 0x0000000000000002 0x0 + 2
)
15/07/12 8:53:48.088 PM UserEventAgent[11]: Captive: [UserAgentDied:139] User Agent @port=26515 Died
15/07/12 8:53:48.088 PM blued[425]: -[CBManager init] init returning self:0x7fbfbba00160
15/07/12 8:53:48.089 PM com.apple.launchd.peruser.501[167]: (com.apple.UserEventAgent-Aqua[423]) Job appears to have crashed: Abort trap: 6
15/07/12 8:53:48.089 PM com.apple.launchd.peruser.501[167]: (com.apple.UserEventAgent-Aqua) Throttling respawn: Will start in 6 seconds
15/07/12 8:53:48.198 PM ReportCrash[420]: Saved crash report for UserEventAgent[423] version 46.17 to /Users/karl/Library/Logs/DiagnosticReports/UserEventAgent_2012-07-15-205348_Karls-Mac-Pro.crash
15/07/12 8:53:48.199 PM ReportCrash[420]: Removing excessive log: file://localhost/Users/karl/Library/Logs/DiagnosticReports/UserEventAgent_2012-07-15-205020_Karls-Mac-Pro.crash

Edited by The Hulk, 15 July 2012 - 10:54 AM.


#2
nyolc8

nyolc8

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 802 posts
  • Gender:Male
  • Location:Budapest, Hungary
I would try to make a new account and see if the problem is present from that account too.

#3
karlcloudy

karlcloudy

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
  • Gender:Male
Yeah, I had tried that. Since then I've done a little bit of experimentation and have come to the conclusion the migration definitely was the cause. I reinstalled without doing the migration, checked the Security & Privacy pane again and it worked. Then did the migration using the Migration Assistant, but this time with Settings deselected. It still broke the Security & Privacy pane, so I'm not sure what the go is there. I'll probably stick with a clean install, but would have been nice to be able to migrate.

#4
Dysphoria

Dysphoria

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
  • Gender:Male
  • Location:The Netherlands
  • Interests:Photography, Music
I am currently experiencing the same problem. I worked out the following to be able to run non-appstore apps:

I first tried this, which had no success:
sudo spctl --disable

After that I tried this and it looked like the systems were still active:
sudo spctl --status

Then I used this and I could open any App I wanted:
sudo spctl --master-disable

#5
Bandes

Bandes

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 103 posts
  • Gender:Male
I have same problems, same error getting filled into Console constantly. More info here : http://www.insanelym...dpost&p=1839656





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy