Jump to content

com.apple.pkg.SIUResources not found


  • Please log in to reply
16 replies to this topic

#1
Zulakis

Zulakis

    InsanelyMac Protégé

  • Members
  • PipPip
  • 54 posts
When clicking the 'Install' button i get the following Screen:

The following required components were not found on installation disc:
	 Essential System Software

In the console it says
Required package com.apple.pkg.SIUResources  not found for item EssentialSystemSoftwareGroup

My /System/Installation/Packages is okay, i md5sum-checked it.

How could i possibly fix this?

#2
tsoifamily

tsoifamily

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
same here, missing SIUResources.pkg, i tried copying the package from dp4 image and it seems to work quite fine, though not sure if there're any side effects

#3
Zulakis

Zulakis

    InsanelyMac Protégé

  • Members
  • PipPip
  • 54 posts

same here, missing SIUResources.pkg, i tried copying the package from dp4 image and it seems to work quite fine, though not sure if there're any side effects


Could you possibly send me this file? I don't want to download the whole dmg for a single file..

#4
tsoifamily

tsoifamily

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
just redownloaded the whole GM dmg, still missing SIUResources.pkg.

attached is from Mountain Lion DP4, you could just copy it over to /system/installation/packages

note: couldn't attach it here, so i'll attach a link instead: https://rapidshare.c...IUResources.zip

#5
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
My GM does not have it either, it is System Image Utility and in DP4 would install to /Library/Application Support/Apple/System Image Utility/
The GM installed fine without it and this file does not exist on my final installation, I don't believe it was every actually installed in DP4 either.

#6
Blake182

Blake182

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
I also am having this problem. I placed the package in the folder and the installer lets me advance but nothing is installed and everything basically crashes. Is anyone else experiencing this?

#7
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
OK, for all who are having this problem, I'll bet money it has to do with OSInstall.mpkg. If your not installing onto a MBR drive, don't touch it when you make your USB installer and just use the version that comes with the GM. The list of Essential System Software lives inside that package and up until the GM, that included SIUrecources. If your using a patched OSInstall.mpkg referenced in one of the tutorials out there, it will expect that SIUresources be one of the required packages, but in reality it is no longer part of the installation. The patched OSInstall is only needed for MBR installs so half of you who are using GUID GPT don't need it anyway. If you are installing to MBR because Windows is on the same drive, then try manually adding the SIUresouce.pkg to your installer.

#8
Blake182

Blake182

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
That's what I was figuring. I have MBR and I had already played around with the different OSInstall replacements and originals. I suppose I'll just wait until the official release and see how it goes.

#9
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
well, I was about to edit it for ya'll last night but I fell asleep. gimme a little bit and I'll see what I can do, I won't be able to test it myself cause I'm not gonna reinstall to a MBR to try.

#10
Blake182

Blake182

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
I'll definitely try it! When I posted the one from the link above (from DP4) it gave me all kinds of errors and wouldn't install anything.

#11
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
OK, edited the Distributions file which is a pre-install script, gotta figure out how to put everything back into a .mpkg that won't cause the installer to throw a fit. Gonna be looking into that part with maybe a little help from TH3L4UGH1NGM4N , but gotta take off for a little while in a couple mins. In the mean time, if you have another HD, internal or external drive that can be formatted GUID, you can use the OSinstall and OSinstall.mpkg from ML GM and not any of the downloaded patched ones, then clone the completed install over to MBR after it's done.

#12
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
OK MBR lovers, I haven't been able to test this and don't want to install on an MBR to try it, but I edited the Distribution file in OSInstall.mpkg to remove the SIURecources check and re-packaged it, in theory it should work unless I overlooked something or goofed on the permissions. Let me know if she works.

Attached File  OSInstall_mpkg.zip   200.48KB   79 downloads

#13
Hackintosh2000

Hackintosh2000

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 171 posts
  • Gender:Male
  • Location:Unites States of America

OK MBR lovers, I haven't been able to test this and don't want to install on an MBR to try it, but I edited the Distribution file in OSInstall.mpkg to remove the SIURecources check and re-packaged it, in theory it should work unless I overlooked something or goofed on the permissions. Let me know if she works.

Attached File  OSInstall_mpkg.zip   200.48KB   79 downloads


Didn't work for me. Anyone else having issues? GM worked fine for me with the MBR patched files I found on the net, but once I tried the retail version I got this error...

OS X install data is incomplete.

The following required components of OS X were not found on an installation disc:

Essential System Software

OS X cannot be installed.



#14
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
good to know, lemme take a second look at that.....wait a min/ retail and GM are the same build # tho, why even reinstall? I haven't even bothered downloading my copy of retail yet for that reason

#15
Hackintosh2000

Hackintosh2000

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 171 posts
  • Gender:Male
  • Location:Unites States of America

When clicking the 'Install' button i get the following Screen:

The following required components were not found on installation disc: Essential System Software
In the console it says
Required package com.apple.pkg.SIUResources not found for item EssentialSystemSoftwareGroup
My /System/Installation/Packages is okay, i md5sum-checked it. How could i possibly fix this?

same here, missing SIUResources.pkg, i tried copying the package from dp4 image and it seems to work quite fine, though not sure if there're any side effects

OK, for all who are having this problem, I'll bet money it has to do with OSInstall.mpkg. If your not installing onto a MBR drive, don't touch it when you make your USB installer and just use the version that comes with the GM. The list of Essential System Software lives inside that package and up until the GM, that included SIUrecources. If your using a patched OSInstall.mpkg referenced in one of the tutorials out there, it will expect that SIUresources be one of the required packages, but in reality it is no longer part of the installation. The patched OSInstall is only needed for MBR installs so half of you who are using GUID GPT don't need it anyway. If you are installing to MBR because Windows is on the same drive, then try manually adding the SIUresouce.pkg to your installer.


My bad guys. I remember what I did. I got my MBR patch files from HERE. Just copy them to the appropriate folders and replace the files when asked. Works like a charm on retail.

#16
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
THERE YOU GO! someone's already done it. I can't even DL the Retail cause it says my Dev redeem code's already been used from when I DL'ed the GM, so they gotta be the same.

#17
Elad Nava

Elad Nava

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
Thanks it solved my problem!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy