Jump to content

[HELP] Error Creating Installer with myHack

myHack installer

  • Please log in to reply
9 replies to this topic

#1
Marta Reis

Marta Reis

    InsanelyMac Protégé

  • Donators
  • 25 posts
  • Gender:Female
  • Interests:video editing, photography, color grading
Hi,

I'm using myHack to create the installer but I always get the same error message...

Mounting InstallESD.dmg
2012-07-05 22:17:34.034 defaults[3197:b07] The domain/default pair of (/Volumes/Mac OS X Install ESD/System/Library/CoreServices/SystemVersion, ProductVersion) does not exist ERROR: Selection does not appear to be a valid OS X installation source.
Exiting.


:wallbash:

The Lion.app or InstallESD.dmg is not corrupted. I've used different files but I always got the same error. I can mount the dmg file normally and run lion.app. The files only became corrupted after I use myhack.

I'm using a USB stick and a macbook running 10.6.8.

Any clue of what might be wrong?

Thx

#2
Hangten

Hangten

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 403 posts
  • Gender:Male
  • Location:Laguna Beach, CA.
http://www.insanelym...howtopic=256729

Try this method see if you get past your glitch.

#3
TheRacerMaster

TheRacerMaster

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 189 posts
  • Gender:Male
Are you mounting the DMG by yourself? If you are, stop doing it and let myHack do everything. Verify that the DMG is InstallESD.dmg (the volume name should Mac OS X Install ESD) and not something else.

#4
Marta Reis

Marta Reis

    InsanelyMac Protégé

  • Donators
  • 25 posts
  • Gender:Female
  • Interests:video editing, photography, color grading
I'm letting myHack do everything. I'm just using the browser to locate the file once it is not able to do that.

Verify that the DMG is InstallESD.dmg (the volume name should Mac OS X Install ESD) and not something else.


I can't download the file from apple store it says I need a more powerfull machine. I'm just using this macbook to create he installer. But I'm using the same file you purchase online, exactly the same.

I've download two different files of that version of Lion and used them with myHack... the same error ocurred. Two different downloads, two different files but still the same error on myHack, which is beyond strange. I can assure you I could mount and run those same applications without any kind of error which is even more strange.

I really want to use myHack but I'm almost giving up. I guess I will be forced to use the method Hangten suggested on one of these posts.

Do you suggest something else?

#5
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Have you looked to see that the 2 files in that error message are present on the completed install USB? They are responsible for making sure your hardware is a mac that meets the minimum system requirements and a good, valid smbios is needed to pass the machine check. So make sure you have one, Chameleon Wizard can help you generate one. It will need to go in /Extra on the install USB. I can get u new copies of both those files to copy over to the USB manually and replace the 2 that are corrupt or missing, but need to know what version of Lion you have i.e. 10.7.3, 10.7.1 etc.

#6
Marta Reis

Marta Reis

    InsanelyMac Protégé

  • Donators
  • 25 posts
  • Gender:Female
  • Interests:video editing, photography, color grading
:) :thanks_speechbubble:

Can u get me a new copie for Lion 10.7.3?

#7
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
should just need this one https://dl.dropbox.c...emVersion.plist it has product version in it. Copy to same file path as the error message in your first post.

#8
Marta Reis

Marta Reis

    InsanelyMac Protégé

  • Donators
  • 25 posts
  • Gender:Female
  • Interests:video editing, photography, color grading

Copy to same file path as the error message in your first post



I'm not sure if I understood that right but I'll try it.

#9
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff

I'm not sure if I understood that right but I'll try it.

/Volumes/Mac OS X Install ESD/System/Library/CoreServices/SystemVersion
or /Volumes/Mac\ OS\ X\ Base\ System/System/Library/CoreServices/SystemVersion

#10
jmangelini

jmangelini

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hello,

I had this problem, and it is solved:
my purchased download had something wrong: was the good size, was able to install OSX, but a checksum was not good.
Downloaded it again, and now it is ok.
To check, right clic on the install mountain lion app, then "show contents", go to shared support > InstallESD.dmg
Try to mount it: it is verified, then you may have something about cjecksum error.

Good luck.





Also tagged with one or more of these keywords: myHack, installer


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy