Jump to content

AMD dual graphics 6950 supported


  • Please log in to reply
94 replies to this topic

#1
manor

manor

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 312 posts
  • Gender:Male
AMD dual graphics 6950 supported
Hi ALL
all credit goes to Netkas/Andy/chameleon team Ermac
This 7 kexts support 6950/6970 to mac osx 10.7.x and 10.8
just install via kext wizard.
before install delete Amdraden kexts.
AMDRadeonAccelerator.kext
After install kexts set GraphicsEnabler=Yes.
MY dual cards works v.well. more info look my ioreg files.
Allso windows7 supported crossfire
All but 2 monitors must be connected to the DP ports on the AMD graphics card, and be able to
support the required resolution. The 2 exceptions can be connected to the DVI or HDMI ports.
The monitors connected to the DP ports can be connected with DP cables, or using AMDrecommended
active adapters to DVI or HDMI ports on the monitors.
Where multiple graphics adapters are installed, Eyefinity groups cannot span across multiple
adapters. With cross-fire enabled, only monitors connected to the primary card will be enabled.
NOTE-10.8 dp4 this kexts not 100%support.

http://www.mediafire...yg175ou2sqt52z3


10.8.2

I have 2x6950
bios setting
Init display first-2nd card
and look my dsdt also.you have to set SMBios.plist Model Identifier: MacPro5,1
http://www.mediafire...z3buzhxu960w7e2

Attached Files



#2
TH3L4UGH1NGM4N

TH3L4UGH1NGM4N

    (~_~)

  • News Team
  • 1,154 posts
  • Gender:Male
  • Location:Wonderland
  • Interests:(~_^)
So I take it that boot loader you used inside the "loder" folder can recognize more than 1 gpu in a pcie slot if I'm not mistaken?

Congrats btw on the dual 6950 working. :star_sunglasses:

#3
manor

manor

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 312 posts
  • Gender:Male
10.7.5 worked now


remove

/System/Library/PrivateFrameworks/GPUSupport.framework

replace

you have to replace mac pro 10.7.4

/System/Library/Frameworks/OpenGL.framework
/System/Library/Frameworks/OpenCL.framework

install this

http://www.mediafire...yg175ou2sqt52z3

GraphicsEnabler=Yes
install without ati_init
enjoy.

Attached Files



#4
telepati

telepati

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
  • Gender:Male
  • Location:istanbul
Sorry but I dont get it? 10.7.5 not release yet is this work with 10.7.4 and how to use ioreg and loder files? And I confused which one I remove which one replace?

1) I will delete /System/Library/PrivateFrameworks/GPUSupport.framework in 10.7.5 right?
2) I will get this 2 files on 10.7.4 and replace with in 10.7.5 right?
/System/Library/Frameworks/OpenGL.framework
/System/Library/Frameworks/OpenCL.framework

#5
manor

manor

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 312 posts
  • Gender:Male

Sorry but I dont get it? 10.7.5 not release yet is this work with 10.7.4 and how to use ioreg and loder files? And I confused which one I remove which one replace?

1) I will delete /System/Library/PrivateFrameworks/GPUSupport.framework in 10.7.5 right?
2) I will get this 2 files on 10.7.4 and replace with in 10.7.5 right?
/System/Library/Frameworks/OpenGL.framework
/System/Library/Frameworks/OpenCL.framework

this for 10.7.5 look screen shots
remove
GPUSupport.framework
update
copy 10.7.4 to replace10.7.5
OpenGL.framework
OpenCL.framework

ioreg for pi of cake just look.

#6
telepati

telepati

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
  • Gender:Male
  • Location:istanbul
Still going cold boot this with kext?

#7
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
I'm running 10.7.5 on my macbook. Must be magic :)

#8
LargeFormat

LargeFormat

    InsanelyMac Protégé

  • Members
  • Pip
  • 18 posts

10.7.5 worked now


remove

/System/Library/PrivateFrameworks/GPUSupport.framework

replace

you have to replace mac pro 10.7.4

/System/Library/Frameworks/OpenGL.framework
/System/Library/Frameworks/OpenCL.framework

install this

http://www.mediafire...yg175ou2sqt52z3

GraphicsEnabler=Yes
install without ati_init
enjoy.


This sounds like a fix but I am confused on how to implement it.

#9
DaviDemon

DaviDemon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts
Could someone post up the 10.7.4 frameworks? I'm trying to get this to work on ML but his instructions are not very clear as to how to install it on ML.
Thannks

#10
nexx892

nexx892

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Hey man, so this works, on hackintoshes, in mountain lion dp3?

Is this true?

#11
telepati

telepati

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
  • Gender:Male
  • Location:istanbul
will I remove "GPUSupport.framework" before to update 10.7.5?

#12
manor

manor

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 312 posts
  • Gender:Male

will I remove "GPUSupport.framework" before to update 10.7.5?

NO
just copy this file backup your desktop 10.7.4
OpenGL.framework
OpenCL.framework
then update 10.7.5
after 10.7.5 update remove GPUSupport.framework
paste your backup this files
OpenGL.framework
OpenCL.framework
install kexts set GE then restart.

#13
manor

manor

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 312 posts
  • Gender:Male
after update remove all ati kexts then install this
del GPUSUPPORTFRwork

http://www.mediafire...y7lnaxwdxypf72v

#14
moob

moob

    InsanelyMac Protégé

  • Donators
  • 55 posts
  • Gender:Male
  • Location:Fiumicino, Italy
This method works on Lion 10.7.4. I will do shortly a more detailed guide.

Attached Files



#15
telepati

telepati

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
  • Gender:Male
  • Location:istanbul
I try this for ML with Sapphire 6950 2GB and its work with GraphicsEnabler=No. But many features are lagging misson control, dashboard notification etc. And no bluetooth for me.

#16
moob

moob

    InsanelyMac Protégé

  • Donators
  • 55 posts
  • Gender:Male
  • Location:Fiumicino, Italy

I try this for ML with Sapphire 6950 2GB and its work with GraphicsEnabler=No. But many features are lagging misson control, dashboard notification etc. And no bluetooth for me.


can you post screen like mine with info of system?

#17
telepati

telepati

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
  • Gender:Male
  • Location:istanbul

can you post screen like mine with info of system?


Your Chess and iTunes cover Flow working on 10.7.4 ? Mine 10.8 is look like this;
Attached File  Screen Shot 2012-07-30 at 1.12.54 AM.png   580.78KB   261 downloads

#18
moob

moob

    InsanelyMac Protégé

  • Donators
  • 55 posts
  • Gender:Male
  • Location:Fiumicino, Italy

Your Chess and iTunes cover Flow working on 10.7.4 ? Mine 10.8 is look like this;
Attached File  Screen Shot 2012-07-30 at 1.12.54 AM.png   580.78KB   261 downloads


nope. anyway you don't have hardware acceleration enabled... Have you replace the "boot" file with that into folder?

#19
telepati

telepati

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
  • Gender:Male
  • Location:istanbul

nope. anyway you don't have hardware acceleration enabled... Have you replace the "boot" file with that into folder?


I delete AMDRadeonAccelerator.kext and I changed the boot with latest chameleon! If I dont delete AMDRadeonAccelerator.kext I get just white screen.

#20
manor

manor

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 312 posts
  • Gender:Male
same thing 4me 12A269 no video memory if GE=yes

navaratnams-Mac-Pro:~ manoranjan$ ioreg | grep ATY
| | | | +-o ATY,Gibba@0 <class AtiFbStub, id 0x100000347, registered, matched, active, busy 0 (3 ms), retain 8>
| | | | +-o ATY,Gibba@1 <class AtiFbStub, id 0x100000348, registered, matched, active, busy 0 (0 ms), retain 8>
| | | | +-o ATY,Gibba@2 <class AtiFbStub, id 0x100000349, registered, matched, active, busy 0 (0 ms), retain 8>
| | | | +-o ATY,Gibba@3 <class AtiFbStub, id 0x10000034a, registered, matched, active, busy 0 (0 ms), retain 8>
| | | | +-o ATY,Gibba@4 <class AtiFbStub, id 0x10000034b, registered, matched, active, busy 0 (0 ms), retain 8>
| | | | +-o ATY,Gibba@0 <class AtiFbStub, id 0x100000369, registered, matched, active, busy 0 (1 ms), retain 8>
| | | | +-o ATY,Gibba@1 <class AtiFbStub, id 0x10000036a, registered, matched, active, busy 0 (0 ms), retain 8>
| | | | +-o ATY,Gibba@2 <class AtiFbStub, id 0x10000036b, registered, matched, active, busy 0 (0 ms), retain 8>
| | | | +-o ATY,Gibba@3 <class AtiFbStub, id 0x10000036c, registered, matched, active, busy 0 (0 ms), retain 8>
| | | | +-o ATY,Gibba@4 <class AtiFbStub, id 0x10000036d, registered, matched, active, busy 0 (0 ms), retain 8>
navaratnams-Mac-Pro:~ manoranjan$





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy