Jump to content

[Help] Installing Snow Leopard on P4 Gateway 510x


  • Please log in to reply
2 replies to this topic

#1
Rowas

Rowas

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
Hello. I am a new user in this forum, but I am already somewhat familiar with osx86, its credo and methods. I have successfully installed Mac on a number of computers, but this one is a little out of the norm.

I have an old computer that I wish to attempt to install Mac on, and I know for sure that it is possible. I need to find out the method that works for this one. The complete specs are below:


Computer model: Gateway 510 X
CPU: Pentium 4 2.8 GHz (sse2)
Graphics: Integrated Graphics (Intel Extreme Graphics 2), Gfx acceleration not necessary
Memory: 1 GB DDR SDRAM 333 MHz
Chipset: Intel 865PE
Install Method: iAtkos S3 V2
Selected options:
32 bit boot
Ethernet
32 bit RTC
qoopz 10.3
Intel SATA/IDE
Apple Ps/2
Other: Nawcom ModCD as Bootloader (This is the only bootloader that allow full boot into the system)

I have included a video right Here to give a visual of the problem described below.

Previously, I wanted to install Leopard into the system as I assumed that it would be an easier load to handle, but repeated efforts have been met with disappointment. After a brief time installing Linux/Windows XP and trying to get a VMWare image of leopard to run, I came back to the original plan of a "real" installation.

A quick search in youtube showed the iAtkos S3 v2 (which is the only one that has actually worked for me in the past) distribution running on a pentium 4. I gave it a shot.
The installer would boot fine, but the installation itself would hang, so I installed the system externally.
I later found out that any attempt to use the bootloader would not work. It would give me a machine check state, errors, etc. Keep in mind that I do use 32 bit boot and verbose to view the errors.
When I use Nawcom ModCD to boot the system, it boots fine. I was actually able to copy the exact bootloader to the system and boot it natively, however here is where the trouble starts...

The boot cd boots with a default "legacy_kernel" which I believe may be the cause of these issues, but I can boot into the system and use it somewhat. However, I get frequent kernel panics even when I navigate through finder.

What I need now is to find if there is another kernel made for this processor that I can use to make the system stable, and I also need to learn how to use kernels. If anyone can assist me with this, it would be great.

ALSO! I am still okay with the prospect of installing 10.5 Leopard. I just need an installation that works and that is stable. If you know a method that will work better, that will be just as good. Thank you very much. :)

Notes:

I am aware that the graphics are ancient and some of the colors are messed up as you can see in the video, but that isn't important. I am just interested in getting the system running and keeping it stable.

#2
Rowas

Rowas

    InsanelyMac Protégé

  • Members
  • Pip
  • 36 posts
No replies? That's fine. I seem to have resolved this issue. I have not experienced any new kernel panics after installing iAtkos again.

The only difference between this installation and the first installation I made was the RTC. I decided to leave the default RTC and it worked fine.

The system runs pretty well despite the fact that this is older hardware. The only bugs are difficulty mounting and unmounting devices.

There is one thing that I need assistance with and that concerns networking. As that would count as a post-installation issue, I will make a new post in the post-installation forum. Nonetheless, thank you for reading and I hope my experience serves to somewhat guide others in the future. Thank you for reading.

EDIT: Just as a side note, I installed the system on a SATA drive, but I found an old IDE drive lying around that would serve the purpose I had in mind for the computer better. I'm going to re-attempt the installation on the IDE drive and I will post any issues if they arise.

#3
awsk8

awsk8

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Hello,
I have the same desktop, and have been having some trouble installing snow leopard. I was wondering if you could write a tutorial on what worked for you on this computer. Thanks in advance.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy