Jump to content

Virus eingefangen?


  • Please log in to reply
3 replies to this topic

#1
pilsator

pilsator

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 200 posts
Mein Desktop-Hackintosh (10.6.8) spinnt nach einem Jahr problemlosen Betriebs total.
Ich habe den Eindruck, dass der Ärger losgeht, wenn ich Java-basierte Programme starte, z.B. Vuze oder JDownloader. Das Programm bleibt hÄngen. Dann legt spotlight los, indexiert die Platte und irgendwann friert der Rechner ein. So hat es angefangen. Kein Problem, dachte ich, wozu habe ich ein zweites System auf einer anderen Partition installiert. Also starte ich von dieser Partition, aber gleich fÄngt spotlight wieder an zu indexieren. DiskWarrior, die aktuelle Version, lÄsst sich auf einmal nicht mehr starten. Das Festplattenhilfsprogramm ging noch, fand und behob einige Probleme auf der anderen Partition. Danach bootete ich von der Standardpartition, es klappte, reparierte die Reservepartition mit DiskWarrior, bootete von der Reserverpartition, DiskWarrior ging wieder, reparierte die Standardpartition und der Drops schien gelutscht. (Die Zugriffsrechte habe ich natürlich auch ein paar mal reparieren lassen und ausserdem ausserdem das aktuelle Java-update und Sicherheitsupdate installiert.)
Bis ich heute von der Standardpartition gebootet und JDownloader gestartet habe. Danach ging das Theater wieder von vorne los.
Ich weiss, dass man auf einen Virus unter OSX zuletzt tippen sollte. Merkwürdig ist nur, dass eine Partition die andere anzustecken scheint. Vorhin habe ich von einer USB-Platte unter 10.7 gebootet und die zeigt jetzt die gleichen Symptome.
Ich hÄtte eigentlich angenommen, dass Viren oder Trojaner sich heutzutage unauffÄllig verhalten. Das hier sieht wie ein klassischer Kaputtmacher aus.
Ich fasse zusammen: nach jedem Neustart rödelt spotlight wie blöd als ob die Platte nicht gerade eben indexiert worden wÄre, ein System infiziert anscheinend das andere und DiskWarrior kann das Problem nicht lösen.
Smart Tools meldet keine Hardwareprobleme mit der Platte.

Kommt das jemandem bekannt vor? Ich sehe im Moment keine andere Lösung als die Systempartitionen zu löschen und alles neu zu installieren, würde mir das aber lieber ersparen.

#2
lazybon3

lazybon3

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
Also ganz ehrlich gesagt,

Ich glaube nicht dass es sich um einen Virus handelt. Bei einem echtem Mac würde ich bei so einem Verhalten darauf schließen dass Festplatte oder Festplattenkabel defekt sind.
Versuch das ganze doch einfach einmal mit einer anderen Festplatte (wenn du eine herumliegen hast). Sonst schließe deine Festplatte mal extern via USB Adapter an und versuche davon zu starten.

Wie gesagt, Virus wäre jetzt zwar nicht komplett unmöglich, aber die Wahrscheinlichkeit ist derart gering, dass die Ursache vermutl. wirklich eher die Festplatte bzw. das Kabel zur Platte ist.
Wenn du 10.6.8 verwendest stelle sicher dass auch alle Softwareaktualisierungen installiert sind, dann sollte dein Rechner auch nicht ohne deine Mithilfe angreifbar sein.

PS: Da es sich ja um keinen echten Mac handelt könnte es auch bei einem Hackintosh eher 100e von anderen Ursachen ausser einem Virus haben, viel Spass beim Fehlersuchen.

lg

#3
pilsator

pilsator

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 200 posts
Ich hatte den gleichen Verdacht und wie gesagt deshalb von einer USB-Platte gebootet, die daraufhin auf einmal auch schwer gezickt hat, was sie vorher nie gemacht hatte.
Die Standardplatte ist via eSata angeschlossen, da gibt es nicht selten Kabelprobleme, hat es auch schon gegeben, aber das habe ich mit Smart Tools geprüft und mit der Hardware einschliesslich Kabel und fest sitzenden und nicht wackelnden Steckern scheint alles in Ordnung zu sein.
Ich kann mir demnächst die desinfect DVD ausleihen, vielleicht finde ich die auch im Netz. Keine Ahnung ob damit auch OSX Viren aufzuspüren sind, aber versuchen kann ich es ja mal.

#4
Meowpard

Meowpard

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:north of .de
Vielleicht sind einfach nur mal die Zugriffsrechte und-oder das Volume zu reparieren?
Das ist immer die erste empfohlene Aktion, wenn ein Hackintosh neu installiert wird. Jedenfalls Zugriffsrechte reparieren.

Mit der Desinfect wird es auf HFS+ sicher nichts zu scannen geben. Die erkennt meines Wissens nur NTFS, FAT und EXT2/3.

Bei Intego gibt es eine 30-Tage-Demoversion von VirusBarrier X6.
Würde ich aber auf einem sauberen System installieren und von dort aus die verdächtigen Volumen scannen.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy