Jump to content

SL 10.6.8 - USB Storage Devices

usb devices 10.6.8 amd

  • Please log in to reply
1 reply to this topic

#1
JosephXM

JosephXM

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
SOLVED.

Hi, I've recently managed to get OS X SL up and running on my AMD PC. I've been able to overcome most problems myself but this one has me a bit lost.

This thread in a nutshell: Upon updating to 10.6.8, USB mass storage devices are not recognised, while peripherals are.

Specs are as follows:
  • ASRock 970 Extreme3
  • AMD Phenom II X4 960T Quad Core
  • 8GB Kingston HyperX Genesis RAM (using maxmem=4096 to avoid CPU halt)
  • Bunch of old Seagate 80GB HDDs (SATA set to AHCI)
  • PowerColor Radeon HD6850 1GB
  • Installed Snow Leopard 10.6.2 Hazard
Okay, so I managed to install Hazard's 10.6.2 DVD. I then followed a guide to update to 10.6.8. In this guide, it suggested you use ####### to install "IOUSBFamilyRollback" (back to the 10.6.2 USB I imagine).

On reboot, everything worked, graphics acceleration, sound, ethernet etc. Apart from USB. It worked fine in 10.6.2, but now it's just not working at all. USB mouse and keyboard work fine, no problems with them, but devices such as USB HDDs and memory sticks just aren't recognised at all.

After extensive searching, I found some other people with similar problems. One guy tried installing a newer IOUSBFamily.kext, however this didn't work for me. Another used the flags "USBLegacyOff=Yes" and "USBBusFix=Yes" which worked for him. Another possible solution was to remove "AppleHPET.kext" as it may be conflicting. This didn't work for me either.

In BIOS, I have USB 2.0 and 3.0 enabled, with USB Legacy on. I'm starting to tear my hair out over this, so if anyone has any possible solutions please do share!

Many thanks in advance,

Joseph.

#2
JosephXM

JosephXM

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Fixed my own problem - For anyone having a similar issue:

I deleted IOUSBFamily.kext from S/L/E and ran ####### and selected "IOUSBFamilyRollback" from the selection menu. Upon reboot, USB worked fine!





Also tagged with one or more of these keywords: usb, devices, 10.6.8, amd


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy