Jump to content

Enoch Bootloader

Chameleon Bootloader Enoch

  • Please log in to reply
859 replies to this topic

#801
Vampirexx

Vampirexx

    Cyborg Ninja

  • Members
  • PipPipPipPipPipPipPip
  • 643 posts
  • Gender:Male
  • Location:Italy
  • Interests:Aikido, Ninpo/Ninjutsu, Rock n roll, Mac OS X
grazie per avermi risposto. volevo offrirti una birra per il tuo aiuto in segno di amicizia e per avere un tuo sguardo da esperto. se non sbaglio ho letto un tuo thread dove avevi risolto il problema con una ati 6670 ma modificando il config di clover. ho provato con dsdt ma non sono espertissimo e non ho risolto la cosa. infatti l iniezione di Enoch è funzionale e comodissima purtroppo con il personality caricato non funziona a dovere, almeno per me. ti volevo chiedere se hai deciso di eliminare il caricamento del framebuffer generico nella prox release e come mai o se era solo una prova in beta. grazie mille

#802
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,752 posts
  • Gender:Male
  • Location:Canary Islands

Chameleon ed Enoch sono stati aggiornati sull'SVN ufficiale alla versione (attuale 2387)
 
In via ancora non ufficale ho caricato nella sezione download le versioni "speciali" che supportano l'avvio di Yosemite
 

10.10.png

Tali versioni non sono ancora presenti ufficialmente dovuto al fatto che Yosemite è ancora in fase di sviluppo, durante questa fase
si può definire tali versioni come versioni RC (Release Candidate), quando verra distribuito ufficialmente il nuovo sistema operativo e verrà confermato il corretto funzionamento di chameleon e i suoi derivati verranno rilasciati i sorgenti.
 
Il supporto a Yosemite è stato possibile grazie a:
- Pike R. Alpha
- ErmaC
- Bungo
- blackosx
- Micky1979
- crazybirdy
- oldnapalm
- janek202

 

Senza il loro prezioso contributo tutto ciò non sarebbe stato possibile.

Trovate i binari e gli installer nella sezione Download

Chameleon -> http://www.insanelym...ameleon-22-svn/

Enoch -> http://www.insanelym.../file/71-enoch/

 

Buon Hack

 

ErmaC



#803
Alex//3oo1

Alex//3oo1

    Cheesecake Destroyer

  • Pandora Team
  • 11,629 posts
  • Gender:Male
  • Location:Lodi

 Il supporto a Yosemite è stato possibile grazie a:

- Pike R. Alpha
- ErmaC
- Bungo
- blackosx
- Micky1979
- crazybirdy
- oldnapalm
- janek202

 

Sempre grandi......grazie ragazzi



#804
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 8,907 posts
  • Gender:Male
  • Location:Italy

Il supporto a Yosemite è stato possibile grazie a:
- Pike R. Alpha
- ErmaC
- Bungo
- blackosx
- Micky1979
- crazybirdy
- oldnapalm
- janek202

Come sempre Ottimo Lavoro Ringrazio tutti.

Fabio

#805
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 2,091 posts
  • Gender:Male
  • Location:Roma

Grazie ragazzi  :yes: per il vostro lavoro svolto come sempre egregiamente



#806
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 2,091 posts
  • Gender:Male
  • Location:Roma

@Ermac 

Si potrebbe fare qualcosa su un bug che si presenta con la mia AMD r9 270x sia in Enoch che con Chamaleon

 

appena istallata mi ha dato boot0 error con caratteri incomprensibili noto anche alla serie Amd 7000 ma non ha tutte come leggo in giro,

ho provato a ripetere più' volte la procedura per togliere l'errore seguendo la FAQ di Fabio ma non ne vuole sapere

 

addirittura mi ritrovo con tutte le usb di pandora istaller inaccessibili sempre per lo stesso motivo anche queste ho provato a rifarle più volte ma niente

 

allora ho messo Clover che per me è una tragedia, dovendolo istallare in legacy , win non riesce a partire( o a meno che ci sia un modo, essendo nibbio in materia) e non posso permerttermi di ristallare i miei sistemi in UEFI e rischiare di perdere dei dati importantissimi  e lavori in completamento

 

In attesa 

 

carlo_67



#807
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,752 posts
  • Gender:Male
  • Location:Canary Islands

@Ermac 

Si potrebbe fare qualcosa su un bug che si presenta con la mia AMD r9 270x sia in Enoch che con Chamaleon

 

appena istallata mi ha dato boot0 error con caratteri incomprensibili noto anche alla serie Amd 7000 ma non ha tutte come leggo in giro,

ho provato a ripetere più' volte la procedura per togliere l'errore seguendo la FAQ di Fabio ma non ne vuole sapere


carlo_67

 

 

Ciao Carlo.... anche se in ritardo...

Domanda... essendo "utente" nvidia non saprei in linea generale come risolvere il problema dei simboli "strani"

ma se non ricordo male non si ovviava a tale problema con una iniezione diretta da DSDT?

Forse e dico forse (vado a memoria) il problema risiede in alcuni ID per determinate schede (mi riferisco al device-id non ai vari subs)

Una possibile idea per "aggirare" il problema da chameleon l'avrei in mente, e sarebbe quella di dargli in pasto un ID che si avvicini come caratteristiche a quello che OS X si aspetti, se sia fattibile a livello di sovrascrittura e "falsificazione dell'ID" non saprei assicurartelo ma potrebbe essere una strada....

Tutto questo se e sempre se il problema si risolve come accennato ad inizio post con dargli in pasto un ID per mzzo dell'iniezione nel DSDT...

 

Una sorta di FakeAti (potrebbe essere la nuova flag...)

 

Aspetto conferme e smentite prima di mettere mano al codice ed impegnare tempo e risorse che sfortunatamente non ho...

 

ErmaC



#808
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 2,091 posts
  • Gender:Male
  • Location:Roma

Scusa anche a me per il ritardo :) sono appena tornato dalle ferie

comincio a fare delle prove poi ti faccio sapere tenendoti aggiornato



#809
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 2,091 posts
  • Gender:Male
  • Location:Roma

@ ErmaC

 

1° Allora ho provato ad istallare chamaleon su usb inizializata prima in ms-dos  --------- risultato sempre solito errore boot0 error

 

2° provato a cambiare tabella da guid a mbr, ho inizializzato in osx jurnaled e voila' chamaleon parte senza dare problemi  :thumbsup_anim:

 

3° inizializato un Hdisk in MBR, clonato con Carbon c il mio Mavericks 10.9.4 su di esso in modo che non mi copia chamaleon

 

finito di clonare ho istallato chamaleon, ho messo priorità' di boot Hardisk clonato, ed è stato un successo parte chamaleon con tutti i miei sistemi ( Ubuntu-Windows-OsX ) l'errore Boot0 error non si presenta

 

ora mi chiedo che c'entra con tutto questo la scheda Video R9 270,  Mistero

 

faccio altre prove

 

Carlo_67



#810
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 2,091 posts
  • Gender:Male
  • Location:Roma

@ErmaC

risolto il problema Boot error con geroglifici delle schede Ati serie 7000 e r9

basta fare un aggiornamento update con chamaleon wizard, e istallare bootmd nell'hd dove istallato chamaleon /o Enoch 

e voila' si entra da hd senza boot error con geroglifici



#811
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,752 posts
  • Gender:Male
  • Location:Canary Islands

@ErmaC
risolto il problema Boot error con geroglifici delle schede Ati serie 7000 e r9
basta fare un aggiornamento update con chamaleon wizard, e istallare bootmd nell'hd dove istallato chamaleon /o Enoch 
e voila' si entra da hd senza boot error con geroglifici


Bene a sapersi...

Se riesco in serata sincronizzo Enoch con gli ultimi aggiornamenti che abbiamo fatto a Chameleon...

ErmaC

#812
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 2,091 posts
  • Gender:Male
  • Location:Roma

@ErmaC

comunque ho chamaleon aggiornato al 2400



#813
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,752 posts
  • Gender:Male
  • Location:Canary Islands
Enoch aggiornato alla revisione 2403 -> http://www.insanelym.../file/71-enoch/

ErmaC

#814
Perdu

Perdu

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 359 posts
  • Gender:Male
  • Location:Italy

Ciao @ErmaC,  funziona benissimo la revisione 2403 con Yosemite, ma se metto il disco di yosemite come disco di avvio non riesco ad accedere  agli altri dischi separati che hanno per esempio Mountain Lion e Mavericks arrivano alla schermata della mela e si piantano, e per potervi accedere devo riavviare e premere F8 all'avvio e scegliere il disco, oppure cambiare il disco di avvio da bios, ho paura ad aggiornare il chameleon di Mavericks e Mountain perché se non partono sono guai ho molti documenti.

 

mi potresti dare un consiglio come fare, tieni conto che non sono molto esperto

 

saluti

 

Perdu 



#815
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 2,091 posts
  • Gender:Male
  • Location:Roma

@Perdu hai istallato Enoch anche sul disco dove hai Yosemite?

istalla la stessa versione sugli altri

 

usa la stessa Extra per tutti e il file boot che trovi nella root



#816
Perdu

Perdu

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 359 posts
  • Gender:Male
  • Location:Italy

Ok grazie Carlo



#817
AlexAMD

AlexAMD

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 146 posts

Ciao a tutti, non ho capito se posso usare enoch-bootloader anche su schede madri Uefi .....



#818
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 7,518 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

Ciao a tutti, non ho capito se posso usare enoch-bootloader anche su schede madri Uefi .....

Certo che puoi, ma devi impostare il bios in modalità Legacy



#819
AlexAMD

AlexAMD

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 146 posts

Ciao grazie per la risposta ma volevo proprio usare enoch-bootloader al posto di chimera perché questo lo trovo un po' complicato .... comunque volevo segnalare "forse" un bug nel bootloader enoch : ho preparato la chiavetta usb con Yosemite ma al boot mi chiede System/Library/Kernels/mach_kernel mentre realmente esiste solo il "kernel" quindi non boota bisogna rinominare kernel in mach_kernel ..... il problema poi sarà al riavvio dopo l'installazione di yosemite perché non si riesce a farlo partire sempre per lo stesso problema, per risolverlo bisogna avere un altra installazione di hack per poter rinominare il kernel in mach_kernel nel disco d'installazione......

Quindi non sarà meglio correggere chameleon per cercare direttamente il "kernel"????

Spero di essere stato chiaro  :)



#820
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 7,518 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

Ho fatto una chiavetta con chameleon e l'unica cosa da fare è creare la cartella Kernels in S/L, mettendoci dentro il file kernel, perchè di default non c'è.

Quello che hai letto tu è "can't find System/Library/Kernels/kernel" seguita da un'altra stringa "can't find mach_kernel"








0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy