Jump to content

Enoch Bootloader

Chameleon Bootloader Enoch

  • Please log in to reply
804 replies to this topic

#721
Fabio1971

Fabio1971

    InsanelyMac Legend

  • Moderators
  • 6,823 posts
  • Gender:Male
  • Location:Italy

Aspetto :) Ricorda, più sono le info meno devo cercare in rete! :P
Se siamo OT apro un topic in questa sezione...

Secondo me meglio aprire un topic.

Fabio

P.S. poi i post con già le informazioni te li sposto io

#722
Marchrius

Marchrius

    Lo scippatore di emozioni

  • Pandora Team
  • 305 posts
  • Gender:Male
  • Location:Ferrara, Italia
  • Interests:Studente di Informatica.
    Passione/Hobby: Informatica in generale, hackintosh, musica Rock...

Secondo me meglio aprire un topic.

Fabio

P.S. poi i post con già le informazioni te li sposto io

Lo apro in "Software e simili", ok?



#723
pianman

pianman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 404 posts
  • Gender:Male

Marchrius, questa è un altro controller ethernet

 

Realtek PCIEx1 LAN 8103EL / 8102EL

 

VEN ID: 10EC DEV ID: 8136 SUBSYS 81361849
 
attualmente funzionante con i driver realtek.


#724
antoniodapc

antoniodapc

    InsanelyMac Legend

  • Donators
  • 546 posts
  • Gender:Male

Ragazzi ho una domanda.

Enoch e capace di pecciare in automatico ApplePowerM...Kext ?



#725
magnifico

magnifico

    InsanelyMac Deity

  • Donators
  • 2,290 posts
  • Gender:Male

Fabio , con Enoch non mi funziona il secondo monitor...

Nuova piattaforma x79 e intel i73930k

questo il bdmesg

Spoiler

 

Effettivamente non mi funziona niente..nemmeno Audio...adesso gli butto diluente sopra e incendio tutto



#726
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,631 posts
  • Gender:Male
  • Location:Canary Islands

Ciao Carmine.

 

Se ti è rimasto qualcosa dopo l'incendio puoi provare se accade la stessa cosa con chameleon 2254?

 

Almeno riesco a tracciare facilmente il problema.

 

Fabio



#727
magnifico

magnifico

    InsanelyMac Deity

  • Donators
  • 2,290 posts
  • Gender:Male
Ciao Fabio , estintore pronto ...ma sono riuscito a farlo funzionare

Puoi vedere la mia cartella Extra...adesso sto su Ipad e ti rispondo da bordo piscina
Ti allego ...


https://www.dropbox....raMagnifico.zip

#728
magnifico

magnifico

    InsanelyMac Deity

  • Donators
  • 2,290 posts
  • Gender:Male

risolto Fabio...dovevo fare una modifica al org.chamaleon.

nvda_drv=1

Ma una cosa non mi è chiara..se metto il DSDT anche in extra ( ne ho uno anche in acpi ) ho bisogno per forza del file HDA enabler in modules..perchè se lo tolgo..ho questo errore nel log

 

Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-179.1.4/AppleHDA/AppleHDADriver.cpp" at line 1656 goto Exit
Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-179.1.4/AppleHDA/AppleHDADriver.cpp" at line 203 goto Exit
Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-179.1.4/AppleHDA/AppleHDADriver.cpp" at line 1656 goto Exit
Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-179.1.4/AppleHDA/AppleHDADriver.cpp" at line 203 goto Exit
DSMOS has arrived
[IOBluetoothHCIController][start] -- completed
ACPI_SMC_PlatformPlugin::gatherCStateOverrides - failed to set c-state demotion data: -1
GeForceSensors (pci1@0): chipset: GK106 (NVE6) bios: 80.06.28.00
GeForceSensors (pci1@0): started
Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-179.1.4/AppleHDA/AppleHDADriver.cpp" at line 1656 goto Exit
Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-179.1.4/AppleHDA/AppleHDADriver.cpp" at line 203 goto Exit


#729
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,631 posts
  • Gender:Male
  • Location:Canary Islands

 

risolto Fabio...dovevo fare una modifica al org.chamaleon.

nvda_drv=1

Ma una cosa non mi è chiara..se metto il DSDT anche in extra ( ne ho uno anche in acpi ) ho bisogno per forza del file HDA enabler in modules..perchè se lo tolgo..ho questo errore nel log

Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-179.1.4/AppleHDA/AppleHDADriver.cpp" at line 1656 goto Exit
Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-179.1.4/AppleHDA/AppleHDADriver.cpp" at line 203 goto Exit
Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-179.1.4/AppleHDA/AppleHDADriver.cpp" at line 1656 goto Exit
Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-179.1.4/AppleHDA/AppleHDADriver.cpp" at line 203 goto Exit
DSMOS has arrived
[IOBluetoothHCIController][start] -- completed
ACPI_SMC_PlatformPlugin::gatherCStateOverrides - failed to set c-state demotion data: -1
GeForceSensors (pci1@0): chipset: GK106 (NVE6) bios: 80.06.28.00
GeForceSensors (pci1@0): started
Sound assertion "0 == pathMap_aDriverInstance" failed in "/SourceCache/AppleHDA/AppleHDA-179.1.4/AppleHDA/AppleHDADriver.cpp" at line 1656 goto Exit
Sound assertion "0 != createAudioEngines ( fPathMap_aDriverInstance )" failed in "/SourceCache/AppleHDA/AppleHDA-179.1.4/AppleHDA/AppleHDADriver.cpp" at line 203 goto Exit

Ciao Carmine.

Presto detto...

L'HDAEnabler.dylib ti "abilita" anche il suono via HDMi della scheda video ;) (A parte che probabilmente hai forse bisogno di patchare l'AppleHDA per il tuo codec HDMi)

 

E da quel che vedo gli errori che riporti sono legati proprio con la scheda grafica. (Sensore GeForce = plug-in di FakeSMC???)

 

Fabio



#730
magnifico

magnifico

    InsanelyMac Deity

  • Donators
  • 2,290 posts
  • Gender:Male

Ciao Carmine.
Presto detto...
L'HDAEnabler.dylib ti "abilita" anche il suono via HDMi della scheda video ;) (A parte che probabilmente hai forse bisogno di patchare l'AppleHDA per il tuo codec HDMi)
 
E da quel che vedo gli errori che riporti sono legati proprio con la scheda grafica. (Sensore GeForce = plug-in di FakeSMC???)
 
Fabio


Si il sensore nel fake....quindi che devo fare?
Ti ricordo che questo e' chinese per me....mhmm

#731
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,631 posts
  • Gender:Male
  • Location:Canary Islands

Si il sensore nel fake....quindi che devo fare?
Ti ricordo che questo e' chinese per me....mhmm

Carmine...
Hai due possibilità se proprio non vuoi usare HDAEnabler

Ho inietti la parte dell'HDEF (HDAU in questo caso) nel DSDT oppure semplicemente "disinstalli" il plug-in di FakeSMC per le GeForce fino a quando non viene sistemato (sempre e se il problema dipenda direttamente da quello), ma come detto nel post precedente mi sa di un "messaggio" dato dalla combinazione dell'HDMI della tua scheda grafica (non riconosciuto) e il plug-in...
oppure ti tieni il modulo.

Fabio

#732
magnifico

magnifico

    InsanelyMac Deity

  • Donators
  • 2,290 posts
  • Gender:Male

cosi ?

Attached Files



#733
ErmaC

ErmaC

    127.0.0.1

  • Supervisors
  • 4,631 posts
  • Gender:Male
  • Location:Canary Islands

cosi ?


Sono con il tablet al momento, e non ho accesso alle postazioni fisse...

#734
magnifico

magnifico

    InsanelyMac Deity

  • Donators
  • 2,290 posts
  • Gender:Male

Sono con il tablet al momento, e non ho accesso alle postazioni fisse...

;) no problem



#735
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 1,887 posts
  • Gender:Male
  • Location:Roma

ErmaC

 

Thema Enoch 

Piu' pulito e aggiornato icone Mavericks

 

Attached Files



#736
magnifico

magnifico

    InsanelyMac Deity

  • Donators
  • 2,290 posts
  • Gender:Male

:hysterical: bello carlito's



#737
HackMan85

HackMan85

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 195 posts
  • Gender:Male
  • Location:napoli
  • Interests:Computer e sapere informatico.

Ciao a tutti, sul mio hardware in firma ho installato Mountain Lion 10.8.4 e ho problemi per l'audio e lo sleep, per l'audio interno installando Voodoo funziona bene ma l'audio HDMI invece non mi permette di modificare il volume, compaiono 4 HDMI Output e selezionando il secondo funziona.

Ho riformattato e subito dopo ho installato subito la nuovo versione di Enoch-rev.2254, e al riavvio nelle impostazioni audio compare solo l'uscita HDMI con il nome LCDTV16 e tipo HDMI ma ugualmente non mi fa regolare il volume.

Nell'ultima versione del bootloader non ci dovrebbe essere il riconoscimento automatico dell'audio? A me interessa in HD perche uso quello.

Sto formattando il pc una ventina di volte al giorno perché tutte le guido che seguo mi mandano in kernel panic, tra  modifiche dsdt e kext sto a perderci la testa. 



#738
ssgoku129

ssgoku129

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

Hi Fabio,

 

I have been using your Enoch bootloader for a while now and it's great! I recently figured out how to get brightness controller working on my L702x in conjunction with your EnableBrightness=Yes flag :)

 

I have one question,

 

I use SkipATIgfx=Yes because I have a Nvidia GT555M, am I using this flag correctly? or should I be using SkipNvidiagfx?

 

Thanks,

ssgoku129



#739
Micky1979

Micky1979

    I realized that I am lucky

  • Moderators
  • 1,692 posts
  • Gender:Male
  • Location:Italy

Ciao a tutti, sul mio hardware in firma ho installato Mountain Lion 10.8.4 e ho problemi per l'audio e lo sleep, per l'audio interno installando Voodoo funziona bene ma l'audio HDMI invece non mi permette di modificare il volume, compaiono 4 HDMI Output e selezionando il secondo funziona.

Ho riformattato e subito dopo ho installato subito la nuovo versione di Enoch-rev.2254, e al riavvio nelle impostazioni audio compare solo l'uscita HDMI con il nome LCDTV16 e tipo HDMI ma ugualmente non mi fa regolare il volume.

Nell'ultima versione del bootloader non ci dovrebbe essere il riconoscimento automatico dell'audio? A me interessa in HD perche uso quello.

Sto formattando il pc una ventina di volte al giorno perché tutte le guido che seguo mi mandano in kernel panic, tra  modifiche dsdt e kext sto a perderci la testa. 

Con il VoodooHDA se non riesci a regolare il volume, non è mica colpa del bootloader  :lol:

Apri il kext con il Finder e nel info.plist che sta lì dentro (aprilo con un programma tipo PlistEditPro.app) cerca la voce "VoodooHDAEnableVolumeChangeFix" modificandola da NO a YES. Ricostrisci la cache e riavvia!

 

L'HDAEnabler funziona solo con AppleHDA.kext, tu invece stai usando VoodooHDA.kext, ma anche nel primo caso ci vorrebbe un kext modificato per il tuo codec/controller, altrimenti non fungerebbe mai. Installando l'HDAEnabler incluso in Enoch/Chameleon, si presume che tu voglia attivare un AppleHDA senza l'ausilio del dsdt.aml, ma è veramente inutile con il Voodoo

 

Micky


Hi Fabio,

 

I have been using your Enoch bootloader for a while now and it's great! I recently figured out how to get brightness controller working on my L702x in conjunction with your EnableBrightness=Yes flag :)

 

I have one question,

 

I use SkipATIgfx=Yes because I have a Nvidia GT555M, am I using this flag correctly? or should I be using SkipNvidiagfx?

 

Thanks,

ssgoku129

Surely you have to use SkipNvidiaGfx=Yes to skip the autodetection of Nvidia cards when you are using GraphicsEnabler=Yes.

 

Micky



#740
HackMan85

HackMan85

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 195 posts
  • Gender:Male
  • Location:napoli
  • Interests:Computer e sapere informatico.

Ma infatti il vodooHda mi abilita bene la alc662 e invece l'hdmi come sconosciuta e anche se cambio il volumefix in YES il volume non si regola ugualmente, per VoodooHDA non ci metto speranze.

Ho provato anche con AppleHDA, cioè ho formattato e quindi avevo il file originale AppleHDA e installando Enoch ultima versione a differenza di altri bootloader mi ha riconosciuto senza modifiche il mio monitor, però c'è sempre il problema del volume.

Io voglio usare AppleHDA che ha una maggiore qualità e stabilità, poi essendo un kext originale è una garanzia.

Sto provando questa guida ma non riesco a modificare i parametri.








0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy