Jump to content

Problem with Backlight

Backlight Dell Inspiron N5050

  • Please log in to reply
23 replies to this topic

#1
TUX FIRE

TUX FIRE

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
Hello

I have found something weird with the backlight function, well it's works fine, but the max brightness level isn't enough (about 80 or 90%)

When the Mac wakes from sleep, the Brightness becomes higher than before (100%)

In IOReg, i watched the "AppleBacklightDisplay", his property "IOPowerManagement" has 2 values before the standby : (CurrentPowerState & MaxPowerState)
Attached File  backlight before sleep.jpg   129.93KB   67 downloads

After the Wake, the property "IOPowerManagement" has 3 values : (CurrentPowerState, DevicePowerState & MaxPowerState)
Attached File  backlight after wak.jpg   138.45KB   59 downloads

The Mac is under Ac Power not Battery, my DSDT is Patched.

Any Ideas ??

Thank you.

#2
juanerson

juanerson

    InsanelyMac Legend

  • Local Moderators
  • 1,410 posts
  • Gender:Male
  • Location:Tru, Venezuela
Very interesting, sure many people have the same report. And another example, when I put the display to sleep, or goes automatically to sleep (only the LID screen device) and wake up, it show three values. Not before. BUT maybe is normal? should be the expected behavior in a genuine macbook pro or Air with the HD 3000 GPU? Therefore, I think we need to compare IOREGS, before sleep and after wake, from the MBP8,1 and/or MBA4,2 of course running Lion.

#3
TUX FIRE

TUX FIRE

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
Mine is 8,1 Smbios definition.

I Found another weird thing !!

When i keep my mac only on AC adapter (i remove the battery) and i (re)boot, once i'm on desktop, going to system preferences --> Energy saver. i can see that the tab is on Battery !!! and as mentioned the display sleep is in 2min, to verify that, i do nothing and about 2min the display sleep comes. When i plug the battery,the tab change to AC Adapter !!! :| (Normally is the contrary should be happen)

I think that something wrong in my DSDT :worried_anim:

If you keep the Ac & Battery and u close the clamshell, after wake, it becomes normal, and the backlight is higher.

#4
alepartt

alepartt

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 103 posts
  • Gender:Male
hi tux fire-have a question: how did you work wireless 1701? Can u help me with DSDT I have the same laptop but have I3 cpu. Ty

#5
TUX FIRE

TUX FIRE

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
i told you, the dell 1701 bluetooth is natively supported by Lion, Wifi not,

#6
TUX FIRE

TUX FIRE

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
I found another weird thing, always battery removed, i put the mac only on AC Power, once on desktop, i check the system properties, the mac show me that the actual source of power is the battery !!!

that explain why i don't have the normal backlight, because after the standby, the backlight become normal and the mac show me this time the actual source power is AC power.

Do you think that the problem is Battery Kexts or from DSDT ?

#7
navendugoyal

navendugoyal

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
Ya I got the same problem on my hp pavillion dv 6 quad core i7 . my backlight display is slightly lower than fully supportes , but when i sleep and get it to wake up the display brightness is complete as in dual booted windows

can someome help

#8
TUX FIRE

TUX FIRE

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
the problem is that the mac when boot, doesn't check the power statue, and automatically set it to battery. i think it's a DSDT problem but where ?

#9
navendugoyal

navendugoyal

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
so any progress to the problem
have u tried the edid setup for ur display
i am gonna try
do lt me know

try this link
http://www.tonymacx8...hp?f=15&t=53970

#10
TUX FIRE

TUX FIRE

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
doesn't work for my, i have the display but the backlight is always the same, low before standby and high after.

#11
navendugoyal

navendugoyal

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
i corrected my edid but the problem is still the same :-(

somebody help us out please........................

#12
navendugoyal

navendugoyal

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
i have a hunch that it is a problem with dsdt

#13
TUX FIRE

TUX FIRE

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
maybe, i have removed my battery kext, now the mac shows me that the actual power source is the AC Power but i have always a low brightness.

#14
navendugoyal

navendugoyal

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
did u try talking in irc channels or on tonymac . i was so happy to have qe/ci and gr8 1920 x 1080 resolution but then the backlight problem ,yuhhhhhhhhhhhhh
come on someone find a solution

if i remember right the backlight is alrite on boot screen so probably its with dsdt which i have patches as hp DV6T GENERIC from olarila

#15
navendugoyal

navendugoyal

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
i have hp pavillion dv6 quad core with i7 2670 . i can only run it with chameleon , some problem which i could never solve is to get it woking with chimera .

there are so many posts on hd 3000 that say to install chimera because it suppirts intel hd 3000 natively and works without any dsdt or kext edits .

have u tried installing chimera .

belive me i am 24 hours into getting our problem solved out

#16
navendugoyal

navendugoyal

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
ya i think confirmed the source now
without using snb framebuffer kext the backlight is 100%

when it loads we have the problem

so we require modified kext or some other solution i dont think its the dsdt

#17
TUX FIRE

TUX FIRE

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
don't worry i use the latest chimera v1.9.2, and i have a native support for my HD3000 (except the pool error in the console)

For the SNB frame buffer, if i delete it, i can't boot correctly, it show me just SNB Framebuffer did not show up, kext unload and the screen still here.

#18
navendugoyal

navendugoyal

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
still whats the solution to the problem , chimera doesnt work on my laptop if i update to 10.7.3 but works well with 10.7.0

#19
TUX FIRE

TUX FIRE

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 113 posts
i work always with Chimera boot loader, it's works fine for me ;)

#20
navendugoyal

navendugoyal

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
well i guess it shouldnt make a real difference between chimera and chameleon but have u solve the backlight problem or its still unsolvd






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy