Jump to content

Still waiting for root device

- - - - - still waiting for root device

  • Please log in to reply
9 replies to this topic

#1
InsanoAlves

InsanoAlves

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
Boa noite. Não sou um membro novo, mas como esse é o meu primeiro post...
...

Sei que esse é um erro comum, mas já tentei tudo que vi e até agora nada.
...

Primeiro, vamos as minhas configurações de hardware:
ASUS P5VD2-VM - BIOS atualizada
Core 2 Duo 2.0 GHz
2GB de RAM
GeForce 8500 GT 512MB

Configuração mais específica está no arquivo anexo, gerado pelo CPU-Z


O que eu fiz:

Baixei o iATKOS L2 do torrent que tem no iatkos.me e gravei no dvd.
Entrei na Bios e no Advanced > "Onboard (...)".
Lá tem uma opção "JMicron (...)" que estava IDE, então eu coloquei AHCI. E no "SATA Controller Mode" só tem a opção IDE e RAID. Deixei como IDE
Dei o boot com o dvd do iATKOS, apertei F8 e digitei a flag "-v" mas, depois, acaba dando "Still waiting for root device"

Reiniciei e troquei o SATA Controller Mode para RAID, mas continuou dando a mesma coisa.
Fui na BIOS, de novo, deixei ela tudo como default ("Load Default(...)"), mas continua do mesmo jeito.
Alterei novamente, após colocar como default, o controller mode e o JMicron, mas nada de diferente.

Já tentei as flags rd:disk0s2, npci=0x2000 e 0x3000, arch=i386, busratio=20, -v, -x, -f, (mesmo não sabendo se eram esses argumentos que eu deveria colocar) e ainda assim, a mensagem continua aparecendo

Só tenho um hd, conectado, que é o que está o Windows. Eu vou instalar o MacOS "por cima". Provavelmente, eu vou ter que formatar para fat32, para o utilitário de disco reconhecer e poder formatar para o sistema de arquivos utilizado pelo MacOS (não é?). Mas primeiro, quero chegar até essa parte que eu formataria o disco. Depois eu formato, caso seja necessário

Bem, sou iniciante nessa área de hackintosh, por isso gostaria da ajuda dos colegas do fórum

Attached Files

  • Attached File  PC.html   530.7KB   8 downloads


#2
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,385 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
olá

em principio por dvd n vais lá, se n tens opção ahci, na bios

terás de preparar um boot por pen para essa mobo, k terá de conter uma kext com a tua controladora

meu conselho é 1º instalares snow (10.6.3 retail + nawcom mod cd)

e depois sim pensares em lion.

bom hack

#3
InsanoAlves

InsanoAlves

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
Obrigado por responder, artur-pt

Realmente faria diferença tentar com o Snow Leopard no lugar do Lion? (acho que sim, senão você não diria. Mas eu queria entender o por que)
Versão retail, para baixar aqui, vai demorar pra caramba. Vou tentar com o iAtkos S3 V2.
Instalando o Snow Leopard, com o iAtkos S3 V2, daria para atualizar para o lion utilizando o iAtkos L2?
No forum oficial, diz que sim: "You can upgrade your existing Snow Leopard or Lion installations to Lion 10.7.2 or make a refresh install to your 10.7.2 system"

#4
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,385 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
olá

podes tentar esse k estás a dizer, o importante é k seja legacy

por isso te dizia para usares nawcom boot cd

o snow é só para preparares uma pen para boot com lion

bom hack

#5
InsanoAlves

InsanoAlves

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
Ah, entendi.
Bem, agora não da para tentar a instalação, porque não posso formatar o pc. Quando puder, posto aqui o que for acontecendo.
Enquanto isso, vou baixando o *.dmg do iAtkos L2 (novamente T-T) para criar o pendrive bootavel com ele, quando conseguir instalar o Snow Leopard

Obrigado.

#6
InsanoAlves

InsanoAlves

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
Instalei o Snow Leopard. Foi tranquilo, o som funcionou, mas a internet não.
Instalei o ##### pra deixar o boot sem o dvd e para ver se a internet funcionava. Quando reiniciei, apareceu aquela mensagem de que precisava reiniciar e se eu coloco o modo verbose trava na parte que esta na SS.

Attached Files



#7
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,385 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
olá

tenta fazer o boot com o cd de boot da instalação

-v

e posta como instalaste com k método ?

bom hack

#8
InsanoAlves

InsanoAlves

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
Para instalar eu utilizei as flags: -v -x -f busratio=20. As opções que eu escolhi no "customize" eu não me recordo.

Com o dvd inicia normalmente usando essas flags (não tentei sem algumas delas)
Só -x -f não vai.
Não sei por que, mas a minha BIOS teima em trocar o AHCI de volta para IDE, sozinha o.O (provavelmente vou ter que trocar outra vez, qualquer hora dessa ahahahaha)

#9
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,385 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
olá

isso tá uma confusão, desde o incio

porque se usaste uma distro, a distro tem lá tudo, para instalares e ficar funcional, pelo k percebi já usaste outra coisa para preparares o boot no hd

dai teus problemas

meu conselho , volta a instalar e se estás a usar uma distro, vê as opções com atenção.

bom hack

#10
InsanoAlves

InsanoAlves

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
Eu só usei o iATKOS S3 V2 para instalar.
Usei as -v -x -f busratio=20 para o boot, formatei o hd com a opção Mac OS Extended Jounaled e antes de clicar em instalar, cliquei em customize, para selecionar algumas coisas para a instalação. Instalei, só que no final deu aquela mensagem que o OS não pode ser instalado. Reiniciei o pc, e dei boot no OS com o DVD do iATKOS, usei as mesmas flags de antes e iniciou normalmente. Instalei o Multi­Beast para fazer ele dar boot direto do HDD e não precisar mais do DVD. Ai quando tento dar boot sem o DVD dá aquele erro.
Foi só isso que fiz.

Vou tentar algumas coisas, qualquer coisa posto aqui.
Obrigado






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy