Jump to content

A Hackintosh project on an HP/Compaq 610...No QE/CI


  • Please log in to reply
1 reply to this topic

#1
naton

naton

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
I've read over a hundred of posts mainly in this forum and to be honest I'm getting nowhere. My laptop specs are on my signature. I used iAtkos L2 (10.7.2). The keyboard and touchpad work perfectly. The webcam and the USBs work too.

The sound works but the volume is set to high even when I turn it down using the sound icon. Also the VoodooHDA preference panel is missing. I tired with VoodooHDA 2.6.2, 2.7.2, and 2.7.3.

Aside from getting the kexts for the graphics cards to load, I'm not yet concerned about the other devices. I mean let's face it, there is no much point having a hackintosh if QE/CI don't work.

I've tried every trick suggested to make my Intel x3100 (2A12) work and I failed. I tried a/ll of the following:

1. Not knowing that there are two types of Intel x3100, the 2A02 and the 2A12, I tried these kexts which I've tested on another laptop and they work well on the 2A02.
http://www.osx86.net...7.0.1.2.3.html

Basically all the kexts in the above link are from Lion 10.7.0 except for 'AppleIntelGMAX3100FB.kext' which is from Snow Leopard 10.6.8. This didn't work with the HP 610.

2. I used an 'AppleIntelGMAX3100FB.kext' from Snow 10.5.8 that was patched to support 2A12. I found it in this forum. This kext loaded. The screen was much brighter than before but it was split into 12 sections. Each section represents an instance of a desktop.

3. I used the 2A12patcher. Mac didn't give me a kernel panic but It froze before reaching the desktop. Amongst the displayed text I noticed that Mac was complained about the fact that the AppleIntelFrameBuffer class was already loaded and thus it could not be loaded again from the AppleIntelFramBuffer.kext file.

4. After 3 days of reading about what other have done, I decided to patch the kexts, install them and see how it goes. I used the kext from Lion 10.7.0 as a starting point. I patched the info.plist files inside AppleIntelGMAX3100.kext and AppleIntelGMAX3100FB.kext. I also used a HEX editor and patched the binary files inside these kexts. Basically I replaced every instance of 2A02 with 2A12.
Nothing happened when I installed these patched kexts.

5. After doing the above I went ahead and patched AppleIntelGMAX3100FB.kext for Snow Leopard 10.6.8 and install it. This time the screen was split into 4 with every section containing an instance of the desktop.
Rebooting with the flag "GraphicsEnabler=No" fixed the split on the screen but I still do not have QE/CI.



What else I can try to get the Intel X3100 (2A12) to work properly?


Thanks

#2
Guest: sincro77_*

Guest: sincro77_*
  • Guests
Hackintoshed !!! Laptop .--Compaqintosh

Anyone who needs help with cheapo hp/compaq with nforce chipset/nvidia graphics/ Amd Turion x2 64.. ]I had trouble ,, every distro would reboot.. tried so many chameleon" boot files until i landed on 'APIC version error '' KP.

After scratching my head for a few weeks and installling ubuntu without any problems..Somehow i found a working Cham RC5 boot file!! (working via usb) not ata "yet"...
(tried to patch nforceata with ID-- but error ""says not compatible 10de... at verbose..... ))

OMG!! i might be the first.,. nobody seems to have got this one working... Im going for audio and qe/ci now..
will update soon.

Anyone who needs help: PM me for now , until i make a guide/how to.. and i will upload a "boot file, etc soon.

Hoooray!!!!!! PERSEVERANCE.!!

sincro77





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy