Jump to content

Please help Ati hd 4850 sapphire 1 gb


  • Please log in to reply
10 replies to this topic

#1
bentek86

bentek86

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
Hello, im going crazy with this video card...evryvere i read thatit works simple editing ati4800controller and adding 0x94421002 but i always got black screen or the message "not optimal resolution".

I try with different motherboard, different monitor with dvi or vga but the result didnt change.

I have an asus p5q-e with dsdt and all works perfect.
I install retail and purchased copy of lion from usb then i modify ati4800controller and repair permission and reboot...black screen...

Also try ati 48xx injector and graphicsenabler by netkas but same result.
Also try graphicsenabler no and -x but nothing to do... On every try i must reinstall anything.

Please somebody can help me? Where i am doing worng?

#2
nyolc8

nyolc8

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 802 posts
  • Gender:Male
  • Location:Budapest, Hungary
Try using the "netkas exotic patch". It's the original ati kext patched for 48xx series cards. What OSX version do you have?

#3
bentek86

bentek86

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
actually lion 10.7.3....but i also try 10.7.0 or 10.6 and 10.6.8...i will try immediatelythe exotic patch...but how it's possible that on HCL and on the forum this video card is supported simply with ati4800 editing or with graphicsenabler and for me this doesen't work?

#4
TH3L4UGH1NGM4N

TH3L4UGH1NGM4N

    (~_~)

  • Retired
  • 1,156 posts
  • Gender:Male
  • Location:Wonderland
  • Interests:(~_^)
since Lion came in I haven't really saw a need for the 4850 using graphics enabler anymore. Getting most 4850s to work meant editing the 4800 controller and the x2000 acceleration kext as well. By chance did you edit the acceleration kext as well because I didn't see you mention it in your original post.

#5
bentek86

bentek86

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
Then do you think that this video card works only with snowleopard? i also tru snow leopard but still black screen...and anyway no, i didn't know that i have to modify the acceleration kexts too...do you mean atiradeonx2000? how i have to modify it?

#6
bentek86

bentek86

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
Ok, i try exotic patch and then try to modify atiradeonx2000 adding my id...sameresult...black screen after load...also try graphcs enabler no and useatirom yes...
During loading i have errors about could'nt load class atiradeonx2000 and audiouuc and applehdacontroller if this can help

#7
bentek86

bentek86

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
nobody?

#8
TH3L4UGH1NGM4N

TH3L4UGH1NGM4N

    (~_~)

  • Retired
  • 1,156 posts
  • Gender:Male
  • Location:Wonderland
  • Interests:(~_^)
You have to add the same ven ID you added to the 4800controller to the x2000 as well that's the edit I mean.

#9
bentek86

bentek86

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
i already do that...and still no signal...also try hdmi, vga or dvi..same result...is it possible that i have to use chameeleon instead of chimera?

#10
TH3L4UGH1NGM4N

TH3L4UGH1NGM4N

    (~_~)

  • Retired
  • 1,156 posts
  • Gender:Male
  • Location:Wonderland
  • Interests:(~_^)
Well I've never used Chimera always been using Cham but I'll see if it actually makes a difference though I doubt it should since you're not really injecting anything.

#11
bentek86

bentek86

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
nothing to do...even wih chameleon...sometimes the video work at 1440x950...but the rest of time still black screen.. with -v flag i read "couldn't alloc class atiradeonx2000" and can't load kext atiradeonx2000 ati4800controller..

what this mean? i try also to put they in extra/extenstion instead of system/library/extension...and i always repair permission...

i'm going to buy another video card...is it impossible that only for me this doesen't work





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy