Jump to content

[AMD] 10.7.3 Guide - Experimental Only

AMD Lion 1073 Guide Kernel

  • Please log in to reply
209 replies to this topic

#81
ham4ever

ham4ever

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 278 posts
  • Gender:Male
hello sir,
i am trying methode 3

i wanna ask how to add empty

Harddrive to VirtualBox ??

i have empty

Harddrive 500 Gb and i wanna use it to install Lion but i dont know how to add the empty

Harddrive to virtualBox




thanks



#82
Devout

Devout

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 180 posts

hello sir,
i am trying methode 3

i wanna ask how to add empty

Harddrive to VirtualBox ??

i have empty

Harddrive 500 Gb and i wanna use it to install Lion but i dont know how to add the empty

Harddrive to virtualBox


thanks


Create a Dynamic Disk of 450 GB on the hard drive and use the vdi.

I've a question, but there is a solution ( or in developements ) for running lion in 64 bit mode .
I've turion rm-74 x2 64bit ss2 .
Or there isn't hope ???

EDIT :


Can anyone send me (mp) a finder.app from dp2 ?? please


I'm not sure, don't bet on 64 bit mode yet.

Hi!
I've a problem with the Second Method:
OSinstall.mpkg doesn't work, It say at least a core2duo, i3 ecc, is necessary.
I've hazard 10.6.2 installed, and "about my mac" is "macpro5,1".

My pc configuration is:

cpu 1090t
mobo shaphire am3rs790g
gpu gfx460
4gb of ram.


You need to use iATKOS L2 or you will get error installing. You need a intel processer to install, you can't fake this with SMBIOS, it uses a very specific checker that can't be bypassed.

You could try to Edit your smbios.plist with Chameleon Wizard. Or just set the smbios to defaults.


Does not work, changing SMBIOS is appearance only to About This Mac. Only thing useful is the serial number, everything else is just for showing off, sometimes it can crash your computer, but pick a similar device.

But the error is that don't work some app !??
Because Now i m in 10.7.2 and textedit iTunes software update don't work !! They don't start...
Is it a kernel bug ???


It works, make sure you turn it on and open software update straight away. Apps stop after 10 minutes, kernel bug, read FAQ in 1st post.

#83
.picodev

.picodev

    Insanelymac Ninja

  • Members
  • PipPipPip
  • 158 posts
  • Gender:Male
  • Location:Serbia

But the error is that don't work some app !??
Because Now i m in 10.7.2 and textedit iTunes software update don't work !! They don't start...
Is it a kernel bug ???


Try making a new user account(administrator),log out,login to the new one and test.Trash the old one if everything is fine.

#84
ham4ever

ham4ever

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 278 posts
  • Gender:Male
@Devout

thank u for info , with vdi i can boot from hardisk in startup and choice Lion ??


i can confirm is working in Athlon II X3 435 CPU and mobo m3a76-cm

but i only use VirtualBox,

#85
otherman

otherman

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

You need to use iATKOS L2 or you will get error installing. You need a intel processer to install, you can't fake this with SMBIOS, it uses a very specific checker that can't be bypassed.


the second method says:

"Using your existing AMD Machine running Snow Leopard".


This is a guide to install on Amd, what's the point of "

You need a intel processer to install"?

#86
Devout

Devout

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 180 posts

@Devout

thank u for info , with vdi i can boot from hardisk in startup and choice Lion ??


i can confirm is working in Athlon II X3 435 CPU and mobo m3a76-cm
but i only use VirtualBox,


I can't give you much information but I would look here, I've done it before:
http://www.sysprobs....zation-software

Make sure you follow correctly, and that when you open and attach the file it creates, you run it in administration mode.

the second method says:

"Using your existing AMD Machine running Snow Leopard".


This is a guide to install on Amd, what's the point of "

You need a intel processer to install"?


Because it's a guide to install AMD Lion. There's no way to install it you use iATKOS L2 on existing Snow Leopard or another machine with intel Lion/Snow Leopard or real mac. Use Method 3.

#87
otherman

otherman

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
Sorry, I don't understand: now i've an amd machine, with snow leopard on it, and I want to upgrade to Lion, but you're saying it's not possible?

#88
Fraom

Fraom

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 222 posts
  • Gender:Male
there is a new kernel v6 for 10.7.4

http://www.osx86.net...for_10.7.4.html

#89
Fraom

Fraom

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 222 posts
  • Gender:Male
Anyone know a metod to dual boot in this order : snow/snow/lion


EDIT : change a c.a.b.p from snow in o.c.B.p

#90
ham4ever

ham4ever

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 278 posts
  • Gender:Male
in VirtualBox i could run Lion ,, but when i tried to dual boot Snow/Lion then alot troubles to boot ,, first sleep, then pci begin ,, after that got KP about FAKESMC 3.1 all solved
then real troubles wait for root device , or dsmos has arrived ,,,


UPDATE:

well now boot , very very slow boot after dsmos has arrived and alot failed kexts ,, but then boot either in bluescreen or background of iatkos , and i hear sound ""about voice speech or something ,and press back to know about it ,,,, ""

Posted Image

Posted Image


UPDATE:2

Deleted all ATI kexts helped me to get to begin of Lion, ( keyboard , time,,,) but then i just got grey screen with cursor on it , and thats all



n00b question : i deleted FAKESMC 3.1 from Lion ,, is it a problem :P,?
PS; helppp with dsmos has arrived, takes forever to begin ,( both in Lion and SL )

#91
instant idiot

instant idiot

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 182 posts
  • Gender:Male
Hello!

Confirmed WORKING using method 2 with an ASUS M4A88T-V EVO/USB3 and an AMD Athlon II x4 640. It looks pretty pathetic at the moment, but hey at least it booted! I'll post back if I actually get it do do anything useful. ;)

#92
jamdownian

jamdownian

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts

in VirtualBox i could run Lion ,, but when i tried to dual boot Snow/Lion then alot troubles to boot ,, first sleep, then pci begin ,, after that got KP about FAKESMC 3.1 all solved
then real troubles wait for root device , or dsmos has arrived ,,,

//---------------------------

Could you please post a step by step procedure in running lion on virtual box please.

I want to run on virtualbox too...

Im using a mobile phenom 2 processor and ive been running 10.6.7 for almost a year now with vmware.

#93
ham4ever

ham4ever

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 278 posts
  • Gender:Male

//---------------------------

Could you please post a step by step procedure in running lion on virtual box please.

I want to run on virtualbox too...

Im using a mobile phenom 2 processor and ive been running 10.6.7 for almost a year now with vmware.


i Used virtualBox, but i think is same as VMware,,
prepare some partition to install Lion in it

* download iatkos l2 and then run it in ur Vmware , then ""

ShowAllFiles "" in ur Snow Leopard,


*

Open

iatkos l2, and then go to ""

System/Installation/Packages/OSInstall.mkpg " and open the file.


* then install Lion and you can customize the install, and make sure select the correct Installation Hard drive/partition

when installation then do STEPS in tutorial in here of Devout


is easy to run in VirtualBox,

goodluck



#94
ham4ever

ham4ever

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 278 posts
  • Gender:Male
i have a working AMD lion 32 bits , SOUND work , QE/CI working , 2 screen working, :D

waiting for 64 bits

#95
dlambert

dlambert

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
  • Gender:Male
  • Location:Galien, Michigan
  • Interests:Computers, Hacking
Going to test on my Phenom II x6 1055t @3.8Ghz w/ GTX 560. WIll post full specs later.

#96
dlambert

dlambert

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
  • Gender:Male
  • Location:Galien, Michigan
  • Interests:Computers, Hacking
What about the PCIFAMILY kexts from 10.7? I've heard those are required?

#97
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,539 posts
  • Gender:Male
Confirmed working with AMD Athlon II X2 250 and motherboard ECS Elitegroup A780LM-M2! Installed with method 2 using v4; thanks very much indeed for the tutorial.

One issue: it boots only when iATKOS L2 is in and set as first boot device, or else the computer shuts down square. Strange and annoying, like some malfunction with chameleon, which i tried to reinstall by the way, to no avail. I think the instaled O.S. uses to boot loader of iATKOS DVD to bypass this error. In fact, the problem was already there in my Snow Leopard, meaning that i made the same mistake twice, but in Snow Leo i was managing to overcome the problem simply by booting in single user mode and typing "mount -uw /" and "exit". It worked, i don't know why, but it was impossible to do with my Lion system, who shuts down my computer whatever flag i use, unless iATKOS is running as first boot device.

At first, when i discovered how to pass through the shutdown problem using the iATKOS dvd, the boot hanged anyway at "

AppleUSBOHCI::CheckSleepCapability - OHCI Controller will be unloaded across sleep

" after a sucessful first boot, and continuing doing so, although i of course had changed to AHCI in my BIOS and had used recomended boot flags, and tried single user too. The solution for it? Using the bootflags "-legacy -s". After this, i had another difficulty when i tried to migrate my settings from my Snow Leo HD, resulting in a "DSMOS has arrived" freeze. i had to reinstall it, and without doing the migration tool, everything worked fine. My ralink was recognized with the correct driver, the same for my maudio and soundblaster soundcards. My graphic card, a nVIDIA GeForce G210, needed only graphics mode and "GraphicsEnabler" in boot.plist to work fine, with full resolution and QE/CI.

Waiting for a 64-bit kernel!

P.S.: of course, i experienced the same kernel-related bugs as everybody else, link finder problems - i used DP2 to partially fix this - and being unable to execute apple "core" apps after a certain amount of time. Not a big deal for me, since these apps are not among those i prefer. Well, except maybe for the AppStore, which could be handy with it worked. Second, my network always takes a certain time to start working. An issue between OsX and ralink drivers, i suppose, since it happened with Snow Leo too.

#98
Devout

Devout

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 180 posts

What about the PCIFAMILY kexts from 10.7? I've heard those are required?


Nope not for 10.7.2/10.7.3, I'm not sure about 10.7.4 because I'm running Mountain Lion under Intel now.

Confirmed working with AMD Athlon II X2 250 and motherboard ECS Elitegroup A780LM-M2! Installed with method 2 using v4; thanks very much indeed for the tutorial.

One issue: it boots only when iATKOS L2 is in and set as first boot device, or else the computer shuts down square. Strange and annoying, like some malfunction with chameleon, which i tried to reinstall by the way, to no avail. I think the instaled O.S. uses to boot loader of iATKOS DVD to bypass this error. In fact, the problem was already there in my Snow Leopard, meaning that i made the same mistake twice, but in Snow Leo i was managing to overcome the problem simply by booting in single user mode and typing "mount -uw /" and "exit". It worked, i don't know why, but it was impossible to do with my Lion system, who shuts down my computer whatever flag i use, unless iATKOS is running as first boot device.

At first, when i discovered how to pass through the shutdown problem using the iATKOS dvd, the boot hanged anyway at "

AppleUSBOHCI::CheckSleepCapability - OHCI Controller will be unloaded across sleep

" after a sucessful first boot, and continuing doing so, although i of course had changed to AHCI in my BIOS and had used recomended boot flags, and tried single user too. The solution for it? Using the bootflags "-legacy -s". After this, i had another difficulty when i tried to migrate my settings from my Snow Leo HD, resulting in a "DSMOS has arrived" freeze. i had to reinstall it, and without doing the migration tool, everything worked fine. My ralink was recognized with the correct driver, the same for my maudio and soundblaster soundcards. My graphic card, a nVIDIA GeForce G210, needed only graphics mode and "GraphicsEnabler" in boot.plist to work fine, with full resolution and QE/CI.

Waiting for a 64-bit kernel!

P.S.: of course, i experienced the same kernel-related bugs as everybody else, link finder problems - i used DP2 to partially fix this - and being unable to execute apple "core" apps after a certain amount of time. Not a big deal for me, since these apps are not among those i prefer. Well, except maybe for the AppStore, which could be handy with it worked. Second, my network always takes a certain time to start working. An issue between OsX and ralink drivers, i suppose, since it happened with Snow Leo too.


Yepp it's ralink drivers, I'm not sure about the other problems though, but it does freeze boot sometimes.

#99
appleAMDx6

appleAMDx6

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
I'll try this out and see how far I get...nice guide

#100
dlambert

dlambert

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
  • Gender:Male
  • Location:Galien, Michigan
  • Interests:Computers, Hacking
So I installed on my AMD x6 system, and I got SL (10.6) running then mounted and installed iAtkos L2. The install failed (towards the end), but I still added kernel and installed chameleon. But now the kexts load, but then the PC reboots. Any ideas? GTX 560 ti, 16GB ram, ASUS M4A87TD EVO.


Right before it reboots:

[Warning] /extra/dsdt.aml not found
USING PCI-ROOT_UID value:0
ACPI Table not found DSDT.aml


Also there is some stuff about SMBIOS is there





Also tagged with one or more of these keywords: AMD, Lion, 1073, Guide, Kernel


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy