Jump to content

SATA HDD Not Recognized During Lion Installation

Dell Optiplex 780 Lion

  • Please log in to reply
3 replies to this topic

#1
Tardisk

Tardisk

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Hi guys! I've done my searching, and have decided that it's time to make my first post regarding this problem.

I'm attempting to get Lion to install on my Dell Optiplex 780, using the guide here http://www.insanelym...howtopic=256729

It is supposedly working, as my model is listed here

http://wiki.osx86pro...LL_Optiplex_780

My problem is that the installer will not recognize my internal hard drive. That's all there is to it. I've enabled legacy in the BIOS, still nothing. It will recognize external disks, so I assume it has something to do with my internal controller. What should I do? Thanks!

PS: I was a very active member of insanelywind when it was still busy. I was happy when I got this Dell as an opportunity to start hackintoshing again!

#2
bigben1

bigben1

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
what are your bios settings??

#3
Tardisk

Tardisk

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
I've tried using both Legacy and Raid On, to no effect. I updated it to the latest A12 revision. There seems to be nothing pertaining to AHCI or anything else useful.

#4
C.Frio

C.Frio

    InsanelyMac Legend

  • Pandora Team
  • 1,044 posts
  • Gender:Male
  • Location:Cabo frio - Brasil
hi ..

see this, note...is the same optiplex 780 and it has AHCI by default

"
DELL Optiplex 780
Hardware Name Chipset Notes Patches Used 32/64bit working withpatches Dell Optiplex 780 Intel Q45 Express w/ ICH10D
  • Intel Core 2 Duo E7500 @ 2.93Ghz
  • RAM: 3GB 1333 Mhz DDR3
  • VGA : Integrad Intel GMA4500 64Mb
  • Audio : ADI 1984A HDA onboard Full working
  • Network: Intel WG82567LM Full working
  • Graphic: working with NO QE/CI 1280x1024x32
  • Monitor : HP W2408" VGA Cable
  • Hard Disk : SATA 160Gb 7200 RPM HDD
  • DVD : DVD +/- RW TSSTCorp Sata TL-463A
  • USB, eSata: all work
  • Installed 10.7 Final with USB Pen creation + Chameleon 2.0-RC5-r755.pkg + Extra_Lion.pkg (followed Mald0n method on InsanelyMac [1])
  • Boot USB Pen and then create a MBR partition HFS+ journaled , then install as usual, Then install Chameleon , Extra_iMac9_1 and Kexts on HD
  • Bootloader - Chameleon 2 VS
  • Kexts used : fakesmc.kext,NullCPUPowerManagement.kext, ElliotForceLegacyRTC.kext (needed to avoid Bios Reset)
  • Audio - VoodooHDA.kext v. 2.62 (x86_64).
  • Video - no Kext - org.chameleon.Boot.plist - Graphics Mode=1280x1024x32 - GraphicsEnabler=Yes
  • SATA - AHCI in BIOS (Set by default on BIOS)
  • Ethernet - IntelE1000.kext
  • Sleep & Wakeup : Works , no Kext needed
  • OSX Lion start in 64 bit kernel by default
  • Update to 10.7.2 using Combo update, don't forget to rerun the Chameleon installer before restart
  • HAVE FUN P3P70
good lucky

c.frio






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy