Jump to content

[Solved] Help needed - EVGA GeForce GTX 550 Ti - Choppy Animations

nVidia Fermi GTX 550 Ti

  • Please log in to reply
5 replies to this topic

#1
Hameer Abbasi

Hameer Abbasi

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
Okay, my basic problem is that, despite VERY good OpenGL and OpenCL benchmark results with my graphics card, I'm facing choppy native Mac OS X animations. Example: The genie effect is choppy, maximizing iTunes, Quicktime, VLC. I've done the following with my rig so far:
  • DSDT edits for my card (attached), including HDMI audio patches.
  • Combo OpenCL enabler for 10.7.2/10.7.3, which injects device ids + netkas's OpenCL patch.
  • Edit AGPM.kext (this may be what's the issue here, I'll try tweaking and report back), I'd rater not delete this.
AGPM edits:
<key>iMac12,1</key>
   <dict>
	<key>LogControl</key>
	<integer>0</integer>
	<key>Vendor10deDevice1244</key>
	<dict>
	 <key>BoostPState</key>
	 <array>
	  <integer>0</integer>
	  <integer>1</integer>
	  <integer>2</integer>
	  <integer>3</integer>
	 </array>
	 <key>BoostTime</key>
	 <array>
	  <integer>3</integer>
	  <integer>3</integer>
	  <integer>3</integer>
	  <integer>3</integer>
	 </array>
	 <key>Heuristic</key>
	 <dict>
	  <key>ID</key>
	  <integer>0</integer>
	  <key>IdleInterval</key>
	  <integer>100</integer>
	  <key>TargetCount</key>
	  <integer>5</integer>
	  <key>Threshold_High</key>
	  <array>
	   <integer>0</integer>
	   <integer>23</integer>
	   <integer>70</integer>
	   <integer>100</integer>
	  </array>
	  <key>Threshold_Low</key>
	  <array>
	   <integer>13</integer>
	   <integer>40</integer>
	   <integer>83</integer>
	   <integer>98</integer>
	  </array>
	 </dict>
	 <key>control-id</key>
	 <integer>17</integer>
	</dict>
   </dict>
Update: Deleting AGPM.kext doesn't solve the issue.

Attached Files



#2
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,879 posts
  • Gender:Male
  • Location:Stuttgart / Germany
HINT: In that AGPM .plist you can setup an LOGGING - so you see if and when the GPU speeds up/ down (Pstates for GPU).

<key>LogControl</key>
<integer>0</integer>
Change 0 into 1 , then better rebuild Kernel cache ( simple delete the Kernel cache folder) and reboot.
Or copy that .kext to desktop, make changes in .plist and install that with Kextwizard (then your kernel cache will be updated automatic, no need to delete it by finder)


You can open konsole beside an using some 2D (QE) or small OpenGL Apps and look if your GPU is switching up / down.

#3
Hameer Abbasi

Hameer Abbasi

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
I've tried using Unigine Haven and Cinebench, and there are no messages in the Console App (I'm assuming you mean /Applications/Utilities/Console.app) about graphics. I tried searching GFX0 and Vendor10deDevice1244 without success. AGPM is loaded (verified in Kext Wizard). There are, however, a whole lot of these messages:
4/10/12 10:36:46.347 PM mds: (Error) Volume: sysctl_queryfs failed: Invalid argument
I wonder what that means? However, it doesn't appear to be switching up/down, or it isn't logged. And yes, my SMBios is set to an iMac 12,1.

#4
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,879 posts
  • Gender:Male
  • Location:Stuttgart / Germany
OK.
First test if AGPM is really loaded by kextstat (terminal command)
You should see such an listing: ffffff7f81e95000 0xb000 0xb000 com.apple.driver.AGPM...... in the kextstat list.

About your DEV-ID (in AGPM .plist)
Is that really 1244(hex) ? If not, and your used 1244 is decimal then use HEX 04DC (Vendor10deDevice04DC

)



I atttached screen which shows how AGPM log locks like in the console (select show all messages).

Attached Files



#5
Hameer Abbasi

Hameer Abbasi

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
First, I'm sure it is 1244 hex, confirmed by IORegistryExplorer. Kext Wizard shows that AGPM is loaded. Okay, apparently it was GFX0 instead of Vendor10deDevice1244 in AGPM.kext. Saving, and rebooting, and using your method, I see that AGPM was switching states even at the last boot, and it is at this boot (see attachment).
But it doesn't go below G-state 0 once it has reached it, as you might see. So, two possibilities spring to mind:
  • Something is using the GPU in the background for no reason (Activity Monitor shows hardly any activity, so this can't be the case).
  • That G-state 0 doesn't exist for my GPU. I will edit the kext accordingly and report back.
Update: The console seems to give the same three messages, even if I disable G-state 0, and immediately upon boot:
4/11/12 4:14:44.000 PM kernel: AGPM: GPU = GFX0 Initialized, Control ID 17
4/11/12 4:14:56.000 PM kernel: AGPM: GPU = GFX0 G-state set to 3 from 3, ControlID = 17
4/11/12 4:14:56.000 PM kernel: AGPM: GPU = GFX0 G-state set to 1 from 3, ControlID = 17
4/11/12 4:15:00.000 PM kernel: AGPM: GPU = GFX0 G-state set to 0 from 1, ControlID = 17
That can't be right. My SMBios is definitely iMac 12,1, confirmed by Chameleon Wizard, and I've disabled G-state 0 in AGPM:
	  <key>Threshold_High</key>
	  <array>
	   <integer>0</integer>
	   <integer>45</integer>
	   <integer>75</integer>
	   <integer>100</integer>
	  </array>
	  <key>Threshold_Low</key>
	  <array>
	   <integer>0</integer>
	   <integer>0</integer>
	   <integer>87</integer>
	   <integer>98</integer>
	  </array>
Update 2: It's definitely a problem with GPU speedstepping. It changes to G-state 0 at the exact moment that the animations go choppy, according to something noticed at a reboot.

Update 3: Okay, GPU Speedstepping now works. I was missing the this stuff in AGPM:
	  <key>SensorOption</key>
	  <integer>1</integer>
	  <key>SensorSampleRate</key>
	  <integer>4</integer>
But the animations still aren't smooth, even if I fix everything to G-state 1.

Attached Files



#6
Hameer Abbasi

Hameer Abbasi

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
Okay, this is infinitely more weird! Using AutoCAD then closing it restores Lion to its perfect smoothness, no choppiness. Logging shows we're still in G-state 2.
Update: Restart, the silkiness of the animations remain! I'm not exactly sure WHAT fixed it. I Googled and lots of people with real Macs are having the same issue.





Also tagged with one or more of these keywords: nVidia, Fermi, GTX 550 Ti


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy