Jump to content

[miniguida] iAktos L2 su HP Mini 210-1030SL


  • Please log in to reply
17 replies to this topic

#1
emachinesE510

emachinesE510

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Salve, spiluccando vari post in giro per la rete sono riuscito ad installare la Iaktos L2 su un hp mini 210-1030sl.
Tralascio la preparazione della partizione dove installare mac Lion. Prima di iniziare ho collegato tastiera e mouse su porte usb. Dopo il boot del dvd alla prima schermata ho premuto F8 e scritto "mach_atom" per selezionare il kernel adatto ai netbook (vedi guida http://www.osx86inst...tion-guide.html)
Di seguito indico ciò che ho scelto di installare da questa distribuzione.

- iAktos L2 Main System (selezionato di default)
- Bootoloader: Chameleon 2.1
- Bootloader options: Graphics Enabler, Builtin Ethernet, PC-Root-1, 32-bit
- Patcher: Fake SMC, Disabler, RTC: RTC 32 bit, EVOreboot, IOPCIFamily, Custom Kernels: Atom Kernel 11.1.0
- Drivers: Main Hardware: SATA/IDE: AHCI SATA
- Drivers: Main Hardware: Sound: Voodoo: 2.7.3
- PS2
- Laptop Battery

Posted Image

La scheda video viene riconosciuta in modo nativo senza accelerazione grafica (ho letto che mettendo dei possibili driver, il sistema prima o poi va in crash).

Sembra che la webcam venga riconosciuta da sola, mentre ci sono problemi con il touchpad e col click di selezione (non funziona e non sono riuscito a risolvere): per ora l’unica è usare un mouse esterno usb. Per far funzionare la tastiera del notebook si ha bisogno dei driver PS/2 (selezionati in fase di installazione); quando viene avviato il sistema cerca di riconoscere il tipo di tastiera senza alcun risultato, ho ignorato la tal cosa e ho selezionato alla schermata successiva una tastiera Europe/ISo (se non ricordo male).

Audio: il volume rimane fisso e non si riesce a regolarlo, per rimediare a ciò ho seguito le istruzioni contenute in questo post http://www.tonymacx8...hp?f=16&t=28608 che dicevano di settare a true il valore VoodooHDAEnableVolumeChangeFix.
Oppure cancellate il file VoodooHDA.kext che trovare in /Sistema/Libreria/Extensions e mettete il seguente kext (in allegato) con l’aiuto del programma Kext Helper (http://cheetha.net/ il quale non sembra perfettamente compatibile con Lion, tant'è che per uscire dal programma devo ricorrere all'uscita forzata dal Finder)e riavviate.

Il wifi interno non funziona, io ho rimediato con una chiavetta usb della dlink e seguendo queste istruzioni: http://www.insanelym...owtopic=273872. usando il file in allegato "RT73 Lion Fix.zip" (se volete le istruzioni in italiano le trovate qua http://www.insanelym...howtopic=267237). Il kext contenuto dentrop il file .zip l'ho sempre caricato con Kext Helper. Una volta installato sono andato su Preferenze di sistema -> Networkm quindi su Posizione e ho selezionato Sconosciuto e nella colonna di sinistra è apparso un servizio che dovrebbe prendere il nome della chiavetta (identificata come 54m usb nel caso di sweex lw053 o 802.11 bg wlan nel caso did link dwl-g122). Poi ho usato il programma WirelessUtility per fare la connessione col router e poi safari per una prima navigata.

Ho provato ad aggiornare il sistema alla versione 10.7.3 ma il sistema al riavvio è andato in crash: se non ho capito male ha a che fare o con le porte usb o con IOPCIFamily.

Saluti e Buona Pasqua a tutti.

Attached Files



#2
Fiox89

Fiox89

    InsanelyMacaholic

  • Moderators
  • 4,518 posts
  • Gender:Male
  • Location:Soverato - Italy
  • Interests:Informatica, Motori...e Donne! :D
Sposto in Guide E Trucchi per Note/Netbooks ;)

#3
emachinesE510

emachinesE510

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Grazie 1000!! Non mi ero accorto dell'errore di sezione.
Auguroni di Buona Pasqua.
Ciao

#4
cavallo

cavallo

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 312 posts
  • Gender:Male
Io Pci non c'entra anzi e' il contrario, da 10.6.7 in poi si doveva scrivere a mano o editarlo nel bootplist come npci=0x2000 o 0 x3000.
Secondo me il tuo problema potrebbe essere PCIroot 1. Se l'Usb funziona cioe riesci a vederle e trasferire files da e per il tuo netbook allora e' pciroot 1. Io poco sopra la tua ottima guida ne ho scritta una per il mio asus EEEPC 1001PX. Ho visto che hai selezionato rtc32 vai a vedere che non sia quello.
Tu che grafica hai?
Ciao e grazie

#5
Maurino

Maurino

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
Ciao, potresti dirmi cosa hai utilizzato per rendere bootable la usb sulla quale hai ripristinato l'immagine di iAtkos L2?
Io ho provato con Chameleon RC5, il boot va a buon fine, ma quando digito " mach_atom " va in crash e si riavvia. Stesso risultato se non lo scrivo. Su un altro pc, utilizzando la stessa penna usb, (essendo un i5 non utilizzo mach_atom) l'installazione parte e va a buon fine.
Ti ringrazio, ciao!

#6
cavallo

cavallo

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 312 posts
  • Gender:Male
Non vorrei dire una stupidata ma penso che non ci sia bisogno di un ulteriore bootloader. Nel caso delle retail si perche' come sai tu ripristini l'immagine di un dvd che ha il suo che non ti farebbe partire il sistema. Se hai pazienza provo e ti faccio sapere

#7
Maurino

Maurino

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male

Non vorrei dire una stupidata ma penso che non ci sia bisogno di un ulteriore bootloader. Nel caso delle retail si perche' come sai tu ripristini l'immagine di un dvd che ha il suo che non ti farebbe partire il sistema. Se hai pazienza provo e ti faccio sapere


Aspetta, facciamo ordine.
Trattandosi di HP Mini 210, ossia di un netbook senza lettore dvd, devi per forza ripristinare l'immagine .dmg su una penna usb. Fatto questo ci si deve installare un bootloader (Chameleon o altri, credo sia indifferente), altrimenti l'installazione non parte a differenza di quando si masterizza l'immagine su un dvd. Fatto tutto, a bootloader partito, quali comandi bisogna dare oltre "mach_atom"? Oppure basta questo? Nel mio caso (HP MIni 210 1020 sl) pare non bastare: parte il boot Chameleon, lancio il comando, inizia a caricare, ma l'installazione non parte perché si riavvia tutto.

Ho cercato qualcosa in giro, ma non ha funzionato nulla, mentre sul fisso in firma l'installazione parte senza problemi e si conclude alla perfezione.

#8
cavallo

cavallo

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 312 posts
  • Gender:Male
Hai ragione tu ci vuole un bootloader, ma non uno a caso devi cercare la versione giusta. io avevo dato mach_atom cpus=1 arch=i386. A me parte anche solo con mach_atom. Fai questo monta l'immagine vai dove ci sono i bootloader selezina coia e copialo sulla scrivania. poi installalo.

non chimera chameleon

#9
Maurino

Maurino

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
Perfetto, provo subito e vi farò sapere. Grazie :-)

#10
Maurino

Maurino

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
Niente da fare, non ne vuole sapere. Ma a voi ha funzionato?

#11
cavallo

cavallo

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 312 posts
  • Gender:Male
Strano dovrebbe funzionare al di la dell'hardware. ho provato sul mio che e' peggiore anche facendo la chiavetta, a ma se parto in -v almeno fino ad un certo punto in cui si vede tutto nero si avvia anche mountain lion

#12
Maurino

Maurino

    InsanelyMac Protégé

  • Members
  • Pip
  • 19 posts
  • Gender:Male
Anche a me si blocca con mach_atom, senza di riavvia all'istante. Secondo me non funziona, a meno di utilizzare un lettore dvd esterno.

#13
cavallo

cavallo

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 312 posts
  • Gender:Male
intendevo in Mountain lion parte e poi si vede nero, in lion parte sempre con disco, chiavetta con disco e chiavetta con boot loader installato. A me ha installato anche 10.7.3 che e' un combo per desktop semplicemente perche non avevo cambiato il bios.plist, era ancora quello che installa iatkos cioè mac pro

#14
emachinesE510

emachinesE510

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Salve, ho letto solo ora i vostri post, ma devo dirvi subito che io non sono un grande esperto di informatica, ho solo provato i vari settaggi spulciando un bel po' di post e ho visto che la combinazione migliore era quella che avevo descritto sulla guida.
Tra l'altro sopra parlavo di "dopo il boot del dvd" dando per scontato che l'installazione avvenisse fatta con un lettore dvd esterno collegato al computerino, cosa che (e me ne scuso) ho dimenticato di esplicitare.
@cavallo: l'hp mini monta una scheda video gma 3150
@Maurino: in giro ho letto e visto un video su youtube, dove per poter far partire la iaktos da chiavetta usb devi prepararla da un mac, sotto windows sembra che non ci siano riusciti

#15
cavallo

cavallo

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 312 posts
  • Gender:Male
Ciao eeee machines grazie per l'informazione. quali sono i kext per la scheda grafica? Grazie comunque mi sono servito anche della tua guida. A me senza pciroot 1 mi va tutto. Dimenticavo potrebbe essere l'usb che ti crea problemi oltre alla pci root1

#16
emachinesE510

emachinesE510

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts
Ciao, grazie per i suggerimenti, appena avrò del tempo riproverò l'installazione togliendo pciroot1 e usb. La scheda video viene riconosciuta in modo nativo. Avevo provato dei kext trovati in giro ma andava in crash e quindi ho tenuto quelli nativi.
Ciao

#17
GHepA

GHepA

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
Ciao, ho un HP mini 210-2005sl (atom N550, GMA 3150, 2GB DDR3)
ho provato a seguire la guida, con lettore dvd esterno, ma non sono riuscito a far partire l'installazione:
arrivo al simbolo della mela con l'indicatore sotto che gira, ma ad un certo punto si pianta tutto e devo resettare.
Ho provato con mach_atom arch=i386 cpus=1 ma non cambia nulla.
possibile che il mio N550 essendo dual core non sia supportato dal kernel atom ??

ho provato anche a crearmi una chiavetta usb seguendo la guida di Fiox89 http://www.insanelym...howtopic=258485 ma ottengo lo stesso risultato
anzi il netbook si riavvia in continuazione.

avete suggerimenti?
Ciao

#18
cavallo

cavallo

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 312 posts
  • Gender:Male
Ciao GHepA, prova senza cpus=1 e arch=i386. Se non va c'e' un problema nel dvd. con ho senza chiavetta, con o senza dvd le ho provate tutte funzionano. Il mio asus e' molto peggio del tuo Acer.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy