Jump to content

Realtek HDA ALC888 with Microphone

ALC888 Amilo PI 3540 Realtek HDA 10.7.3 Lion VoodooHDA Kexts Microphone LegacyHDA Hackintosh

  • Please log in to reply
2 replies to this topic

#1
Download-Fritz

Download-Fritz

    InsanelyMac Protégé

  • Developers
  • 35 posts
  • Gender:Male
  • Location:Germany
  • Interests:Digital: Programming, gaming, surfing, chatting
Hey Macintosh and Hackintosh users!

My Hackintosh Lion 10.7.3 is completely working, without Sleep (untested), Wireless (Intel 5100 AGN, absolutely NO solution available), Webcam (never use it) and, the main problem, my ALC888 Soundcard. I tried through so many variations, like (HDAEnabler + AppleHDA (binpatched and unpatched) + various ALC888 kexts / LegacyHDA instead of the ALC888 kexts // including the ###### kexts (3 kexts) etc... VoodooHDA was the onliest kext, that got my Sound and Headphones completely working, but 2 problems are present, why I don't want to use it: 1. iTunes with bass sounds sounds really messed and crappy 2. The onliest problem that has to be solved is the microphone. I can live without Wireless, Sleep and the best sound quality, but I badly need the microphone. So, if anyone got the microphone working with an ALC888 (or maybe one of the other unimportant problems :D ), I would be grateful, if you give me some instructions or simply the download link :wink2:

Thanks to you guys!

Aditional Infos:
NO DSDT

FSC Amilo PI 3540
Intel Core2 Duo - Working
NVIDIA GeForce 9300M GS - Working
Realtek HDA ALC888 - Fix needed
Realtek RTL8169 - Working
Intel® WiFi Link 5100 AGN - Not working
Card Reader - Not listed, but working ^^
Battery - working (gets displayed, not tested when unplugged)
USB and other stuff - working
Sleep - Without SleepEnabler -> Partition corrupt, with SleepEnabler -> Not tested, too scared XD

System:
Mac OS X Lion 10.7.3
latest Chameleon Bootloader

EDIT: Sound Quality now excellent after a little modification in VoodooHDA's Settings :D Battery now also works!

#2
Download-Fritz

Download-Fritz

    InsanelyMac Protégé

  • Developers
  • 35 posts
  • Gender:Male
  • Location:Germany
  • Interests:Digital: Programming, gaming, surfing, chatting
Well, I got a combination, with that ALL audio devices (including my microphone :D ) get displayed! Well, they don't really work, so, anyone has an idea? Thanks!

#3
isidoro_mtnez

isidoro_mtnez

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
I have an ALC888/1200 working in 10.7.3 with ALC1200_1063 (from osx86 web)





Also tagged with one or more of these keywords: ALC888, Amilo PI 3540, Realtek HDA, 10.7.3 Lion, VoodooHDA, Kexts, Microphone, LegacyHDA, Hackintosh


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy