Jump to content

[SOLVED] nForce ethernet on iATKOS L2


  • Please log in to reply
3 replies to this topic

#1
palz

palz

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
I recently installed iATKOS L2 on my Acer Aspire X1700, and so far everything is working well (graphics, USB, drives, etc.) except for LAN and sound (VoodooHDA was causing kernel panics, so I reinstalled with only Apple's and it failed). I have an NVIDIA nForce ethernet card, and it was supported in Snow Leo (iATKOS S3 v2), but in Lion, there appears to be an NVEthernet driver installed already, but it isn't working properly. Is this driver available?

SOLUTION: Replace Apple's nvenet.kext (inside IONetworkingFamily.kext/Contents/PlugIns) with nForceLAN.kext. It still stops working after a little while, forcing me to reboot or reload the driver, and kernel panics frequently.

#2
palz

palz

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
bump, I've heard that others have gotten it to work on Lion, how do I do that?

#3
palz

palz

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
please help

#4
palz

palz

    InsanelyMac Protégé

  • Members
  • Pip
  • 20 posts
Ok, since nobody apparently knows anything about this, here's my solution: Go into IONetworkingFamily.kext and find the PlugIns folder. Replace the stock "nvenet.kext" with an nForceLAN driver, and you'll have unstable internet for a while, until it kernel panics to hell.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy