Jump to content

Lion won't boot after VoodooHDA.kext installation


  • Please log in to reply
3 replies to this topic

#1
Joe Crozier

Joe Crozier

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
System: P55A-GD55
CPU: Intel Core i5-750
Graphics: ATI Radeon HD 6770 512MB


Hi there,

I recently followed the instructions for the USB method Lion tutorial, and it was for the most part a success.

I had a working Lion system, apart fom some small issues with audio where I would hear faint feedback at high levels. I read somewhere else that installing an older version of VoodooHDA would fix the problem, so I went ahead and installed it.

Unfortunately, upon verbose booting, I was greeted with an unfamiliar error message, one which no amount of google and forum searching seems to help with.


PCI configuration begin
PCI configuration changed (bridge=1 device=0 cardbus=0)
PCI configuration end, bridges 7 devices 20
kxld[com.apple.driver.AppleRTC]: The Mach-0 file is malformed: Invalid magic number: 0xbebafeca
Can't load kext com.apple.driver.AppleRTC - link failed.
Failed to load executable for kext com.apple.driver.AppleRTC
Kext com.apple.driver.AppleRTC failed to load (error 0xdc008016)
Failed to load kext com.apple.driver.AppleRTC (error 0xdc008016)
Couldn't alloc class "AppleRTC"
FakeSMC: opensource SMC device emulator by netkas © 2009
FakeSMC: plugins & plugins support modifications by mozodojo, usr-see2, slice © 2010
FakeSMCDevice: 17 preconfigured keys added:
FakeSMCDrvice: successfully initialized
** AppleSMBusPCI :: start failed to get acpi path for provider
** AppleSMBusPCI :: start failed to get acpi path for provider
[RealtekRTL81xx:init] RealtekRTL81xx.kext v0.0.90 ©2010-2011 by Lnx2Mac
[RealtekRTL81xx:init] _loglevel is now 132 (0x0084)

[RealtekRTL81xx:init] Using updated PHY config method

[RealtekRT81xx:init] init completed
FireWire runtime power conservation disabled. (2)
FireWire (OHCI) VendorID 1106 3404 PCI now active, GUID 0010dc0001b5403f; max speed s400.

And from there it hangs indefinitely. As I've said this completely baffles me, as prior to the kext installation the system worked just fine. I've tried deleting the kext in MacDrive in Windows, and even though the kext is gone from S/L/E, the same error message occurs.

I've tried booting with -x, -f, PCIRootUID=1, and several other boot flags, none of which seem to have any effect.

I've been using Hackintosh for nearly two years now so I generally know what I'm doing, though this message really seemed to stump me. I'd really rather not start from square 1 (wipe the drive, install SL, update to 10.7.2, download Lion, install Lion to USB stick, and install), as I'm sure that there is a way to fix this, I just can't figure out what it is.

If one of you could provide some insight, I'd be eternally grateful.

Thanks!

tl;dr VoodooHDA.kext caused Lion to become unbootable. Tried bootflags and deleting the kext, no result.

#2
rlf

rlf

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,000 posts
Did you remove AppleHDA.kext first? They cannot exist together.

You should be able to boot into single user mode -s which gives you a text gui.

When it gets to the command line type:
mount -uw /
cd /System/Library/Extensions

Next, if you are going to remove AppleHDA.kext, then type this:
mv AppleHDA.kext AppleHDA.kext.bak

But if you are going to remove VoodooHDA.kext, then type this:
mv VoodooHDA.kext VoodooHDA.kext.bak

Now reboot the computer using -v -f

#3
sinanziric

sinanziric

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
mount -uw /
cd /System/Library/Extensions
rm -rf AppleHDA.kext

first time typing code on forum, so I'm testing :D
but also wanted to say that you can remove .kext :)

#4
alaskantraveler

alaskantraveler

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 118 posts
  • Gender:Male
  • Location:Central Arizona Desert
  • Interests:Single Carburetor GoldWings
    BlackPowder Revolvers
    PC based OSX

    AMD...
Use the mv to bak method until you are sure you don't need the kext. Once it boots and works with the .bak then you can remove it.

oh, yeah. you need to remove the .mkext files to get things going.

boot into single user by typing -s at the chameleon prompt.

type /sbin/mount -uw / at the prompt.

Type rm -rf /System/Library/Caches/com.apple.kext.caches

Type rm -rf /Extra/ *.mkext

Type reboot.

cross fingers, should work.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy