Jump to content

MacOSX installed - but Black screen....


  • Please log in to reply
29 replies to this topic

#21
blubberor

blubberor

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
as I had a lot of problems finding getting the right EDID I used another tool "monitorinfoview"

This gave me this:

==================================================
Monitor Name	  : t Flat Panel
Active		    : Yes
Serial Number	 :
Manufacture Week  : 45 / 2002
ManufacturerID    : 55629 (0xD94D)
ProductID		 : 1530 (0x05FA)
Maximum Resolution: 0 X 0
Image Size	    : 30.9 X 17.4 cm (14.0 Inch)
Maximum Image Size: 31 X 17 cm (13.9 Inch)
Horizontal Frequency: 29 - 47 KHz
Vertical Frequency:
Digital		   : Yes
Standby Mode	  : Yes
Suspend Mode	  : Yes
Low-Power Mode    : Yes
Default GTF	   : No
Display Gamma	 : 1.00
Serial Number (Numeric): 0 (0x00000000)
EDID Version	  : 1.4
Registry Key	  : SNY05FA\5&3ad961d4&0&UID16777488
Computer Name	 :
Last Update Time  : 01.04.2012 17:02:22
==================================================

Hope it works now...

#22
iLeopod

iLeopod

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 435 posts
  • Gender:Male
  • Location:Germany
  • Interests:ileopod.wordpress.com
Ok, now whe should have the right IDs.
Folder: DisplayVendorID-D94D
File: DisplayProductID-5fa
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>DisplayProductID</key>
<integer>1530</integer>
<key>DisplayProductName</key>
<string>Internal LCD Forced EDID</string>
<key>DisplayVendorID</key>
<integer>55629</integer>
<key>IODisplayEDID</key>
<data>/***red code without space***/
</data>
</dict>
</plist>




#23
blubberor

blubberor

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
I am going to test as soon as I return from work ;) Thank you very much already!! Crossing fingers.Didn't work - maybe due to ProductID-5fa and -0(!)5fa ? I have the directory DisplayVendor-ID-D94D and within a file without extension name DisplayProductID-5fa


it contains:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>DisplayProductID</key>
<integer>1530</integer>
<key>DisplayProductName</key>
<string>Internal LCD Forced EDID</string>
<key>DisplayVendorID</key>
<integer>55629</integer>
<key>IODisplayEDID</key>
<data>
00FFFFFFFFFFFF004DD9FA05000000002D0C0104901F1100EAA8E099574B92251C505400000001010101010101010101010101010101201C56AE50000C303A3A440035AE10000018000000FC004E76696469612044656661756C000000FC007420466C61742050616E656C00000000FD00003D1D2F0800002020202020000003
</data>
</dict>
</plist>


Do you see any mistake?


Edit2

As soon as I'm a t home I will try this:
- Go to Library/Extensions and DELETE the NVDAN50HAL.kext

#24
glapi

glapi

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
Hello, I have the same problem with the same computer. :s

#25
iLeopod

iLeopod

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 435 posts
  • Gender:Male
  • Location:Germany
  • Interests:ileopod.wordpress.com
No the Zero should not make any difference.If we really made no mistake, it will maybe never work. This is a special sony related problem because Sony is going his own way ignoring specifications.

#26
blubberor

blubberor

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
This is really annoying.... :/
no chance to get a kext or saomething for it? it's so strange as installation and booting works on the internal lcd...

#27
rlf

rlf

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,008 posts

This is really annoying.... :/
no chance to get a kext or saomething for it? it's so strange as installation and booting works on the internal lcd...

The VESA video mode you have during installation and booting has no control over your resolution and graphics acceleration. If you temporarily moved all of your Nvidia and Geforce kexts to a folder, you would have no drivers in the way and you would get VESA video mode. You would see your Desktop but it would be far from ideal. It would alleviate your frustration temporarily but it would not be the ultimate solution.

All searching I have done with regards to the GT330M in a Vaio does not reveal good news. Success on external monitors and only partial success on the internal monitor.

#28
glapi

glapi

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
up, nobody has find a solution?

#29
blubberor

blubberor

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
hrmm would be interesting for me as well. I didn't figure anything new out :/

#30
glapi

glapi

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
blubberor I have find this: http://www.tonymacx8...p?f=170&t=41669

I don't know if it's work, but we can try it...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy