Jump to content

No QE/CI With Geforce 9800GT In DP 2


  • Please log in to reply
28 replies to this topic

#1
CrazyELF

CrazyELF

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Montreal
Hi I installed 10.8 dp 2 and it see the 9800gt just fine but I have no acceletated Graphics with with Nait.kext or Nabler64.kext or GraphicsEnabled=Yes in boot
In 10.8 dp 1 and 10.7.3 all I needed was GraphicsEnabled=Yes
Anyone eles have issues with this card?

#2
rlf

rlf

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPip
  • 1,008 posts
Maybe you need the latest Chameleon with Mountain Lion support: http://www.insanelym...howtopic=231075

Make sure you select one for ML.

#3
CrazyELF

CrazyELF

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Montreal
Tried the Latest Chameleon and still no go..

#4
CrazyELF

CrazyELF

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Montreal
So I've been looking in to my problem a little More and it seems the NVDANV50Hal.kext was not loading. so I look to the kext and it had no Package Contents so I grabed the one for the Base.dmg replaced it and did a discUtil Repair and now the kext loads but I get a kernel Panic.. What the hell did Apple do to Dp2 that's do diffrent fro Dp1.. Posted Image

#5
Taruga

Taruga

    Retired

  • Retired Developers
  • 533 posts
  • Gender:Male
  • Location:Portugal

So I've been looking in to my problem a little More and it seems the NVDANV50Hal.kext was not loading. so I look to the kext and it had no Package Contents so I grabed the one for the Base.dmg replaced it and did a discUtil Repair and now the kext loads but I get a kernel Panic.. What the hell did Apple do to Dp2 that's do diffrent fro Dp1..



I'm also having that same error, but I've found out that if I boot with -x and then reboot ... then it works.

#6
CrazyELF

CrazyELF

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Montreal
Taruga what version of Cameleon are you using? and are you using a Geforce 9800gt 512 as well?
are you using GraphicsEnabler=yes and with what Kernel flags String? npci=0x2000?

#7
Taruga

Taruga

    Retired

  • Retired Developers
  • 533 posts
  • Gender:Male
  • Location:Portugal

Taruga what version of Cameleon are you using? and are you using a Geforce 9800gt 512 as well?
are you using GraphicsEnabler=yes and with what Kernel flags String? npci=0x2000?


I'm using chameleon 1820 with a GTX 260 and GraphicsEnabler, i don't use the npci flag.

#8
CrazyELF

CrazyELF

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Montreal
yea I've tried with -x same resualt I tired chameleon 1820 1823 all the way up to 1897 I've tried chimera 1.8 all with or without or GraphicsEnabler or Npci flags... I'm really at a loss here don't know what eles to try Think I'll just stick with Dp1 and wait and see what Dp3 is like..

#9
René_

René_

    InsanelyMac Protégé

  • Donators
  • 76 posts
  • Gender:Male
  • Location:Maassluis, Netherlands
I've a 8800GT, works fine in DP1. In DP2 can't even boot to install > black screen
Tried a lot, saw even once a "[AGPM Controller] unknowPlatform".

Maybe we lost support after years with the 8800GT/9800GT.

#10
Taruga

Taruga

    Retired

  • Retired Developers
  • 533 posts
  • Gender:Male
  • Location:Portugal
I have a GTX 260 (10de05e2) and my smbios.plist has MacPro5,1.
AppleGraphicsPowerManagment.kext has info for it:


<key>MacPro5,1</key>
<dict>
<key>Vendor10deDevice05e2</key>
<dict>
<key>Heuristic</key>
<dict>
<key>ID</key>
<integer>0</integer>
<key>IdleInterval</key>
<integer>250</integer>
<key>SensorOption</key>
<integer>1</integer>
<key>SensorSampleRate</key>
<integer>4</integer>
<key>TargetCount</key>
<integer>5</integer>
<key>Threshold_High</key>
<array>
<integer>87</integer>
<integer>87</integer>
<integer>87</integer>
<integer>100</integer>
</array>
<key>Threshold_Low</key>
<array>
<integer>0</integer>
<integer>87</integer>
<integer>87</integer>
<integer>87</integer>
</array>
</dict>
<key>LogControl</key>
<integer>1</integer>
<key>control-id</key>
<integer>18</integer>
</dict>


#11
cochon

cochon

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
  • Gender:Male

I've a 8800GT, works fine in DP1. In DP2 can't even boot to install > black screen
Tried a lot, saw even once a "[AGPM Controller] unknowPlatform".

Maybe we lost support after years with the 8800GT/9800GT.


8800GT/9800GT are still using NVDANV50Hal.kext in DP1/DP2. Apple removed NVDANV40G7xxx.kext, no longer support 32-bit

#12
CrazyELF

CrazyELF

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Montreal
I seen another post on a difrent site talk about adding Device id to NVDANV50Hal.kext, Geforce.kext and NVDAResman.kext as well to add the Word Primary in the <key>IOPCIMatch</key> String
Example on all 3 kext
<key>IOPCIPrimaryMatch</key>
<string>0x061410de&amp;0x0000ffff</string>
I'll give that a try when i get home don't know if it will fix this Hoping for the best.

#13
CrazyELF

CrazyELF

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Montreal
So this didn't work still at square one

:help:

#14
goodbye losers

goodbye losers

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 261 posts
my 8800gt works fine in dp1 and dp2 with chameleon r1820

try this in your boot.plist


<key>GraphicsEnabler</key>
<string>Yes</string>
<key>UseNvidiaROM</key>
<string>Yes</string>
<key>VBIOS</key>
<string>Yes</string>

and place the attached rom in your extra folder and replace the "dev-id" you have!!!




sorry for my bad english :-)

Attached Files



#15
CrazyELF

CrazyELF

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Montreal
Hey goodbye losers,
when you say replace the "dev-id", Where do i change it? in the 10de_0611.rom? or in the NVDANV50Hal.kext, Geforce.kext and NVDAResman.kext?
And so I still use Kernel flags String? npci=0x2000?

#16
goodbye losers

goodbye losers

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 261 posts
this is my plist:

PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Boot Banner</key>
<string>No</string>
<key>DSDT</key>
<string>/dsdt.aml</string>
<key>Graphics Mode</key>
<string>1280x1024x32@75</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>Quiet Boot</key>
<string>Yes</string>
<key>Rescan</key>
<string>Yes</string>
<key>UseNvidiaROM</key>
<string>Yes</string>
<key>VBIOS</key>
<string>Yes</string>
</dict>
</plist>

rename the romfile! see my systemprofiler...

Attached Files

  • Attached File  Sys.jpg   119.22KB   124 downloads


#17
CrazyELF

CrazyELF

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Montreal
all be god dammed it alctuly worked lol However I had to change my Smbois to a MacBook Pro 5,1 but I can live with that and the Fan's on the card a Quite Now!
Thanks!

#18
CrazyELF

CrazyELF

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Montreal
Now the bigger question is why does this Method Only work in 10.8 Dp2? And not 10.7.3 and why can't I use a Diffrent SMbios other than MacBookPro 5,1?

#19
eurisko1

eurisko1

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Spain
I have a asus en9800gt in LION 10.7.3 and ML DP2 and I have not any problem. The best way to run this card is through DSDT. See this post: http://tonymacx86.bl...a-graphics.html

#20
CrazyELF

CrazyELF

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts
  • Gender:Male
  • Location:Montreal
Hey eurisko1 I tried to follow the guide but either I don't know what I'm doing or it didn't work... Are you good with DSDTSE Editor? If I sent you my Current DSDT file and what ever other info you need on the card would you be able to edit it Properly?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy