Jump to content

AMD Radeon HD 6650M / Graphics Enabler / DSDT / HDMI Audio / Acer Aspire 7750G - 2674G50Mnkk [Gradients Fixed]

ATI 6650M GraphicsEnabler ATI 6650M 10.6.8 AMD Radeon HD 6650M ATI Radeon HD 6650M mac AMD 6650M custom personality 6650M DSDT patch ATI Radeon HD 6650M DSDT ATI Radeon 6470M DSDT

  • Please log in to reply
868 replies to this topic

#161
Basaa

Basaa

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Trucker, I would like to try if I can patch the ATI6000Controller.kext myself. Could you give me some fast instructions on what to patch, and how to do that? I really can't wait untill 22:00 :o.
God, I'm so impatient :S

Thanks!

#162
Trucker MK

Trucker MK

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 347 posts
  • Gender:Male
  • Location:Republic Of Macedonia
Find the Ipomoa personality offset in the ATI6000Controller.kext (You can do this with ATI-personality.pl, go few pages back, there's a link for it). Than open the kext with hex editor and replace the values starting at that offset with my ipomoea configuration (look for it on post #1)

#163
Basaa

Basaa

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Working on it real hard.

When I don't succeed, would you still do it for me tonight please? :P

Thanks for your help, I really appreciate it :)

#164
Trucker MK

Trucker MK

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 347 posts
  • Gender:Male
  • Location:Republic Of Macedonia
Yes, don't worry. I'll do it anyway.

For LVDS, change transmitter from 20 to 10 if you are using my DSDT patch.

#165
Basaa

Basaa

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
I have no idea what you are talking about, but yeah, I will change it :P

#166
Trucker MK

Trucker MK

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 347 posts
  • Gender:Male
  • Location:Republic Of Macedonia
02 00 00 00 40 00 00 00 09 01 00 00 10 01 00 03 --- LVDS

00 08 00 00 00 02 00 00 00 01 00 00 11 02 04 01 - HDMI

10 00 00 00 10 00 00 00 00 01 00 00 00 00 01 05 - VGA

#167
Basaa

Basaa

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
I downloaded the decoder, but I get this:

Bass-Mac-Pro:ati-personality.pl.0.10 basbuur$ perl ati-personality.pl
Kext /System/Library/Extensions/ATI1300Controller.kext/Contents/MacOS/ATI1300Controller
Cannot open otool -arch x86_64 -l /System/Library/Extensions/ATI1300Controller.kext/Contents/MacOS/ATI1300Controller for input

EDIT: Ah, need Xcode, installing :)

Ok, got the offset. 182640.

So, now I should open the kext file with a hex editor? Or 1of the files inside it?

And then replace it with what you posted 2 posts back? Like, just paste those rows together, and start replacing?

#168
Basaa

Basaa

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
I replaced the framebuffer, and now it works.

http://i.imgur.com/90ypv.png

Again, thank you so, so much for all your work and help.

Basaa

#169
Trucker MK

Trucker MK

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 347 posts
  • Gender:Male
  • Location:Republic Of Macedonia
Post the output from ati-personality.pl here.
Yes, the file you need to edit is inside the kext, It's ATI60000Controller (without extension).
Open it with hex editor, than search for Find and Replace option. In the "FIND" field, paste the first line from the original ipomoea personality ( you got this with ati-personality.pl) and click "Find Next". You should now have those values highlighted in the hex editor. In the "REPLACE" field, paste the first line of values from the post above than click "Replace". Do the same for all 3 lines. At the end don't forget to save the file.
Edit. Great, I replyed to late, driving and typing takes long time.

Edit 2. You can read on the first post what's working, extended desktop, booting with HDMI/VGA connected etc. If you have the time you can play around with the HotplugIDs (the second two numbers from right to left in each line) . I was planning to fine tune these, but I bricked my laptop and never finished that. Post the results here if you find something new.

#170
Basaa

Basaa

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Ah ok, indeed everything works fine for me so far. No fuzzyness or whatsoever.

Great tip, thanks! Will let you know if I find something :)

Do you also have a working USB 3.0 kext? For me the entire OS freezes upon inserting a device into the slot.

How's your laptop now? It's working again? :P

#171
Trucker MK

Trucker MK

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 347 posts
  • Gender:Male
  • Location:Republic Of Macedonia
Today I've sent it for repair. nai22 will try to fix it.

#172
Basaa

Basaa

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Ah awesome. Well, good luck with it!
Thanks again, I'm very happy with my hackbook pro ;)

#173
Trucker MK

Trucker MK

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 347 posts
  • Gender:Male
  • Location:Republic Of Macedonia
Thanks. Yes, me to, it's a good hackbook.

Oh, one more thing. Please share your kext here if you want to. Someone else might need it.

#174
Basaa

Basaa

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Yes indeed!

And I would love to, but with the standard uploader I getan IO error, and with the basic uploader I can't select hidden files... Any ideas?

Also, I noticed that a gradient has like little bars, instead of a smooth transition. Any ideas / fixes for that?

#175
Trucker MK

Trucker MK

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 347 posts
  • Gender:Male
  • Location:Republic Of Macedonia
Try few times for the upload, eventually it will work.

There is no fix for that at the moment.

#176
Basaa

Basaa

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Ok, well it's very acceptable, so no worries. Will try to upload the kext.

What about my question in #170? You got a working USB 3.0 driver? And maybe even sleep mode?

#177
Trucker MK

Trucker MK

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 347 posts
  • Gender:Male
  • Location:Republic Of Macedonia
No for the USB 3.0
For sleep, you need to patch AppleIntelCPUPowerManagment.kext There's a script for this, search this forum for patching AICPUPM

#178
macsane123

macsane123

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts

You can start by testing all personalities and if none of them works for LVDS you need to choose one and edit the connector info ( SenseID, Transmitter, Encoder etc)


ok

#179
Tauio111

Tauio111

    InsanelyMac Protégé

  • Members
  • PipPip
  • 96 posts
  • Gender:Male
  • Location:Estonia
Patched the values of LVDS for pitchecia and ipomoea, tried them both with editing the chameleon conf. The LVDS is still black with no backlight.
This is what i used for lvds:
02 00 00 00 40 00 00 00 09 01 00 00 10 01 00 07

I have never achieved getting backlight working on the LVDS. It detects my GPU as 6400 series with 1024mb which is right. VGA screen working with 1440x900@75hz with customized edid file. When booting without VGA connected i get a kernel panic.
What am I missing?

#180
Trucker MK

Trucker MK

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 347 posts
  • Gender:Male
  • Location:Republic Of Macedonia

Patched the values of LVDS for pitchecia and ipomoea, tried them both with editing the chameleron conf. The LVDS is still black with no backlight.
This is what i used for lvds:

02 00 00 00 40 00 00 00 09 01 00 00 10 01 00 07

I have never achieved getting backlight working on the LVDS. It detects my GPU as 6400 series with 1024mb which is right. VGA screen working with 1440x900@75hz with customized edid file.
What am I missing?

Try different value for the transmitter.





2 user(s) are reading this topic

1 members, 0 guests, 1 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy