Jump to content

AMD Radeon HD 6650M / Graphics Enabler / DSDT / HDMI Audio / Acer Aspire 7750G - 2674G50Mnkk [Gradients Fixed]

ATI 6650M GraphicsEnabler ATI 6650M 10.6.8 AMD Radeon HD 6650M ATI Radeon HD 6650M mac AMD 6650M custom personality 6650M DSDT patch ATI Radeon HD 6650M DSDT ATI Radeon 6470M DSDT

  • Please log in to reply
905 replies to this topic

#721
cchumi

cchumi

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Great news :)

Actually i use a usb wifi stick and this is totally fonctional.

 

Do you think my idea of making a tutorial is good ? I must create a new topic for that or here it's the right place ?

 

Do you think correct dsdt warning is useful ? And what about optimizations ??? don't really find informations .



#722
freeuser16

freeuser16

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 170 posts
  • Gender:Male
  • Location:Lithuania

You can't use original Apple Airport software with USB stick. It's much better than 3rd party applications from USB sticks developers.

I'm not that good at writing tutorials to advise you something :) But you can create a thread for your notebook here on the forum, like I did on applelife. In appropriate section, of course.

Some DSDT fixes (RTC, HPET, PIC, TMR) are pretty important. Simple warnings and optimizations in compiler are not that important, but "nice to have", of course. It's not difficult at all to fix them :)



#723
zsolt.molnarrr

zsolt.molnarrr

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Hello there!

 

I have an Acer Aspire 7750G with: Intel Core i7 (2GHz), AMD Radeon HD 6650M (2GB), 17` screen (1600x900).

I am here to ask for your assistance. I have installed ML 10.8.4 and I can`t get the graphics card to work.

I would really appreciate if one of you could give me a detailed step by step list of instructions about how to get this graphics card working with Chameleon`s GraphicsEnabler on a fresh installation (,this would only cost you a few minutes but you could save weeks for me, cause I am a noob and I am working on this for 2 weeks ago now without any success). 

I don`t need the VGA or the HDMI ports working, but only the main screen of the laptop.

Please help me, I need hackintosh this for studying but I am stuck with the graphics and homework deadline is closing in! :D

 

Regards,

Molna'r Zsolt



#724
freeuser16

freeuser16

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 170 posts
  • Gender:Male
  • Location:Lithuania

Hi, Zsolt,

 

There is a guide in the OP of this thread. Have you tried to enable the card like Trucker did? Doesn't it work?



#725
zsolt.molnarrr

zsolt.molnarrr

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Yes I have installed the ATI6000Controller.kext and the latest bootfile from the #1Post (set GraphicsEnabler=Yes AtiConfig=Iponomea) and the system boots without panic, but it doesn't load the OSX gui. I end up seeing the messages from verbose, also it doesn't freeze, because when I type the password and hit return it throws up a few new lines about the login panel.

 

Sadly I'm working from various sources (I had to install easybeas to generate a org.chameleon.boot.plist and a few other things those haven't been isntalled by chameleon), so I'm not sure if this causes incompatibility or not.

 

Another problem (I don't know, this might be caused by the missing graphics acceleration but) my system is bit slow, mostly when I open safari elements those require advanced graphics. So I don't know if it is normal that I/O is blocked/slowed by the graphics. Do I need anything to install to get multi core processing enabled?



#726
freeuser16

freeuser16

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 170 posts
  • Gender:Male
  • Location:Lithuania

(set GraphicsEnabler=Yes AtiConfig=Iponomea)

You meant "Ipomoea", right? Make sure you haven't mistyped this in your config :)



#727
zsolt.molnarrr

zsolt.molnarrr

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Yes I ment "Ipomoea". I couldn't misstype it, because I choose it from a scrolldown list in Chameleon wizard.



#728
freeuser16

freeuser16

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 170 posts
  • Gender:Male
  • Location:Lithuania

Wait, so what actually doesn't work? Is notebooks screen black with/without backlight or the card is not recognised? Or the system doesn't even boot up correctly with Truckers files?



#729
zsolt.molnarrr

zsolt.molnarrr

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

It doesn't boot up correctly. It recognizes the card(I can see a few lines about it, at different stages of the boot process) and the screen doesn't go off it just doesn't changes to the GUI from the verbose text.



#730
freeuser16

freeuser16

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 170 posts
  • Gender:Male
  • Location:Lithuania

That's very weird. Anyway, post here your videobios and I will have a look. Maybe you have a bit different card than Trucker and need different ATI6000Controller patch.



#731
steve6x

steve6x

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts

Doesn't that computer need a DSDT?



#732
freeuser16

freeuser16

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 170 posts
  • Gender:Male
  • Location:Lithuania

Doesn't that computer need a DSDT?

It depends on videobios, Steve. Chameleons graphics injector doesn't work only if LVDS senseid is 7. Trucker has the same notebook with senseid=03 and he can enable the card without DSDT ;)



#733
zsolt.molnarrr

zsolt.molnarrr

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Here is my vbios dump.

 

https://dl.dropboxus...434/vgabios.dmp



#734
freeuser16

freeuser16

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 170 posts
  • Gender:Male
  • Location:Lithuania

Here is my vbios dump.

 

https://dl.dropboxus...434/vgabios.dmp

Well, your card is identical to Truckers one. Thus kexts from the first post should work 100%. Either you installed them wrong / for the wrong version of OS or Trucker did something wrong when patching that kexts.



#735
zsolt.molnarrr

zsolt.molnarrr

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Is it possible to identify those installed kexts which are incompatible?

#736
freeuser16

freeuser16

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 170 posts
  • Gender:Male
  • Location:Lithuania

Post here your original ATI6000Controller kext from your system and I will patch it for you with Truckers numbers. Or you can do it on your own, it's pretty straight forward - http://www.insanelym...32#entry1936584. Use all the number from the first post.



#737
zsolt.molnarrr

zsolt.molnarrr

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Thank you! I`ve attached the original ATI6000Controller, but note, I was trying to use 10.8.4_GE_ATI6000Controller from the 1#Post.

 

Please tell me what other kexts do I need to have or delete, and what else I need to do from a fresh installation!

I`ve also tried with ATISupport+AMDRadeonAccelerator+ATIFramebuffer kexts, but I still get the original problem.

My SMBIOS is MBP(8,3).

Attached Files



#738
zsolt.molnarrr

zsolt.molnarrr

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Guys, do I have any chance for getting help or answer for my questions?

#739
freeuser16

freeuser16

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 170 posts
  • Gender:Male
  • Location:Lithuania

This kext you posted is already patched. I asked for original one from the system you are using.



#740
zsolt.molnarrr

zsolt.molnarrr

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

I don't know how it is possible. After I installed the system I moved every graphics kexts into a folder and the one which I uploaded here is from there. How can I get a clean one if not from my system?







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy