Jump to content

[aiuto]Sapphire 5770 ed artefatti grafici


  • Please log in to reply
13 replies to this topic

#1
MacGTO

MacGTO

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 154 posts
ciao a tutti, ho appena aggiornato nel mio hack la scheda video prendendo questa ati sapphire 5770 hd con 1gb gddr5.
La cosa strana è che Lion (10.7.3) la riconosce nativamente....ma ho dei continui artefatti grafici.....che sono un po' noiosi...

credo dipenda anche dal fatto che mi viene riconosciuta dal sistema come Ati 5000 series... e non come ati radeon hd5770....

Avvio senza Graphics enabler, e non ho dovuto modificare nessuna kext...

idee su come risolvere il problema???

#2
l3l3k

l3l3k

    InsanelyMac Protégé

  • Members
  • PipPip
  • 89 posts
  • Gender:Male
  • Location:Cesena
Ma con altri sistemi operativi la scheda va bene? Che tipo di artefatti ti fa?
Mi pare strano che sia colpa di un mancato riconoscimento

#3
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 8,901 posts
  • Gender:Male
  • Location:Italy
Devi mettere :
<key>GraphicsEnabler</key>
<string>Yes</string>


#4
MacGTO

MacGTO

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 154 posts
Gli artefatti del tipo come se tutta la finestra andasse in prospettiva in un unico punto...tipo rimangono parti di finestre anche se la finestra viene chiusa...e li fa anche con ge=yes....idee??

E cin Windows Va a bomba....

#5
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 8,901 posts
  • Gender:Male
  • Location:Italy
Strano come scheda viene riconosciuta nativamente solo devi aggiungere GE=Yes

#6
MacGTO

MacGTO

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 154 posts
aggiungendo Ge=yes, ottengo che al posto di essere vista come 5000series viene vista come 5700 series....ma mai come ati hd5770....non è che possa dipendere dal Framebuffer???

cmq gli artefatti restano...

#7
MacGTO

MacGTO

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 154 posts
Up

#8
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 8,901 posts
  • Gender:Male
  • Location:Italy
Posta IoReg e org.c.b.p.

#9
MacGTO

MacGTO

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 154 posts
org.c.b.p


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>AtiConfig</key>
<string>Vervet</string>
<key>AtiPorts</key>
<string>4</string>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>
<key>Graphics Mode</key>
<string>1920x1080x32</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>Theme</key>
<string>LoginToLion</string>
<key>Timeout</key>
<string>2</string>
</dict>
</plist>

ioreg come lo posto???

#10
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 7,512 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Devi farlo con DSDTSE http://www.osx86.es/...ivos/DSDTSE.zip

Attached Files



#11
Fiox89

Fiox89

    InsanelyMacaholic

  • Moderators
  • 4,518 posts
  • Gender:Male
  • Location:Soverato - Italy
  • Interests:Informatica, Motori...e Donne! :D
Questa serie non ha bisogna nè di graphics enabler ne di nulla. Funzionano OOTB. In genere basta modificare l'id nel kext ati

Che venga visualizzata come 5000 series è normalissimo. Hai guardato se l'id nel Info.plist del kext è corretto?

hai accelerazione grafica?

#12
MacGTO

MacGTO

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 154 posts
Viene vista nativamente e senza modificare nessuna kext....i due id sono già presenti....solo che non mi spiego gli artefatti grafici.....pensavo fosse un problema di framebuffer....

#13
.::Fabio::.

.::Fabio::.

    InsanelyMac Legend

  • Moderators
  • 8,901 posts
  • Gender:Male
  • Location:Italy
in o.c.b.p. hai il framebuffer della tua scheda

#14
MacGTO

MacGTO

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 154 posts
Vervet..... E allora perché gli artefatti???

E poi perché ad alcuni viene riconosciuta come ati radeon hd 5770??





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy