Jump to content

iAtkos L2 install problem on MSI P6N SLI-FI

iatkos l2 msi p6n sli install problem bootcachecontrol

  • Please log in to reply
4 replies to this topic

#1
mitsos1os

mitsos1os

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
  • Gender:Male
(CHECK BELOW FOR SOLUTION!)

ORIGINAL:
Hi guys. I downloaded the iAtkos L2 DVD and restored it on a usb flash drive through osx 10.6 i have already installed on my PC. If I tried booting from the usb just like that, I got the still waiting for root device error after loading kexts, so I just copied the AppleNforceAta.imk64bit.kext from Verdant's files (a big thanks to Verdant for his helpful post), and I managed to surpass this. However now after a while, the loading hans at a point with this message:

BootCacheControl: Unable to open /var/db/BootCache.playlist: 2 no such file or directory
Bug:launchctl.c:2408 (24687):30: cdefd =open (g_overrides_db_patch....

and can't start the installation. Somewhere I read that a fakeSmc will fix this, so I also tried different fakesmc's from verdant's files again but now it doesn't even hang, it immidiately restarts the pc without having time to see the error.

Any ideas on what to do in order to be able to finally start the installation? THanks

UPDATE: For usb flash to boot normally, just copy AppleNForceATA.imk.64bit.kext and NforceLAN.kext in S/L/E from Verdant's files and install Chameleon Bootloader on USB from Verdant's files also. After install, you must boot in the installer again and install through the terminal, the chimera 1.9.1 bootloader on your OSX Volume. This requires that you have downloaded the chimera package and saved it somewhere. You can install it this way:
Let's say you have downloaded chimera to the root of your usb installation flash. Boot in the installer like you firstly did, and when it opens, select utilities and open Terminal. It will start a Terminal directly with administartor permissions (bash-3.2#)
type:
cd / (to move to top directory)
cd Volumes/USBFLASHNAME (Because we said that we downloaded the chimera package there)
installer -pkg chimera-packagename.pkg -target /Volumes/OSX-VolumeName (replace the names with the corresponding ones from your configuration)

This should have done it. Just select restart and boot from your hard disk. It should continue normally the boot into the system.
Hope I helped

#2
mitsos1os

mitsos1os

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
  • Gender:Male
CORRECTION: Forget the restart, there was an error with chameleon. I tried with the other boot files (boot0 and boot1h) from EFI 10.6 and the boot file from netkas 10.7 as verdant suggested in his post, But now loading hangs at:
USBMSC identifier (non-unique) and some numbers.
Now what?

#3
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,641 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
hello

try in boot flags

USBFix=Yes

good hack

#4
mitsos1os

mitsos1os

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
  • Gender:Male
After using the latest chameleon on the USB flash and kexts for nforcelan and sata I managed to get through with the install. After install I put these kexts again in the S/L/E folder in hard drive ( otherwise still waiting for Root device appears) but now the install hangs at waiting for DSMOS. I have read different solutions like using the latest FakeSMC or deleting the Don't steal Mac os.kext but none of three work. What now?

#5
mitsos1os

mitsos1os

    InsanelyMac Protégé

  • Members
  • Pip
  • 31 posts
  • Gender:Male
UPDATE: Finally I found out that it was a matter of the bootloader beeing used. All this time I was using the versions os Chameleon Bootloader (including the one from the iAtkos setup and the one from Verdant's files from his guide about Lion on NForce). When I switch to the latest version of Chimera (1.9.1) it booted in the os normally and finished the configuration. Unfortunately I didn't have some drivers like audio but I think this will be easier to fix.... So waiting for DSMOS problem was bootloader related for me. Thank you, please mark this as Solved.





Also tagged with one or more of these keywords: iatkos l2, msi p6n sli, install problem, bootcachecontrol


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy