Jump to content

Trouble with native speedstep on EVGA X58 board

evga x58 speedstep

  • Please log in to reply
No replies to this topic

#1
marthastewart333

marthastewart333

    InsanelyMac Protégé

  • Members
  • Pip
  • 15 posts
Hi all,

I've got 10.6.8 running on my desktop, which has an EVGA X58 board with a Core i7 (specifically the EVGA 131-GT-E767-TR and the Intel Core i7-950. I used ##### to install, and I've got everything working so far, except for speedstep. The i7 makes my tiny apartment pretty hot running at 3 GHz nonstop.

The computer will not boot unless NullCPUPowerManagement.kext is in /E/E. If I remove it, I get a kernel panic (error 13, general protection) from AppleIntelCPUPowerManagement.kext as soon as darwin starts booting.

This is what I have in /Extra to get a booting system:
sh-3.2# ls -lh /Extra/Extensions
total 0
drwxr-xr-x 3 root wheel 102B Jan 7 2011 ALC8xxHDA.kext
drwxr-xr-x 3 root wheel 102B May 14 2011 FakeSMC.kext
drwxr-xr-x 3 root wheel 102B Aug 29 2009 IOAHCIBlockStorageInjector.kext


sh-3.2# cat /Extra/smbios.plist
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>SMfamily</key>
<string>Mac Pro</string>
<key>SMproductname</key>
<string>MacPro3,1</string>
<key>SMboardproduct</key>
<string>Mac-F42C88C8</string>
<key>SMserial</key>
<string>G88451235J4</string>
<key>SMbiosversion</key>
<string>######.tonymacx86.com</string>
</dict>
</plist>


sh-3.2# cat /Extra/org.chameleon.Boot.plist
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>arch=x86_64 busratio=23 npci=0x2000 PCIRootUID=1</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Graphics Mode</key>
<string>1920x1200x32@60</string>
<key>Timeout</key>
<string>2</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>UseKernelCache</key>
<string>Yes</string>
<key>Quiet Boot</key>
<string>No</string>
</dict>
</plist>


In S/L/E I've added
ALC892HDA.kext (to enable audio)
PHXCD.kext (for USB 3.0)
AppleRTL8169Ethernet.kext (to /S/L/E/IONetworkingFamily.kext/Contents/Plugins)


The rest I accomplished by patching my DSDT, as described here. However, I get the same kernel panic without NullCPUPowerManagement regardless of whether I use my DSDT or additional kexts. I also get the panic regardless of whether or not I use 32 or 64 bit or include or busratio=23 in my boot.plist.

I've tried disabling unused controllers and ports in my BIOS. I've also set my speedstep options to "Enabled" and "C1E" in my BIOS, and set HPET to "Enabled" and "64 bit", as recommended in other posts I've read. My BIOS is currently updated to the latest version, and speedstepping works fine on this machine in Windows and Linux. I've also tried EvoSpeedStep.kext, but I get the same panic.

This panic seems common with EVGA X58 boards, and there was some interesting discussion about the issue by d00d, banini_jeque, and others in these threads:
Vanilla Speedstep on EVGA X58 SLI
EVGA X58 Speedstep attempts with bios version >= 44
Evga X58 Native Powermanagement With Bios 44 And Newer
Evga X58 Native Powermanagement With Bios 44 And Newer270-WS-W555 DSDT native power management modifications

I tried everything mentioned in those threads, but nothing worked.No one ever seemed to come up with a solution.

This thread at InfiniteMac seems to be the most comprehensive, but in OP, it states:

You should make a note in the first post about speedstep not working on the [latest] X58 SLI3 or X58 FTW3, and how it only works on the other models if you use the bios version before version 44, which is of course SZ2Z. I


Since all those threads are over a year old, I was wondering if anyone else had managed to get this working since then.

Thanks guys!





Also tagged with one or more of these keywords: evga, x58, speedstep


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy