Jump to content

HP xw4400 Workstation + OS X Lion

xw4400 Lion 975X Broadcom BCM5755 Broadcom BCM5751 NVIDIA Quadro FX 1500 Realtek HD ALC260 Audio

  • Please log in to reply
7 replies to this topic

#1
justApple

justApple

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Gender:Male
HP xw4400 Workstation + OS X Lion 10.7

CONCLUSION: TOO HARD TO GET TO A STABLE SYSTEM FOR DAILY USE.

MAYBE ITS DIFFERENT FOR OS X 10.8.X AND HP XW4400. HAVE FUN AND GOOD LUCK!

#2
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,121 posts
  • Gender:Male
  • Location:Brazil
Because you should go to the TonyMac forums if you need help with TonyMac products.

#3
iawval

iawval

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
  • Gender:Male
  • Location:Waadt
hope you solved problems, if not, here what I did
had xw4400 fully working at first run, excluding graphics, she had a quadro3400, I knew this will never work in osx, so I got a gts210, to try, works perfectly chameleon GraphicsEnabler=Yes with double monitor 1920x1200 + 1600x1200, ok it's a 30$ card, but solves the problem.
I have a fx1500 perfectly working with leopard, so should work, needs some injector though, try different ones.

/System/Library/Extensions/BCM5722D.kext works perfectly, maybe you've got a hacked one
DSDT.aml goes nowhere with the Xw4400 & not needed, it's all calls to SSDT tables & external, you'll get lost, let it go.
Stay away from ######
update to 10.7.3 no problem
slow disk, very slow, this I'm trying to understand

#4
M43

M43

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hi,

this machine and the older Snow Leopard (10.6.8) it looks also fine.

The state w/ softwareupdate today:
  • xxxxx
    • graphic: video (youtube, etc.) + sound: ok w/ single monitor @ 2048x1024 (monitors limit...)
    • PS/2 keyboard + USB mouse (only @ upper front usb socket)
  • VoodooHDA 2.7.3
    • sound: back line out + mic: ok
  • BCM5722D.kext
    • onboard LAN: ok
  • I'm not very happy about:
    • lower front usb and back usb is not working. All tested USB fix versions didn't working. Any good ideas?


#5
Bunga

Bunga

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
  • Gender:Male
hi everyone.I try to install a osx lion 10.7.2 on this PC:

HP workstation xw-4400 whit this everest report:

Computer Type ACPI Multiprocessor PC
Operating System Microsoft Windows XP Professional
OS Service Pack Service Pack 3
Internet Explorer 7.0.5730.13 (IE 7.0)
DirectX 4.09.00.0904 (DirectX 9.0c)
Computer Name X-39F8C3915A614
User Name User
Logon Domain X-39F8C3915A614
Date / Time 2012-08-09 / 17:35

Motherboard:

CPU Type DualCore Intel Core 2 Duo E4300, 1800 MHz (9 x 200)
Motherboard Name Hewlett-Packard HP xw4400 Workstation
Motherboard Chipset Intel Glenwood-DG i975X
System Memory 3584 MB (DDR2-800 DDR2 SDRAM)
DIMM2: PNY Tech. 2 GB DDR2-800 DDR2 SDRAM (6-5-5-18 @ 400 MHz) (5-5-5-18 @
400 MHz) (4-4-4-12 @ 266 MHz)
DIMM4: PNY Tech. 2 GB DDR2-800 DDR2 SDRAM (6-5-5-18 @ 400 MHz) (5-5-5-18 @
400 MHz) (4-4-4-12 @ 266 MHz)
BIOS Type Compaq (10/28/10)
Communication Port Communications Port (COM1)
Communication Port ECP Printer Port (LPT1)
Display:

Video Adapter NVIDIA Quadro NVS 285 (128 MB)
Video Adapter Quadro NVS 285 (128 MB)
3D Accelerator nVIDIA Quadro NVS 285
Monitor Samsung SyncMaster 740BF/MagicSyncMaster CX702B/CX715B (Digital)
[17" LCD] (HVFL307860)

Multimedia:

Audio Adapter Realtek ALC262 @ Intel 82801GB ICH7 - High Definition Audio Controller
[A-1]
Storage:
IDE Controller Intel® 82801G (ICH7 Family) Ultra ATA Storage Controllers - 27DF
Storage Controller Intel® 82801GR/GH SATA RAID Controller
file:///H|/HP%20XW-4400%20WORKSTATION.txt[8/9/2012 5:56:56 PM]
Disk Drive ST3250823AS (250 GB, 7200 RPM, SATA)
Disk Drive UDISK PDU15_8G 77I2.0 USB Device (7 GB, USB)
Optical Drive ATAPI DVD D DH16DYP
SMART Hard Disks Status OK

Partitions:

C: (NTFS) 232.9 GB (228.6 GB free)
Total Size 232.9 GB (228.6 GB free)
Input:
Keyboard Standard 101/102-Key or Microsoft Natural PS/2 Keyboard
Mouse HID-compliant mouse
Mouse PS/2 Compatible Mouse

Network:

Primary IP Address 192.168.1.100
Primary MAC Address 00-02-72-93-4E-87
Network Adapter Broadcom NetXtreme Gigabit Ethernet
Network Adapter Realtek RTL8191SU Wireless LAN 802.11n USB 2.0 Network Adapter

So i first burn my lion L2 disc on mac with disc utility succesfully, then on the workstation boot order I select the DVD ROM, and everything it's loaded fine, untill the installation arrive at DiscUtility option, them from there I can't see the HDD. If somebody can give me a hand and help me with this issue taking by reference my evererest report i'll be appretiate a lot. Thanks in advance

#6
iawval

iawval

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
  • Gender:Male
  • Location:Waadt

hi everyone.I try to install a osx lion 10.7.2 on this PC:

HP workstation xw-4400 whit this everest report:

Updated the Xw4400 to Mountain Lion, everything works perfectly excluding sleep, needs cpu power management disabler, probably can be easily solved with some ssdt tampering but for the moment it isn't worth to.
If Os/x cannot see your disk, check in the bios what's the option set for SATA, if it's RAID, select 'separate IDE controller' instead

Yes, it's not mistyping, I'm speaking of a Xw4400, the Xw8400 in my signature is another system

#7
justApple

justApple

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
  • Gender:Male

Updated the Xw4400 to Mountain Lion, everything works perfectly excluding sleep, needs cpu power management disabler, probably can be easily solved with some ssdt tampering but for the moment it isn't worth to.
If Os/x cannot see your disk, check in the bios what's the option set for SATA, if it's RAID, select 'separate IDE controller' instead

Yes, it's not mistyping, I'm speaking of a Xw4400, the Xw8400 in my signature is another system



can you please detail your steps to get it working?

is the xw4400 and xw8400 the same family ? ie same mainboard? just different intel cpus?

example i read an hp kb "HP xw4400, xw4600, xw6400 or xw8400 Workstation - X may fail to start with Specific NVIDIA Quadro Graphics Cards and certain Red Hat Linux 32 bit versions"

#8
iawval

iawval

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
  • Gender:Male
  • Location:Waadt

can you please detail your steps to get it working?

is the xw4400 and xw8400 the same family ? ie same mainboard? just different intel cpus?

example i read an hp kb "HP xw4400, xw4600, xw6400 or xw8400 Workstation - X may fail to start with Specific NVIDIA Quadro Graphics Cards and certain Red Hat Linux 32 bit versions"

the XW4400 & the XW8400 are quite different, the first is an enhanced PC with a core duo duo, the 2nd is a dual xeon 5150 and needs only fakesmc to work perfectly, I've been playing with the Xw4400 today with mountain Lion, it isn't absolutely perfect as a mac pro as the Xw8400 is but works very well you only need:
fakesmc, nullcpupwermamegement, sleepenabler & a simply patched voodoohda for audio
no DSDT, no SSDT no tampering, nothing! all works perfectly well.
the Xw8400 is superbly stable, fast and reliable and doesn't even need nullcpupwermamegement, sleepenabler, the processor is seen as native
these machines are really different from assembled PC and quality nears that of apple.





Also tagged with one or more of these keywords: xw4400, Lion, 975X, Broadcom BCM5755, Broadcom BCM5751, NVIDIA Quadro FX 1500, Realtek HD ALC260 Audio


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy