Jump to content

OpenCL Nbody Simulation bench (works 10.9+)


  • Please log in to reply
81 replies to this topic

#41
shatterhenner

shatterhenner

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts
confirmed....not working!!!

#42
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,902 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Yep, that down worry and use other OpenCL Benchmarks like Luxmark 2.0 or OpenCL_OceanWave.

#43
surfcaster

surfcaster

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 517 posts
403 for 65xxx
10.7.4 Lion

#44
RobertX

RobertX

    Yosemite Sam

  • Members
  • PipPipPipPipPipPipPip
  • 572 posts
  • Gender:Not Telling
damn...found my problem...a bad edit in geforcegldriverbundle... fixed after reading this:
in 10.7.3 there is a change in the GeForceGLDriver... see below
From Netkas Thread:


Find
EB A8 83 F8 02 7C 15
replace 02 with 03 to get
EB A8 83 F8 03 7C 15

Find
78 E8 83 F8 02 7C 11
replace 02 with 03 to get
78 E8 83 F8 03 7C 11
i didn't do the edit in bold...(in HexEdit) :| ...seems all good now...my bad...( i only get 60-65 gigaflops with my GeForce GT 520)

#45
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,902 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Good to hear you get your fermi lowend GT 520 cardto work. 9600 GT gets 131 (10.7.3 and 10.7.4)
What result with Luxmark 2.0 in the small Luxball Scene ? i get around 740 (and 74 in the middle complex scene, 25 very complex scene)
http://www.luxrender...uxMark#Download

Oceanwave (attached) gets around 90 FPS. All results for Nvidia 9600 GT.

Fermi gpu type doesnt mean its always faster than the old non fermi types. For example the GTX 680 is great in OpenGL but very bad in OpenCL speed compared to GTX 580. GTX 680 plays in OpenCL region of GTX 460-GTX 470. Upcoming GTX 690 is much faster in OpenCL (ok, it has 2 OpenCL gpus on the card ;) )

Attached Files



#46
shatterhenner

shatterhenner

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts

damn...found my problem...a bad edit in geforcegldriverbundle... fixed after reading this:
in 10.7.3 there is a change in the GeForceGLDriver... see below
From Netkas Thread:


Find
EB A8 83 F8 02 7C 15
replace 02 with 03 to get
EB A8 83 F8 03 7C 15

Find
78 E8 83 F8 02 7C 11
replace 02 with 03 to get
78 E8 83 F8 03 7C 11
i didn't do the edit in bold...(in HexEdit) :| ...seems all good now...my bad...( i only get 60-65 gigaflops with my GeForce GT 520)



thanx for da headsup....wrong edit too!!!fixed

432 gflops...thanx guys

#47
sg

sg

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 738 posts
  • Gender:Male
10.8.2, Nvidia 670 GTX (EVGA non-OC), 940 Gigaflops in Galaxies.

#48
khe91

khe91

    InsanelyMac Protégé

  • Members
  • PipPip
  • 66 posts
  • Gender:Male
  • Location:Germany
10.8.2., NVidia 304.00.05f02 driver, Asus GTX670, 2560x1600, 918 Gigaflops in Galaxies

#49
stefano.85

stefano.85

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 232 posts
  • Gender:Male
  • Location:Italy
Attached File  Schermata 2012-12-04 alle 01.15.48.png   164.7KB   11 downloads

10.8.2 NVidia 304.00.05f02 driver, Asus GTX660ti, 1920x1200

#50
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,902 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Great to see 1K Gigaflop was reached.

#51
Wayang-NT

Wayang-NT

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 142 posts
  • Gender:Male
AMD6870 - OS X Mountain Lion build 12D32

Posted Image

#52
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,902 posts
  • Gender:Male
  • Location:Stuttgart / Germany
AMD 78/9XX will be the fastest OpenCL card in near future i think. At least from the HW speed it shoud be beat any Nvidia. Maybe AMD OpenCL framework/drivers are the bottleneck.

PS: Have you already tried new Furmark OpenGL Benchmark? Happy to see new results :)

http://www.insanelym...x/#entry1867811

#53
sea_man

sea_man

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Gender:Male
  • Location:Bogota D.C - Colombia
MSI 7970 10.8.3 beta !


edit: new bench whit browser closed:

Attached Files



#54
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,902 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Outstanding result!

#55
sea_man

sea_man

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Gender:Male
  • Location:Bogota D.C - Colombia
This mean can i have the pole position ? :superman:

:thumbsup_anim:

#56
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,902 posts
  • Gender:Male
  • Location:Stuttgart / Germany
YES - an i think for a long time (until other similar AMDs bench or Nvidia build new highend gpus next year)

#57
UNOE

UNOE

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
here is my go at it

Attached Files



#58
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff

This mean can i have the pole position ? :superman:

:thumbsup_anim:

Increase number of stars to max and probably can go even higher :)

#59
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,973 posts
  • Gender:Male
Is it an over clocked 7970, sea_man?

#60
UNOE

UNOE

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts
To answer that question for him Yes it was overclocked it had 1010mhz bios on that card. Mine is at 925mhz. I'm pretty sure this is the card he has, http://us.ncix.com/products/?sku=68758





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy