Jump to content

Any luck with 10.8 Mountain Lion DP 1 on VMware?


  • Please log in to reply
74 replies to this topic

#61
Konran Udo Gerber

Konran Udo Gerber

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
  • Gender:Male
  • Location:Troisdorf, DE

I made it! :happymac:

Install the following steps:

Created a Virtual Machine for Lion 10.7
Edited the .vmx file and set this: smc.present = "TRUE"

Once the installation is complete (Patience, each boot takes a long time):

Install FakeSMC.kext with Kext Wizard
Install darwin.iso of Unlocker 1.0.2
Install VMsvga2_v1.2.4_OS_10.6-7.pkg

Reset Virtual Machine and ready (Now the booting time normal as is in the Lion)

Thanks to all :thumbsup_anim:

Thanks lpsccs ... but did it really work for you w/out applying the VMware tools patch as seen on http://www.robservatory.com/?p=809?
I've mistakenly rebooted too quickly and kept the full install of darwin.iso and get these kernel panics with vmmemctl.

Edit:
For me it works with FakeSMC.kext 3.1.1, but I have to set smc.present = "FALSE" in the .vmx file. Otherwise I don't get mouse clicks and the keyboard working! I omitted the VMsvga2_v1.2.4_OS_10.6-7.pkg because it gave me a fixed screen resolution only.
The VMware tools from darwin.iso make the screen shrink or grow depending on normal view or fullscreen view. I like that more because otherwise the desktop gets screwed up on fixed resolution and switching from normal screen to fullscreen view.

#62
yozh

yozh

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 246 posts
DP3 Same procedure as 1 and 2, works better

#63
yozh

yozh

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 246 posts
FYI,

DP4 works same way

#64
Donk

Donk

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,974 posts
  • Gender:Male
  • Location:Manchester UK
Guys, just go and get the free Tech Preview of Workstation all works without any hacks.

#65
TechXero

TechXero

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
  • Gender:Male
  • Location:Beirut Lebanon
Just updated to Workstation v8.04 done everything right installed rebooted now as most of u here not booting stuck on famous boot n spinning wheel... Tried with smc.present = "TRUE" never booted ... smc.present = "FALSE" never booted xD

Am using DP2 while I wait for DP4 to finish downloading xD

EDIT : GOT IT WORKING !!!!!!

What I did was, once Installation done successfully, I shut it down, mounted the Mountain Lion DP2 VMDK into the Lion VM, copied over the FakeSMC.kext provided earlier to the Mountain Lion DP2 drive /S/L/E, fixed permissions still on lion, and for {censored} n giggles I added -v flag to see what's going on, n voila it booted in 2mins ...

Note : DO NOT install VMWare Tools it WILL cause a Kernel Panic !!!! Just do like I did, and add a separate partition/VMDK shared between Lion VM n Mountain Lion VM ...

Hope this helps anyone ;)

#66
yozh

yozh

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 246 posts
Got GM working. But iCloud is not working getting error: "Cannot Sign up This Apple ID is valid but is not an iCloud account"

Been searching and searching, seems to be something with the identifier or the serial number, but still havent found a way to change it. Any help would be appreciated.

BTW App Store is working .....

Also on my 10.7.4 VM iCloud works fine...

#67
Nemes

Nemes

    InsanelyMac Protégé

  • Members
  • PipPip
  • 54 posts
Seconding that 10.8 ML works just fine with the latest VMWare Tech Previews after the requisite unlocker patching. I haven't had a chance to try iCloud though, so I can't confirm what yozh is seeing.

#68
prophetizer

prophetizer

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Google applelsifusionmpt 3.0.0.pkg which is an installer that drops the kext in and does other necessary stuff. Apart from some apps crashing I now have a working system, including the vmware tools, video and sound driver, it boots in about two minutes.


googling that doesn't seem to return any relevant results, other than this thread

#69
yozh

yozh

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 246 posts
I`m referring to ESXi 5 515841 install. iCloud and iMessage does not work, tried multiple things to no luck.... in Workstation 8.04 iCloud works fine

#70
gfdos.sys

gfdos.sys

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
This is probably a donk question, and I know I am a lurker... but I've been installing osx on pcs since it required pearPC....

That said it is now noted at
http://www.robservatory.com/?p=809
that the problem no longer occurs in Fusion 4.1.2 or later -- so my question is, would using the vmware tools from Fusion 4.1.3 on VMWorkstaion 8.0.4 prevent the ugly kernel panic, or do we need donk to modify them in someway to accomplish this without "patching" method found at
http://www.robservatory.com/?p=809


That said, I am running Both Lion and Mountain Lion GM in VMWorkstaion 8.0.4 on Windows 8 Release Preview build 8400 on 3 monitors (Quadro FX 570 x2) on a Dell Precision T3400 with 8GB of ram....

Just want to be careful not to hose the Installation of Mountain Lion GM I have working :)

Thanks,
gfdos.sys

#71
szr

szr

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

Is there a way I can boot it in verbose mode so i can see what's going wrong possibly?

Just hold the Win (or command key, if you have a mac keyboard) + v, as soon as the gray VMware EFI screen comes up (make sure you click on the screen so it has focus), and after a few seconds you should see the background change to black. Keep holding win/command + v until you see OS X start booting verbosely, black background and all. Hope this helps.

#72
no1youknowz

no1youknowz

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts
Just out of interest, is anyone doing this under ubuntu/linux and workstation 8.0.4?

Is it working fine?

#73
slapkey

slapkey

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male
Has anyone experienced problems installing the VMWare tech preview (legit download from their website)? I'm getting MSI install errors when I try to install it...searching around the net reveals a number of people with the same problem, but the VMWare devs say it's a Windows issue and don't seem to want to go any further from their end...I previously had the last version of Workstation installed, and it won't successfully uninstall, either, citing MSI install errors.
Searching had me delete a million different things, attempt a few different cmd prompt install commands, all to no avail. Has anyone seen this issue and resolved it?

#74
elcomgeek

elcomgeek

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
Thanks me later!

http://www.ihackinto...lion-in-vmware/

#75
d00m

d00m

    InsanelyMac Protégé

  • Members
  • Pip
  • 12 posts

Thanks me later!

http://www.ihackinto...lion-in-vmware/


it is not working on ESXi 5.0.0 768111
ive created boot disk MLI as provided in this manual but it wont start installation - i get only grey screen with apple icon and rolling progressbar





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy