Jump to content

HWSensors

FakeSMC Plugins Hardware Monitoring Sensors SuperIO Temperature Voltage Tachometer Frequency

  • Please log in to reply
1029 replies to this topic

#601
tot318

tot318

    InsanelyMac Protégé

  • Members
  • PipPip
  • 81 posts

Please, try this version:


Still no dice and here is my kernel logs for v1.0.61

Spoiler


#602
kozlek

kozlek

    InsanelyMac Sage

  • Developers
  • 331 posts
  • Gender:Male
  • Location:Israel

Still no dice and here is my kernel logs for v1.0.61

Spoiler


Can't find what's the problem is. I can't test it on my hardware. Also I am not understand well I2C protocols so it's become very difficult to find what's wrong. So I decided to get back NVClockX plugin. Could you, please, test it with your hardware? As I remember It was working well on my GTX 260 two years ago. Deselect NouveauSensors in installer and select NVCLock. But before running installer delete NouveauSensors.kext from FakeSMC.kext plugins directory.

#603
kozlek

kozlek

    InsanelyMac Sage

  • Developers
  • 331 posts
  • Gender:Male
  • Location:Israel

There is no NVClock inside v1.0.61 package.


It's in the new package on GitHub

#604
tot318

tot318

    InsanelyMac Protégé

  • Members
  • PipPip
  • 81 posts

It's in the new package on GitHub

Ok I got it and installed it and still no GPU temp reading...Here is my kernel log

Spoiler


#605
kozlek

kozlek

    InsanelyMac Sage

  • Developers
  • 331 posts
  • Gender:Male
  • Location:Israel

Ok I got it and installed it and still no GPU temp reading...Here is my kernel log

Spoiler


Cool. It doesn't work at all. Seems I need to start porting NVClock into kernel extension from the scratch.

There is another project here: http://www.assembla....s/fakesmc/start. It's incompatible with project on GitHub so you must install corresponding kext and monitoring app from the same project or it will not work. You could give it a try.

#606
tot318

tot318

    InsanelyMac Protégé

  • Members
  • PipPip
  • 81 posts

Cool. It doesn't work at all. Seems I need to start porting NVClock into kernel extension from the scratch.

There is another project here: http://www.assembla....s/fakesmc/start. It's incompatible with project on GitHub so you must install corresponding kext and monitoring app from the same project or it will not work. You could give it a try.


I have tried that one ans it is the same can't get GPU temp too but even worse, not many things can be read, yours is the best. It's ok that I can get my GX260 temp readings, it an ancient card..

#607
PiSToLBR

PiSToLBR

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
  • Gender:Male
  • Location:Brazil - Recife - PE
Kozlek,

I downloaded the lastest versions form GitHub and used the installer.
The HWmonitor doesn't seens to work.

Here is what happens:

Attached File  hwmonitor.png   51.08KB   47 downloads


Thanks and keep the good work,

PiSToL

#608
kozlek

kozlek

    InsanelyMac Sage

  • Developers
  • 331 posts
  • Gender:Male
  • Location:Israel

Kozlek,

I downloaded the lastest versions form GitHub and used the installer.
The HWmonitor doesn't seens to work.

Here is what happens:

Attached File  hwmonitor.png   51.08KB   47 downloads


Thanks and keep the good work,

PiSToL


It's on Lion? Do you see something related to HWMonitor in Console?

#609
PiSToLBR

PiSToLBR

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
  • Gender:Male
  • Location:Brazil - Recife - PE
Lion

Here is what is shows



04/08/12 13:14:48,722 HWMonitor: unlockFocus called too many time.
04/08/12 13:14:48,722 HWMonitor: unlockFocus called too many time.
04/08/12 13:14:48,723 HWMonitor: Unlocking Focus on wrong view (<NSMatrix: 0x10014b8f0>), expected <NSView: 0x1001618d0>
04/08/12 13:14:48,725 HWMonitor: (
0 CoreFoundation 0x00007fff86faff56 __exceptionPreprocess + 198
1 libobjc.A.dylib 0x00007fff8a6e6d5e objc_exception_throw + 43
2 CoreFoundation 0x00007fff86fafd8a +[NSException raise:format:arguments:] + 106
3 CoreFoundation 0x00007fff86fafd14 +[NSException raise:format:] + 116
4 AppKit 0x00007fff8abdab6c -[NSFocusStack unfocusView:] + 194
5 AppKit 0x00007fff8abdaa29 -[NSView unlockFocus] + 215
6 AppKit 0x00007fff8b0138ad -[NSMatrix drawRect:] + 262
7 AppKit 0x00007fff8ad597a9 -[NSView(NSInternal) _recursive:displayRectIgnoringOpacity:inContext:topView:] + 1435
8 AppKit 0x00007fff8ad59b53 -[NSView(NSInternal) _recursive:displayRectIgnoringOpacity:inContext:topView:] + 2373
9 AppKit 0x00007fff8ad58eaa -[NSView displayRectIgnoringOpacity:inContext:] + 452
10 AppKit 0x00007fff8ad58bff -[NSView cacheDisplayInRect:toBitmapImageRep:] + 287
11 AppKit 0x00007fff8ae019bc -[NSView _drawView:] + 500
12 AppKit 0x00007fff8ac05a36 -[NSView _recursiveDisplayAllDirtyWithLockFocus:visRect:] + 1302
13 AppKit 0x00007fff8abd5f55 -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:] + 1032
14 AppKit 0x00007fff8abd720a -[NSView _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:] + 5821
15 AppKit 0x00007fff8abd544f -[NSThemeFrame _recursiveDisplayRectIfNeededIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:topView:] + 270
16 AppKit 0x00007fff8abd086f -[NSView _displayRectIgnoringOpacity:isVisibleRect:rectIsVisibleRectForView:] + 4755
17 AppKit 0x00007fff8abc92ed -[NSView displayIfNeeded] + 1676
18 AppKit 0x00007fff8abc509a -[NSAnimationManager animationTimerFired:] + 2593
19 Foundation 0x00007fff8ce8cf40 __NSFireTimer + 102
20 CoreFoundation 0x00007fff86f64934 __CFRUNLOOP_IS_CALLING_OUT_TO_A_TIMER_CALLBACK_FUNCTION__ + 20
21 CoreFoundation 0x00007fff86f64486 __CFRunLoopDoTimer + 534
22 CoreFoundation 0x00007fff86f44e11 __CFRunLoopRun + 1617
23 CoreFoundation 0x00007fff86f44486 CFRunLoopRunSpecific + 230
24 HIToolbox 0x00007fff84a494d3 RunCurrentEventLoopInMode + 277
25 HIToolbox 0x00007fff84a50781 ReceiveNextEventCommon + 355
26 HIToolbox 0x00007fff84a5060e BlockUntilNextEventMatchingListInMode + 62
27 AppKit 0x00007fff8ab8ce31 _DPSNextEvent + 659
28 AppKit 0x00007fff8ab8c735 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 135
29 AppKit 0x00007fff8ab89071 -[NSApplication run] + 470
30 AppKit 0x00007fff8ae05244 NSApplicationMain + 867
31 HWMonitor 0x000000010000b3d2 main + 34
32 HWMonitor 0x0000000100001584 start + 52
33 ??? 0x0000000000000002 0x0 + 23
)



Kozlek, just downloaded latest build.

HWmonitor is working again. Thank you so much for this great app. It looks awesome now, congratulations.
PiSToL

#610
kozlek

kozlek

    InsanelyMac Sage

  • Developers
  • 331 posts
  • Gender:Male
  • Location:Israel

I have tried that one ans it is the same can't get GPU temp too but even worse, not many things can be read, yours is the best. It's ok that I can get my GX260 temp readings, it an ancient card..


It was working on my older system but something changed after and now it doesn't. I'll keep trying to fix it but it'll take a time. Maybe I'll get back my gtx260 for testing.

#611
RN95

RN95

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 147 posts

It's on Lion? Do you see something related to HWMonitor in Console?


I raised that but you ignored it. It's on Lion,

It worked up to version 1.0.50

Edit: Is it OK to use this earlier version with the latest Kexts ?

#612
tot318

tot318

    InsanelyMac Protégé

  • Members
  • PipPip
  • 81 posts

It was working on my older system but something changed after and now it doesn't. I'll keep trying to fix it but it'll take a time. Maybe I'll get back my gtx260 for testing.

That would be great, no rush here just take your time....

#613
kozlek

kozlek

    InsanelyMac Sage

  • Developers
  • 331 posts
  • Gender:Male
  • Location:Israel

I raised that but you ignored it. It's on Lion,

It worked up to version 1.0.50

Edit: Is it OK to use this earlier version with the latest Kexts ?


Try latest rev. it should be ok now.

#614
RN95

RN95

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 147 posts

Try latest rev. it should be ok now.


Thanks Kozlek.
I can confirm that 1.0.63 (2.3.5) is working on LION 10.7.4.

Cheers

#615
scorcho

scorcho

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
A new problem emerges, though! On my 10.8 install with a Gigabyte P67A-UD4-B3 motherboard, the latest HWSensors build only shows HDD temps. I had to roll back to your August 3 build to regain all sensor readings again for my system.

Also, a curious issue on my Mountain Lion install. Whenever I install a new version of the HWSensor application, unless I completely deactivate Gatekeeper the system will complain that the application is corrupted and cannot be launched. Right-clicking and selecting Open doesn't override this dialoag.

Once it launches the first time, I can then go back to re-enable Gatekeeper on its second setting (MAS and identified developers). Your app will continue to launch and quit as it should.

#616
kozlek

kozlek

    InsanelyMac Sage

  • Developers
  • 331 posts
  • Gender:Male
  • Location:Israel

A new problem emerges, though! On my 10.8 install with a Gigabyte P67A-UD4-B3 motherboard, the latest HWSensors build only shows HDD temps. I had to roll back to your August 3 build to regain all sensor readings again for my system.

Also, a curious issue on my Mountain Lion install. Whenever I install a new version of the HWSensor application, unless I completely deactivate Gatekeeper the system will complain that the application is corrupted and cannot be launched. Right-clicking and selecting Open doesn't override this dialoag.

Once it launches the first time, I can then go back to re-enable Gatekeeper on its second setting (MAS and identified developers). Your app will continue to launch and quit as it should.


Do you use Extra folder for FakeSMC?


#617
scorcho

scorcho

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts

Do you use Extra folder for FakeSMC?

Yes I do. Will future versions of your extension work best from S/L/E now?

#618
kozlek

kozlek

    InsanelyMac Sage

  • Developers
  • 331 posts
  • Gender:Male
  • Location:Israel

Yes I do. Will future versions of your extension work best from S/L/E now?


Everything works best from kernel cache. But if it also works well from E/E why not? I'll fix it in the next rev.

#619
scorcho

scorcho

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 110 posts
Many thanks, Kozlek. You have my sincerest appreciation for your selfless work on this project! Do you accept Paypal donations?

#620
kozlek

kozlek

    InsanelyMac Sage

  • Developers
  • 331 posts
  • Gender:Male
  • Location:Israel

Many thanks, Kozlek. You have my sincerest appreciation for your selfless work on this project! Do you accept Paypal donations?


Thank you for you support. But I can't get donations for work of so many people who participated in project. It's hackintosh community's project so keep it 100% free





Also tagged with one or more of these keywords: FakeSMC, Plugins, Hardware Monitoring, Sensors, SuperIO, Temperature, Voltage, Tachometer, Frequency


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy